aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-05-20 16:23:31 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-05-20 16:23:31 +0200
commit01fa805758aa3e5e7837901dba0c046da8094186 (patch)
tree56506995ceec3fbc6028f76312d0d9b5947b6aed
parentsci-libs/arrayfire: Update dependencies, boost-compute is shipped with boost-... (diff)
downloadsci-01fa805758aa3e5e7837901dba0c046da8094186.tar.gz
sci-01fa805758aa3e5e7837901dba0c046da8094186.tar.bz2
sci-01fa805758aa3e5e7837901dba0c046da8094186.zip
dev-python/nbdime: New package, ebuild wirtten by me
Package-Manager: portage-2.2.28
-rw-r--r--dev-python/nbdime/metadata.xml14
-rw-r--r--dev-python/nbdime/nbdime-9999.ebuild38
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/nbdime/metadata.xml b/dev-python/nbdime/metadata.xml
new file mode 100644
index 000000000..979d02bd0
--- /dev/null
+++ b/dev-python/nbdime/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ nbdime contains tools for diffing and merging of Jupyter Notebooks.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jupyter/nbdime</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nbdime/nbdime-9999.ebuild b/dev-python/nbdime/nbdime-9999.ebuild
new file mode 100644
index 000000000..8be6e65d3
--- /dev/null
+++ b/dev-python/nbdime/nbdime-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Diff and merge of Jupyter Notebooks"
+HOMEPAGE="http://jupyter.org"
+EGIT_REPO_URI="https://github.com/jupyter/${PN}.git"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ "
+# Some additional packages (e.g. commonmark, recommonmark) are required to build the docs
+# Furthermore, backports.shutil_which is required for python2_7.
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ cp -r "${S}/${PN}"/tests "${TEST_DIR}"/lib/ || die
+ py.test -l || die
+}