aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin <jlec@gentoo.org>2014-07-07 08:35:43 +0200
committerJustin <jlec@gentoo.org>2014-07-07 08:35:43 +0200
commit0db28ec6a3046b2a46e1a7fa9ced8933050ee34e (patch)
tree92263778d30762a20a86116085c095ceab3ec76b
parentNnot available anymore (diff)
parentdev-python/bokeh: dev-python/bokeh: New version with python3 support for bug ... (diff)
downloadsci-0db28ec6a3046b2a46e1a7fa9ced8933050ee34e.tar.gz
sci-0db28ec6a3046b2a46e1a7fa9ced8933050ee34e.tar.bz2
sci-0db28ec6a3046b2a46e1a7fa9ced8933050ee34e.zip
Merge pull request #237 from aufau/bokeh
dev-python/bokeh (in the main tree): Fix bug #516052
-rw-r--r--dev-python/bokeh/ChangeLog11
-rw-r--r--dev-python/bokeh/Manifest1
-rw-r--r--dev-python/bokeh/bokeh-0.4.4.ebuild98
-rw-r--r--dev-python/bokeh/files/bokeh-0.4.4-fix_test_object.patch32
-rw-r--r--dev-python/bokeh/metadata.xml15
5 files changed, 157 insertions, 0 deletions
diff --git a/dev-python/bokeh/ChangeLog b/dev-python/bokeh/ChangeLog
new file mode 100644
index 000000000..0dac60237
--- /dev/null
+++ b/dev-python/bokeh/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/bokeh
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*bokeh-0.4.4 (07 Jul 2014)
+
+ 07 Jul 2014; Witold Pilat (fau) <witold.pilat@gmail.com> +bokeh-0.4.4.ebuild,
+ +files/bokeh-0.4.4-fix_test_object.patch, -ChangeLog, -Manifest,
+ -bokeh-0.4.2.ebuild, metadata.xml:
+ dev-python/bokeh: dev-python/bokeh: New version with python3 support for bug
+ #516052
diff --git a/dev-python/bokeh/Manifest b/dev-python/bokeh/Manifest
new file mode 100644
index 000000000..2c752eaeb
--- /dev/null
+++ b/dev-python/bokeh/Manifest
@@ -0,0 +1 @@
+DIST bokeh-0.4.4.tar.gz 40315677 SHA256 ca989c9d554d07bface516ad9eccda39cf999c244c85ca52881b10fea0466417 SHA512 46dfe615a53996158b9e17e1f5cb46b401d017e18638457905f283cb3bb1d734207b370f3b3d78850e8e75ccfbe47736beba8b5730296f5db2677d5eb92423e9 WHIRLPOOL b0c56b43091d171b7b85ccec66f0986bf747479f8fbb20a4758a9e788533f34578c5ce6f87f704c34e27030a58890733003bee23ad85d9cf6ac8a68e6d80bf2c
diff --git a/dev-python/bokeh/bokeh-0.4.4.ebuild b/dev-python/bokeh/bokeh-0.4.4.ebuild
new file mode 100644
index 000000000..22d38c588
--- /dev/null
+++ b/dev-python/bokeh/bokeh-0.4.4.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Statistical and interactive HTML plots for Python"
+HOMEPAGE="http://bokeh.pydata.org/"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test chaco"
+# docs require napoleon sphinx extension which will be included in next sphinx release
+
+RDEPEND="
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-0.23[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-0.18[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ >=dev-python/pystache-0.5.3[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013b[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-2.7.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.9.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/gevent-1.0[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep '>=dev-python/gevent-websocket-0.9.2[${PYTHON_USEDEP}]' python2_7)
+ chaco? (
+ $(python_gen_cond_dep '>=dev-python/traits-4.4[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep '>=dev-python/chaco-4.4[${PYTHON_USEDEP}]' python2_7)
+ )
+
+"
+# testing server: needs websocket not in portage yet
+# >=dev-python/websocket[${PYTHON_USEDEP}]
+# hdf5 backend: needs arraymanagement not in portage yet
+DEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.2.7[${PYTHON_USEDEP}]
+ )
+"
+DOCS=( CHANGELOG QUICKSTART.md README.md )
+
+python_prepare_all() {
+ # Fix test_references_by_ref_by_value from test_object.py
+ local PATCHES=( "${FILESDIR}"/${P}-fix_test_object.patch )
+ # Remove broken test case
+ sed -i -e "s:MetaTest:_&:" bokeh/tests/test_bokeh_init.py || die
+
+ if ! use chaco; then
+ sed -i -e "/'bokeh.chaco_gg'/d" setup.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ # exclude server tests for now
+ nosetests -v \
+ -e multiuser_auth_test \
+ -e usermodel_test \
+ || die
+}
+
+pkg_postinst() {
+ elog "websockets work only with python2_7"
+ local chaco_msg="chaco useflag doesn't affect python targets other than python2_7"
+ if use chaco; then
+ if use python_targets_python2_7; then
+ elog "${chaco_msg}"
+ else
+ ewarn "${chaco_msg}"
+ fi
+ fi
+}
diff --git a/dev-python/bokeh/files/bokeh-0.4.4-fix_test_object.patch b/dev-python/bokeh/files/bokeh-0.4.4-fix_test_object.patch
new file mode 100644
index 000000000..24183d831
--- /dev/null
+++ b/dev-python/bokeh/files/bokeh-0.4.4-fix_test_object.patch
@@ -0,0 +1,32 @@
+commit 9606ae037dbd9ee888f9763a1bd9c6d7fc3b5824
+Author: Bryan Van de Ven <bryanv@continuum.io>
+Date: Sat Apr 19 10:05:35 2014 -0500
+
+ fix #548
+
+diff --git a/bokeh/plotobject.py b/bokeh/plotobject.py
+index 7485d27..92ae2dd 100644
+--- a/bokeh/plotobject.py
++++ b/bokeh/plotobject.py
+@@ -220,7 +220,7 @@ class PlotObject(HasProps):
+
+ def references(self):
+ """Returns all ``PlotObjects`` that this object has references to. """
+- return self.collect_plot_objects(self)
++ return set(self.collect_plot_objects(self))
+
+ #---------------------------------------------------------------------
+ # View Model connection methods
+diff --git a/bokeh/tests/test_objects.py b/bokeh/tests/test_objects.py
+index 1a17f69..75d5678 100644
+--- a/bokeh/tests/test_objects.py
++++ b/bokeh/tests/test_objects.py
+@@ -242,7 +242,7 @@ class TestPlotObject(unittest.TestCase):
+ x2 = X2(y=y, z2=z2)
+
+ # TODO: self.assertEqual(x1.references(), [t1, y, t2, x1])
+- self.assertEqual(x2.references(), [t1, y, t2, z2, x2])
++ self.assertEqual(x2.references(), set([t1, y, t2, z2, x2]))
+
+ if __name__ == "__main__":
+ unittest.main()
diff --git a/dev-python/bokeh/metadata.xml b/dev-python/bokeh/metadata.xml
new file mode 100644
index 000000000..b59e358e7
--- /dev/null
+++ b/dev-python/bokeh/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Bokeh is a Python interactive visualization library for large
+ datasets that natively uses the latest web technologies. Its goal is
+ to provide elegant, concise construction of novel graphics in the
+ style of Protovis/D3, while delivering high-performance
+ interactivity over large data to thin clients.
+</longdescription>
+<use>
+ <flag name="chaco">Enable interface for implementing qplot and ggplot like functionality using chaco</flag>
+</use>
+</pkgmetadata>