aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-23 14:16:09 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-23 14:16:09 +0200
commit0ef7a20428a2e35099ccc13bd68a22abd13ad755 (patch)
tree1007cc959a22ae32c009842b86540782467c88aa
parentsci-physics/abinit: Use default functions (diff)
downloadsci-0ef7a20428a2e35099ccc13bd68a22abd13ad755.tar.gz
sci-0ef7a20428a2e35099ccc13bd68a22abd13ad755.tar.bz2
sci-0ef7a20428a2e35099ccc13bd68a22abd13ad755.zip
sci-astronomy/lephare: Bump to EAPI=5
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-astronomy/lephare/lephare-2.2.ebuild14
-rw-r--r--sci-astronomy/lephare/metadata.xml4
2 files changed, 8 insertions, 10 deletions
diff --git a/sci-astronomy/lephare/lephare-2.2.ebuild b/sci-astronomy/lephare/lephare-2.2.ebuild
index 5834609c8..4d047340a 100644
--- a/sci-astronomy/lephare/lephare-2.2.ebuild
+++ b/sci-astronomy/lephare/lephare-2.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
+
inherit eutils check-reqs fortran-2 versionator
MYP=${PN}_dev_v$(replace_version_separator 2 '')
@@ -16,9 +17,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc"
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
S="${WORKDIR}/${PN}_dev/source"
CHECKREQS_DISK_BUILD="400M"
@@ -26,14 +24,14 @@ CHECKREQS_DISK_BUILD="400M"
src_prepare() {
export LEPHAREDIR="${WORKDIR}/${PN}_dev" LEPHAREWORK="${WORKDIR}"
# clean up mac left over crap
- find . -name ._\* -delete
+ find . -name ._\* -delete || die
# respect user flags and compiler
sed -i -e '/^FC/d' -e '/^FFLAGS/d' Makefile || die
}
src_test() {
# from pdf manual
- cd ${LEPHAREDIR}/test
+ cd ${LEPHAREDIR}/test || die
${LEPHAREDIR}/source/sedtolib -t S -c ../config/zphot.para || die
${LEPHAREDIR}/source/sedtolib -t Q -c ../config/zphot.para || die
${LEPHAREDIR}/source/sedtolib -t G -c ../config/zphot.para || die
@@ -57,7 +55,7 @@ src_install() {
mag_zform
dodoc README_TECH
insinto /usr/share/${PN}
- cd ..
+ cd .. || die
doins -r {ext,filt,config,opa,sed,simul,test,tools,vega}
echo "LEPHAREDIR=${EPREFIX}/usr/share/${PN}" > 99lephare
doenvd 99lephare
diff --git a/sci-astronomy/lephare/metadata.xml b/sci-astronomy/lephare/metadata.xml
index e68e8f647..665c2abc4 100644
--- a/sci-astronomy/lephare/metadata.xml
+++ b/sci-astronomy/lephare/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-astronomy</herd>
-<longdescription lang="en">
+ <herd>sci-astronomy</herd>
+ <longdescription lang="en">
Le Photometric Analysis for Redshift Estimate is a set of commands
to compute photometric redshifts and to perform SED fitting.
</longdescription>