aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-05-19 09:12:35 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2016-05-19 09:12:35 +0200
commit1139d2d3e3dd50668e12f74f87c406a33cfb5f1c (patch)
tree0f0080200538f7d1186be187908d44721e953996
parentsci-libs/arrayfire: Version bump to 3.2.2 (diff)
downloadsci-1139d2d3e3dd50668e12f74f87c406a33cfb5f1c.tar.gz
sci-1139d2d3e3dd50668e12f74f87c406a33cfb5f1c.tar.bz2
sci-1139d2d3e3dd50668e12f74f87c406a33cfb5f1c.zip
sci-libs/arrayfire: Bump to EAPI=6
Package-Manager: portage-2.2.28
-rw-r--r--sci-libs/arrayfire/arrayfire-3.1.3-r1.ebuild28
-rw-r--r--sci-libs/arrayfire/arrayfire-3.2.2.ebuild28
-rw-r--r--sci-libs/arrayfire/arrayfire-3.3.2.ebuild28
-rw-r--r--sci-libs/arrayfire/arrayfire-9999.ebuild32
4 files changed, 58 insertions, 58 deletions
diff --git a/sci-libs/arrayfire/arrayfire-3.1.3-r1.ebuild b/sci-libs/arrayfire/arrayfire-3.1.3-r1.ebuild
index 3b3591b34..12f6fcfd0 100644
--- a/sci-libs/arrayfire/arrayfire-3.1.3-r1.ebuild
+++ b/sci-libs/arrayfire/arrayfire-3.1.3-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit cmake-utils multilib
@@ -85,18 +85,18 @@ src_configure() {
fi
local mycmakeargs=(
- $(cmake-utils_use_build cpu CPU)
- $(cmake-utils_use_build cuda CUDA)
- $(cmake-utils_use_build opencl OPENCL)
- $(cmake-utils_use_build examples EXAMPLES)
- $(cmake-utils_use_build test TEST)
- $(cmake-utils_use_build graphics GRAPHICS)
- $(cmake-utils_use_build nonfree NONFREE)
- -DUSE_SYSTEM_BOOST_COMPUTE=ON
- -DUSE_SYSTEM_CLBLAS=ON
- -DUSE_SYSTEM_CLFFT=ON
- -DUSE_SYSTEM_FORGE=ON
- -DAF_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/ArrayFire
+ -DBUILD_CPU="$(usex cpu)"
+ -DBUILD_CUDA="$(usex cuda)"
+ -DBUILD_OPENCL="$(usex opencl)"
+ -DBUILD_EXAMPLES="$(usex examples)"
+ -DBUILD_TEST="$(usex test)"
+ -DBUILD_GRAPHICS="$(usex graphics)"
+ -DBUILD_NONFREE="$(usex nonfree)"
+ -DUSE_SYSTEM_BOOST_COMPUTE=ON
+ -DUSE_SYSTEM_CLBLAS=ON
+ -DUSE_SYSTEM_CLFFT=ON
+ -DUSE_SYSTEM_FORGE=ON
+ -DAF_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/ArrayFire
)
cmake-utils_src_configure
}
diff --git a/sci-libs/arrayfire/arrayfire-3.2.2.ebuild b/sci-libs/arrayfire/arrayfire-3.2.2.ebuild
index b92c6623f..aa766c93c 100644
--- a/sci-libs/arrayfire/arrayfire-3.2.2.ebuild
+++ b/sci-libs/arrayfire/arrayfire-3.2.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit cmake-utils multilib
@@ -85,19 +85,19 @@ src_configure() {
fi
local mycmakeargs=(
- $(cmake-utils_use_build cpu CPU)
- $(cmake-utils_use_build cuda CUDA)
- $(cmake-utils_use_build opencl OPENCL)
- $(cmake-utils_use_build examples EXAMPLES)
- $(cmake-utils_use_build test TEST)
- $(cmake-utils_use_build graphics GRAPHICS)
- $(cmake-utils_use_build nonfree NONFREE)
- $(cmake-utils_use_build unified UNIFIED)
- -DUSE_SYSTEM_BOOST_COMPUTE=ON
- -DUSE_SYSTEM_CLBLAS=ON
- -DUSE_SYSTEM_CLFFT=ON
- -DUSE_SYSTEM_FORGE=ON
- -DAF_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/ArrayFire
+ -DBUILD_CPU="$(usex cpu)"
+ -DBUILD_CUDA="$(usex cuda)"
+ -DBUILD_OPENCL="$(usex opencl)"
+ -DBUILD_EXAMPLES="$(usex examples)"
+ -DBUILD_TEST="$(usex test)"
+ -DBUILD_GRAPHICS="$(usex graphics)"
+ -DBUILD_NONFREE="$(usex nonfree)"
+ -DBUILD_UNIFIED="$(usex unified)"
+ -DUSE_SYSTEM_BOOST_COMPUTE=ON
+ -DUSE_SYSTEM_CLBLAS=ON
+ -DUSE_SYSTEM_CLFFT=ON
+ -DUSE_SYSTEM_FORGE=ON
+ -DAF_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/ArrayFire
)
cmake-utils_src_configure
}
diff --git a/sci-libs/arrayfire/arrayfire-3.3.2.ebuild b/sci-libs/arrayfire/arrayfire-3.3.2.ebuild
index 22b96bdcd..78c0ecc58 100644
--- a/sci-libs/arrayfire/arrayfire-3.3.2.ebuild
+++ b/sci-libs/arrayfire/arrayfire-3.3.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit cmake-utils multilib
@@ -87,19 +87,19 @@ src_configure() {
fi
local mycmakeargs=(
- $(cmake-utils_use_build cpu CPU)
- $(cmake-utils_use_build cuda CUDA)
- $(cmake-utils_use_build opencl OPENCL)
- $(cmake-utils_use_build examples EXAMPLES)
- $(cmake-utils_use_build test TEST)
- $(cmake-utils_use_build graphics GRAPHICS)
- $(cmake-utils_use_build nonfree NONFREE)
- $(cmake-utils_use_build unified UNIFIED)
- -DUSE_SYSTEM_BOOST_COMPUTE=ON
- -DUSE_SYSTEM_CLBLAS=ON
- -DUSE_SYSTEM_CLFFT=ON
- -DUSE_SYSTEM_FORGE=ON
- -DAF_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/ArrayFire
+ -DBUILD_CPU="$(usex cpu)"
+ -DBUILD_CUDA="$(usex cuda)"
+ -DBUILD_OPENCL="$(usex opencl)"
+ -DBUILD_EXAMPLES="$(usex examples)"
+ -DBUILD_TEST="$(usex test)"
+ -DBUILD_GRAPHICS="$(usex graphics)"
+ -DBUILD_NONFREE="$(usex nonfree)"
+ -DBUILD_UNIFIED="$(usex unified)"
+ -DUSE_SYSTEM_BOOST_COMPUTE=ON
+ -DUSE_SYSTEM_CLBLAS=ON
+ -DUSE_SYSTEM_CLFFT=ON
+ -DUSE_SYSTEM_FORGE=ON
+ -DAF_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/ArrayFire
)
cmake-utils_src_configure
}
diff --git a/sci-libs/arrayfire/arrayfire-9999.ebuild b/sci-libs/arrayfire/arrayfire-9999.ebuild
index a4b1d90d1..b0494ea35 100644
--- a/sci-libs/arrayfire/arrayfire-9999.ebuild
+++ b/sci-libs/arrayfire/arrayfire-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit cmake-utils git-r3 multilib
@@ -44,7 +44,7 @@ RDEPEND="
graphics? (
media-libs/glew
>=media-libs/glfw-3.1.1
- >=sci-visualization/forge-3.1
+ =sci-visualization/forge-3.2.2
)"
DEPEND="${RDEPEND}"
@@ -86,19 +86,19 @@ src_configure() {
fi
local mycmakeargs=(
- $(cmake-utils_use_build cpu CPU)
- $(cmake-utils_use_build cuda CUDA)
- $(cmake-utils_use_build opencl OPENCL)
- $(cmake-utils_use_build examples EXAMPLES)
- $(cmake-utils_use_build test TEST)
- $(cmake-utils_use_build graphics GRAPHICS)
- $(cmake-utils_use_build nonfree NONFREE)
- $(cmake-utils_use_build unified UNIFIED)
- -DUSE_SYSTEM_BOOST_COMPUTE=ON
- -DUSE_SYSTEM_CLBLAS=ON
- -DUSE_SYSTEM_CLFFT=ON
- -DUSE_SYSTEM_FORGE=ON
- -DAF_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/ArrayFire
+ -DBUILD_CPU="$(usex cpu)"
+ -DBUILD_CUDA="$(usex cuda)"
+ -DBUILD_OPENCL="$(usex opencl)"
+ -DBUILD_EXAMPLES="$(usex examples)"
+ -DBUILD_TEST="$(usex test)"
+ -DBUILD_GRAPHICS="$(usex graphics)"
+ -DBUILD_NONFREE="$(usex nonfree)"
+ -DBUILD_UNIFIED="$(usex unified)"
+ -DUSE_SYSTEM_BOOST_COMPUTE=ON
+ -DUSE_SYSTEM_CLBLAS=ON
+ -DUSE_SYSTEM_CLFFT=ON
+ -DUSE_SYSTEM_FORGE=ON
+ -DAF_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/ArrayFire
)
cmake-utils_src_configure
}