aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@kyomu.43-1.org>2014-07-25 01:07:07 +0200
committerMatthias Maier <tamiko@kyomu.43-1.org>2014-07-25 01:07:07 +0200
commit12e974f004f7e7305377f53eaca21666c616f506 (patch)
treee9688a30d392a5a91b3f7122a9493012ec5affc3
parentMerge github.com:gentoo-science/sci (diff)
downloadsci-12e974f004f7e7305377f53eaca21666c616f506.tar.gz
sci-12e974f004f7e7305377f53eaca21666c616f506.tar.bz2
sci-12e974f004f7e7305377f53eaca21666c616f506.zip
Update repository to github, fix readme file change, add forgotten use-flag to metadata.xml, fix tabstops
Package-Manager: portage-2.2.8-r1
-rw-r--r--sci-libs/dealii/ChangeLog6
-rw-r--r--sci-libs/dealii/dealii-9999.ebuild11
-rw-r--r--sci-libs/dealii/metadata.xml58
3 files changed, 39 insertions, 36 deletions
diff --git a/sci-libs/dealii/ChangeLog b/sci-libs/dealii/ChangeLog
index 267da7ecf..edd11d137 100644
--- a/sci-libs/dealii/ChangeLog
+++ b/sci-libs/dealii/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 24 Jul 2014; Matthias Maier <tamiko@gentoo.org> dealii-9999.ebuild,
+ metadata.xml:
+ Update repository to github, fix readme file change, add forgotten use-flag to
+ metadata.xml, fix tabstops
+
02 Mar 2014; Matthias Maier <tamiko+GENTOO@kyomu.43-1.org>
dealii-9999.ebuild:
Add use flag muparser and c++11 to reflect latest live build changes.
@@ -15,4 +20,3 @@
metadata.xml:
Add missing die; shorten DESCRIPTION; add dummy locel USE description; Fix
RDEPEND.suspect
-
diff --git a/sci-libs/dealii/dealii-9999.ebuild b/sci-libs/dealii/dealii-9999.ebuild
index 1d8b7ad02..30f3b70a8 100644
--- a/sci-libs/dealii/dealii-9999.ebuild
+++ b/sci-libs/dealii/dealii-9999.ebuild
@@ -4,13 +4,12 @@
EAPI=5
-inherit cmake-utils eutils multilib subversion
+inherit cmake-utils eutils multilib git-r3
DESCRIPTION="Solving partial differential equations with the finite element method"
HOMEPAGE="http://www.dealii.org/"
-ESVN_REPO_URI="https://svn.dealii.org/trunk/deal.II"
-ESVN_OPTIONS="--trust-server-cert --non-interactive"
+EGIT_REPO_URI="git://github.com/dealii/dealii.git"
KEYWORDS=""
LICENSE="LGPL-2.1+"
@@ -55,8 +54,6 @@ DEPEND="
src_configure() {
- subversion_wc_info
-
if use debug; then
CMAKE_BUILD_TYPE="DebugRelease"
else
@@ -64,7 +61,7 @@ src_configure() {
fi
local mycmakeargs=(
- -DDEAL_II_PACKAGE_VERSION=99.99.svn${ESVN_WC_REVISION}
+ -DDEAL_II_PACKAGE_VERSION=99.99
-DDEAL_II_ALLOW_AUTODETECTION=OFF
-DDEAL_II_ALLOW_BUNDLED=OFF
-DDEAL_II_ALLOW_PLATFORM_INTROSPECTION=OFF
@@ -103,7 +100,7 @@ src_configure() {
}
src_install() {
- DOCS=( README )
+ DOCS=( README.md )
cmake-utils_src_install
diff --git a/sci-libs/dealii/metadata.xml b/sci-libs/dealii/metadata.xml
index bb3333845..6f21d087d 100644
--- a/sci-libs/dealii/metadata.xml
+++ b/sci-libs/dealii/metadata.xml
@@ -1,32 +1,34 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <maintainer>
- <email>tamiko+GENTOO@kyomu.43-1.org</email>
- <name>Matthias Maier</name>
- </maintainer>
- <longdescription lang="en">
- deal.II is a C++ program library targeted at the computational solution
- of partial differential equations using adaptive finite elements. It uses
- state-of-the-art programming techniques to offer you a modern interface
- to the complex data structures and algorithms required.
-</longdescription>
- <use>
- <flag name="arpack">Adds support for ARPACK (<pkg>sci-libs/arpack</pkg>)</flag>
- <flag name="avx">Use Advanced Vector Extensions for AVX capable chips</flag>
- <flag name="debug">
- Build an additional debug library with extra debug codepaths, like asserts
- and extra output. If you want to get meaningful backtraces see
- &lt;http://www.gentoo.org/proj/en/qa/backtraces.xml&gt;</flag>
- <flag name="mesh_converter">Build and install the mesh_converter executable</flag>
- <flag name="metis">Add support for metis (<pkg>sci-libs/metis</pkg>)</flag>
- <flag name="mumps">Add support for mumps (<pkg>sci-libs/mumps</pkg>)</flag>
- <flag name="p4est">Add support for p4est (<pkg>sci-mathematics/p4est</pkg>)</flag>
- <flag name="parameter_gui">Build and install the parameter_gui executable</flag>
- <flag name="petsc">Add support for petsc (<pkg>sci-libs/petsc</pkg>)</flag>
- <flag name="sparse">Add support for suitesparse (<pkg>sci-libs/suitesparse</pkg>)</flag>
- <flag name="tbb">Add threading support with the help of the tbb library (<pkg>dev-cpp/tbb</pkg>)</flag>
- <flag name="trilinos">Add support for trilinos (<pkg>sci-libs/trilinos</pkg>)</flag>
- </use>
+ <herd>sci</herd>
+ <maintainer>
+ <email>tamiko+GENTOO@kyomu.43-1.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <longdescription lang="en">
+deal.II is a C++ program library targeted at the computational solution
+of partial differential equations using adaptive finite elements. It uses
+state-of-the-art programming techniques to offer you a modern interface
+to the complex data structures and algorithms required.
+ </longdescription>
+ <use>
+ <flag name="arpack">Adds support for ARPACK (<pkg>sci-libs/arpack</pkg>)</flag>
+ <flag name="avx">Use Advanced Vector Extensions for AVX capable chips</flag>
+ <flag name="debug">
+Build an additional debug library with extra debug codepaths, like asserts
+and extra output. If you want to get meaningful backtraces see
+&lt;http://www.gentoo.org/proj/en/qa/backtraces.xml&gt;</flag>
+ <flag name="c++11">Compile the library with -std=c++11</flag>
+ <flag name="mesh_converter">Build and install the mesh_converter executable</flag>
+ <flag name="metis">Add support for metis (<pkg>sci-libs/metis</pkg>)</flag>
+ <flag name="mumps">Add support for mumps (<pkg>sci-libs/mumps</pkg>)</flag>
+ <flag name="muparser">Add support for muparser (<pkg>dev-cpp/muParser</pkg>)</flag>
+ <flag name="p4est">Add support for p4est (<pkg>sci-mathematics/p4est</pkg>)</flag>
+ <flag name="parameter_gui">Build and install the parameter_gui executable</flag>
+ <flag name="petsc">Add support for petsc (<pkg>sci-libs/petsc</pkg>)</flag>
+ <flag name="sparse">Add support for suitesparse (<pkg>sci-libs/suitesparse</pkg>)</flag>
+ <flag name="tbb">Add threading support with the help of the tbb library (<pkg>dev-cpp/tbb</pkg>)</flag>
+ <flag name="trilinos">Add support for trilinos (<pkg>sci-libs/trilinos</pkg>)</flag>
+ </use>
</pkgmetadata>