aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-12-05 10:40:49 -0700
committerChristoph Junghans <ottxor@gentoo.org>2014-12-05 10:40:49 -0700
commit157fc79d7616d270fc94129977a481b943a7b621 (patch)
tree2e9e19c8dd406a6b6233a9840b7305c3d59b2737
parentversion bump (diff)
downloadsci-157fc79d7616d270fc94129977a481b943a7b621.tar.gz
sci-157fc79d7616d270fc94129977a481b943a7b621.tar.bz2
sci-157fc79d7616d270fc94129977a481b943a7b621.zip
added prefix support
Package-Manager: portage-2.2.14
-rw-r--r--app-shells/mpibash/ChangeLog3
-rw-r--r--app-shells/mpibash/mpibash-4.3_p30-r1.ebuild23
2 files changed, 22 insertions, 4 deletions
diff --git a/app-shells/mpibash/ChangeLog b/app-shells/mpibash/ChangeLog
index 441e0df8a..bbc69c9f5 100644
--- a/app-shells/mpibash/ChangeLog
+++ b/app-shells/mpibash/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 05 Dec 2014; Christoph Junghans <ottxor@gentoo.org> mpibash-4.3_p30-r1.ebuild:
+ added prefix support
+
*mpibash-4.3_p30-r1 (03 Dec 2014)
03 Dec 2014; Christoph Junghans <ottxor@gentoo.org>
diff --git a/app-shells/mpibash/mpibash-4.3_p30-r1.ebuild b/app-shells/mpibash/mpibash-4.3_p30-r1.ebuild
index 692f99891..0328448e5 100644
--- a/app-shells/mpibash/mpibash-4.3_p30-r1.ebuild
+++ b/app-shells/mpibash/mpibash-4.3_p30-r1.ebuild
@@ -38,7 +38,7 @@ SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~amd64-linux"
IUSE="afs bashlogger examples mem-scramble +net nls plugins +readline vanilla"
DEPEND=">=sys-libs/ncurses-5.2-r2
@@ -101,6 +101,17 @@ src_configure() {
# For descriptions of these, see config-top.h
# bashrc/#26952 bash_logout/#90488 ssh/#24762
+ if use prefix ; then
+ append-cppflags \
+ -DDEFAULT_PATH_VALUE=\'\"${EPREFIX}/usr/sbin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
+ -DSTANDARD_UTILS_PATH=\'\"${EPREFIX}/bin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/usr/sbin:/bin:/usr/bin:/sbin:/usr/sbin\"\' \
+ -DSYS_BASHRC=\'\"${EPREFIX}/etc/bash/bashrc\"\' \
+ -DSYS_BASH_LOGOUT=\'\"${EPREFIX}/etc/bash/bash_logout\"\' \
+ -DNON_INTERACTIVE_LOGIN_SHELLS \
+ -DSSH_SOURCE_BASHRC \
+ $($(tc-getPKG_CONFIG) --cflags libcircle) \
+ $(use bashlogger && echo -DSYSLOG_HISTORY)
+ else
append-cppflags \
-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
-DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
@@ -110,6 +121,7 @@ src_configure() {
-DSSH_SOURCE_BASHRC \
$($(tc-getPKG_CONFIG) --cflags libcircle) \
$(use bashlogger && echo -DSYSLOG_HISTORY)
+ fi
# Don't even think about building this statically without
# reading Bug 7714 first. If you still build it statically,
@@ -173,15 +185,18 @@ src_compile() {
}
src_install() {
- local d f
-
- default
+ emake install DESTDIR="${D}"
find "${ED}" -name "bashbug*" -delete || die
+ rm -rf "${ED}"/usr/share/locale
mv "${ED}"/usr/share/man/man1/{,mpi}bash.1 || die
mv "${ED}"/usr/share/info/{,mpi}bash.info || die
return 0
+ local d f
+
+ default
+
dodir /bin
mv "${ED}"/usr/bin/bash "${ED}"/bin/ || die
dosym bash /bin/rbash