aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-03-30 16:47:35 +0200
committerMartin Mokrejš <mmokrejs@fold.natur.cuni.cz>2016-03-30 16:47:35 +0200
commit1a200d0a079c95ff7357a3581d1f43be63af802d (patch)
tree2deb789c210c3a55f29f566e0eaacec362b675da
parentfixing /# : $/# $/ (diff)
downloadsci-1a200d0a079c95ff7357a3581d1f43be63af802d.tar.gz
sci-1a200d0a079c95ff7357a3581d1f43be63af802d.tar.bz2
sci-1a200d0a079c95ff7357a3581d1f43be63af802d.zip
sci-biology/TransDecoder: version bump
Package-Manager: portage-2.2.28
-rw-r--r--sci-biology/TransDecoder/Manifest1
-rw-r--r--sci-biology/TransDecoder/TransDecoder-2.1.0.ebuild83
-rw-r--r--sci-biology/TransDecoder/files/TransDecoder-2.1.0__fix_paths.patch22
3 files changed, 106 insertions, 0 deletions
diff --git a/sci-biology/TransDecoder/Manifest b/sci-biology/TransDecoder/Manifest
index 83f501c15..01bcf6532 100644
--- a/sci-biology/TransDecoder/Manifest
+++ b/sci-biology/TransDecoder/Manifest
@@ -1 +1,2 @@
DIST TransDecoder-2.0.1.tar.gz 9925281 SHA256 ce069da72c8a04e739f8c057af4f97187bf587d3f0d3db40465dfc2c89393e22 SHA512 fd12aeda089a12036e288e58eb0a3c3b9bb1f104f6821102d84ba6ddaec1a9dd32ec7937cd87129ff9814c7c8e26b6b98d27c6af8edd7ed6b5335c4878f649de WHIRLPOOL 61c6b7fe5684becdb28a3bccb113fea07889a2c4e6627e92cd27c1a90ca53f5a88504e048363a1322f1108dd6ebd5549c52aee9d438fbcfb2023390c79c126ec
+DIST TransDecoder-2.1.0.tar.gz 11500688 SHA256 681a8dd72e482cb322d74d8431ddcda61f25c53ad5453d0e22c02c92b2157b24 SHA512 4635a544ef56718db3fbfbe84ab47dfd7af605df73ead69c98e79dca64649c91d6d5139f0b5540d307f23fce5d0d75289c4fd1bedffc393721ccd9b863b7b043 WHIRLPOOL 9c8200e77c5c25384c87bdfe6daeac51336c61abcf6cc247f01f1b80aa0c9eb1a6c70f008ca3b09522fef3988583c520d1634d18bfcabe81eccad772fb7e433e
diff --git a/sci-biology/TransDecoder/TransDecoder-2.1.0.ebuild b/sci-biology/TransDecoder/TransDecoder-2.1.0.ebuild
new file mode 100644
index 000000000..9fbcea5ca
--- /dev/null
+++ b/sci-biology/TransDecoder/TransDecoder-2.1.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+[ "$PV" == "9999" ] && inherit git-r3
+
+PERL_EXPORT_PHASE_FUNCTIONS=no
+inherit perl-module eutils toolchain-funcs
+
+DESCRIPTION="Extract ORF/CDS regions from FASTA sequences"
+HOMEPAGE="http://transdecoder.github.io"
+if [ "$PV" == "9999" ]; then
+ EGIT_REPO_URI="https://github.com/TransDecoder/TransDecoder.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/TransDecoder/TransDecoder/archive/v"${PV}".tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}"/TransDecoder-"${PV}"
+fi
+
+LICENSE="BSD-BroadInstitute"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sci-biology/cd-hit
+ sci-biology/parafly
+ sci-biology/ffindex"
+
+src_prepare(){
+ rm -rf transdecoder_plugins/cd-hit
+ for f in PerlLib/*.pm; do
+ p=`basename $f .pm`;
+ sed -e "s#use $p;#use TransDecoder::$p;#" -i PerlLib/*.pm util/*.pl TransDecoder.LongOrfs TransDecoder.Predict || die;
+ done
+ epatch "${FILESDIR}"/"${P}"__fix_paths.patch
+ epatch "${FILESDIR}"/pfam_runner.pl.patch
+}
+
+src_compile(){
+ einfo "Skipping compilation of bundled cd-hit code, nothing else to do"
+}
+
+# avoid fetching 1.5TB "${S}"/pfam/Pfam-AB.hmm.bin, see
+# "Re: [Transdecoder-users] Announcement: Transdecoder release r20140704"
+# thread in archives. You can get it from
+# http://downloads.sourceforge.net/project/transdecoder/Pfam-AB.hmm.bin
+
+src_install(){
+ dobin TransDecoder.Predict TransDecoder.LongOrfs
+ insinto /usr/share/${PN}/util
+ doins util/*.pl
+ chmod -R a+rx "${D}"/usr/share/${PN}/util
+ # zap the bundled cdhit binaries copied from transdecoder_plugins/cdhit/ to util/bin
+ rm -rf util/bin
+ #
+ # * sci-biology/trinityrnaseq-20140413:0::science
+ # * /usr/bin/Fasta_reader.pm
+ # * /usr/bin/GFF3_utils.pm
+ # * /usr/bin/Gene_obj.pm
+ # * /usr/bin/Gene_obj_indexer.pm
+ # * /usr/bin/Longest_orf.pm
+ # * /usr/bin/Nuc_translator.pm
+ # * /usr/bin/TiedHash.pm
+ #
+ perl_set_version
+ insinto ${VENDOR_LIB}/${PN}
+ doins PerlLib/*.pm
+ # dodoc Release.Notes
+ einfo "Fetch your own Pfam-A.hmm (Pfam-AB.hmm is discontinued since 05/2015):"
+ einfo "wget --mirror -nH -nd ftp://ftp.ebi.ac.uk/pub/databases/Pfam/current_release/Pfam-A.hmm.gz"
+ einfo "hmmpress Pfam-A.hmm.bin"
+}
+
+pkg_postinst(){
+ einfo "It is recommended to use TransDecoder with sci-biology/hmmer-3 or"
+ einfo "at least with NCBI blast from either:"
+ einfo " sci-biology/ncbi-blast+ (released more often) or from"
+ einfo " sci-biology/ncbi-toolkit++ (a huge bundle with releases and less frequent bugfixes)"
+}
diff --git a/sci-biology/TransDecoder/files/TransDecoder-2.1.0__fix_paths.patch b/sci-biology/TransDecoder/files/TransDecoder-2.1.0__fix_paths.patch
new file mode 100644
index 000000000..0a6fca050
--- /dev/null
+++ b/sci-biology/TransDecoder/files/TransDecoder-2.1.0__fix_paths.patch
@@ -0,0 +1,22 @@
+--- TransDecoder-2.0.1/TransDecoder.LongOrfs.ori 2015-11-19 21:05:53.340219051 +0100
++++ TransDecoder-2.0.1/TransDecoder.LongOrfs 2015-11-19 21:20:44.870221380 +0100
+@@ -64,7 +64,7 @@
+ use TransDecoder::Fasta_reader;
+ use TransDecoder::Longest_orf;
+
+-my $UTIL_DIR = "$FindBin::RealBin/util";
++my $UTIL_DIR = "/usr/share/TransDecoder/util/";
+ $ENV{PATH} = "$UTIL_DIR/bin:$ENV{PATH}";
+
+
+--- TransDecoder-2.0.1/TransDecoder.Predict.ori 2015-11-19 21:06:04.280219080 +0100
++++ TransDecoder-2.0.1/TransDecoder.Predict 2015-11-19 21:21:22.560221479 +0100
+@@ -52,7 +52,7 @@
+ use TransDecoder::Fasta_reader;
+ use TransDecoder::Longest_orf;
+
+-my $UTIL_DIR = "$FindBin::RealBin/util";
++my $UTIL_DIR = "/usr/share/TransDecoder/util/";
+ $ENV{PATH} = "$UTIL_DIR/bin:$ENV{PATH}";
+
+