aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-23 17:52:59 +0200
committerJustin Lecher <jlec@gentoo.org>2015-05-23 17:52:59 +0200
commit1a930a0faaead47c6d02c2d07c9636f006b5c3e9 (patch)
treef8ab217762926115a38d0dc0e2e915823d0b9450
parentsci-biology/breakdancer: added inherit cmake (diff)
parentsci-libs/arrayfire: Split up ebuilds to fix 9999 (diff)
downloadsci-1a930a0faaead47c6d02c2d07c9636f006b5c3e9.tar.gz
sci-1a930a0faaead47c6d02c2d07c9636f006b5c3e9.tar.bz2
sci-1a930a0faaead47c6d02c2d07c9636f006b5c3e9.zip
Merge remote-tracking branch 'github/master'
* github/master: sci-libs/arrayfire: Split up ebuilds to fix 9999 sci-libs/ccif: Bump to EAPI=5 sci-libs/geom: Bump to EAPI=5 sci-libs/amdlibm: Add missing die app-admin/eselect: Add missing die sci-libs/calculix-ccx: Add missing die sci-biology/kallisto: add kallisto media-gfx/brlcad: fixed deps tcl/tk slots sci-libs/calculix-ccx-2.8_p2: several small fixes dev-libs/utf8proc: Version bump sci-libs/calculix-ccx-2.8_p2 version bump dev-util/f90cache: Version bump dev-java/jrosetta: switching to fedora mirror because upstream server unavailable
-rw-r--r--app-admin/eselect/eselect-1.4.4-r100.ebuild2
-rw-r--r--dev-java/jrosetta/jrosetta-1.0.4.ebuild4
-rw-r--r--dev-libs/utf8proc/ChangeLog8
-rw-r--r--dev-libs/utf8proc/Manifest1
-rw-r--r--dev-libs/utf8proc/files/utf8proc-1.2-buildflags.patch14
-rw-r--r--dev-libs/utf8proc/utf8proc-1.2.ebuild31
-rw-r--r--dev-util/f90cache/ChangeLog7
-rw-r--r--dev-util/f90cache/Manifest1
-rw-r--r--dev-util/f90cache/f90cache-0.95.ebuild38
-rw-r--r--media-gfx/brlcad/ChangeLog4
-rw-r--r--media-gfx/brlcad/brlcad-7.24.2.ebuild4
-rw-r--r--media-gfx/brlcad/brlcad-9999.ebuild4
-rw-r--r--sci-biology/kallisto/ChangeLog10
-rw-r--r--sci-biology/kallisto/Manifest1
-rw-r--r--sci-biology/kallisto/kallisto-0.42.1.ebuild19
-rw-r--r--sci-biology/kallisto/kallisto-9999.ebuild20
-rw-r--r--sci-biology/kallisto/metadata.xml9
-rw-r--r--sci-libs/amdlibm/amdlibm-3.1.ebuild4
-rw-r--r--sci-libs/arrayfire/ChangeLog9
-rw-r--r--sci-libs/arrayfire/arrayfire-9999.ebuild15
-rw-r--r--sci-libs/arrayfire/files/FindBoostCompute.cmake18
-rw-r--r--sci-libs/arrayfire/files/arrayfire-3.0_beta-FindBoostCompute.patch (renamed from sci-libs/arrayfire/files/FindBoostCompute.patch)0
-rw-r--r--sci-libs/arrayfire/files/arrayfire-3.0_beta-FindCBLAS.patch (renamed from sci-libs/arrayfire/files/FindCBLAS.patch)0
-rw-r--r--sci-libs/arrayfire/files/arrayfire-3.0_beta-opencl_CMakeLists.patch (renamed from sci-libs/arrayfire/files/opencl_CMakeLists.patch)0
-rw-r--r--sci-libs/arrayfire/files/arrayfire-9999-FindCBLAS.patch52
-rw-r--r--sci-libs/calculix-ccx/Manifest3
-rw-r--r--sci-libs/calculix-ccx/calculix-ccx-2.7-r1.ebuild4
-rw-r--r--sci-libs/calculix-ccx/calculix-ccx-2.8_p2.ebuild70
-rw-r--r--sci-libs/calculix-ccx/files/01_ccx_2.8p2_Makefile_custom_cc_flags_spooles_arpack.patch32
-rw-r--r--sci-libs/ccif/ChangeLog7
-rw-r--r--sci-libs/ccif/ccif-0.3.20111209.ebuild4
-rw-r--r--sci-libs/geom/ChangeLog6
-rw-r--r--sci-libs/geom/Manifest2
-rw-r--r--sci-libs/geom/geom-5.1.2.7.ebuild10
34 files changed, 379 insertions, 34 deletions
diff --git a/app-admin/eselect/eselect-1.4.4-r100.ebuild b/app-admin/eselect/eselect-1.4.4-r100.ebuild
index 02730fa03..8001cf173 100644
--- a/app-admin/eselect/eselect-1.4.4-r100.ebuild
+++ b/app-admin/eselect/eselect-1.4.4-r100.ebuild
@@ -57,7 +57,7 @@ src_install() {
# band aid for prefix
if use prefix; then
- cd "${ED}"/usr/share/eselect/libs
+ cd "${ED}"/usr/share/eselect/libs || die
sed -i "s:ALTERNATIVESDIR_ROOTLESS=\"${EPREFIX}:ALTERNATIVESDIR_ROOTLESS=\":" alternatives.bash || die
fi
}
diff --git a/dev-java/jrosetta/jrosetta-1.0.4.ebuild b/dev-java/jrosetta/jrosetta-1.0.4.ebuild
index 040af6248..3f5c32598 100644
--- a/dev-java/jrosetta/jrosetta-1.0.4.ebuild
+++ b/dev-java/jrosetta/jrosetta-1.0.4.ebuild
@@ -8,7 +8,9 @@ inherit java-pkg-2 java-ant-2
DESCRIPTION="Provides a common base for graphical component to build a graphical console."
HOMEPAGE="http://dev.artenum.com/projects/jrosetta"
-SRC_URI="http://maven.artenum.com/content/groups/public/com/artenum/${PN}/${PV}/${P}-sources.jar"
+#currently down
+#SRC_URI="http://maven.artenum.com/content/groups/public/com/artenum/${PN}/${PV}/${P}-sources.jar"
+SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/jrosetta/${P}-sources.jar"
LICENSE="GPL-2"
SLOT="0"
diff --git a/dev-libs/utf8proc/ChangeLog b/dev-libs/utf8proc/ChangeLog
index f5afbed53..f822d346b 100644
--- a/dev-libs/utf8proc/ChangeLog
+++ b/dev-libs/utf8proc/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-libs/utf8proc
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*utf8proc-1.2 (21 May 2015)
+
+ 21 May 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +files/utf8proc-1.2-buildflags.patch, +utf8proc-1.2.ebuild:
+ Version bump
+
02 Apr 2014; SĂ©bastien Fabbro <bicatali@gentoo.org> metadata.xml,
utf8proc-1.1.6.ebuild:
dev-libs/utf8proc: Keyworded for amd64-linux x86-linux
diff --git a/dev-libs/utf8proc/Manifest b/dev-libs/utf8proc/Manifest
index 4459cdb6a..7d19b7696 100644
--- a/dev-libs/utf8proc/Manifest
+++ b/dev-libs/utf8proc/Manifest
@@ -1 +1,2 @@
+DIST utf8proc-1.2.tar.gz 137294 SHA256 9b07ffe12e049974d120f1558459f6ba9b44681c182ac738ca96fb70aa842fd9 SHA512 066b77d599320e0f6d90e52f6ae482c3caf54276920ad4afacaf4d0c4969d94aa33401e63edee14b2887cdf60fdffd07f913d246212aac1a26b480f20cbc24d4 WHIRLPOOL 597f30c1f1b6d413d9ab7b81c203d01386a949bf33a99eb0bf90ffb7b2c560b78b55ad02d074bff57ecaccda46db991d0bbb9dcf113756c87914a488a2e44762
DIST utf8proc-v1.1.6.tar.gz 105825 SHA256 fedc8fa78022eb8f0584fbc85c9f9571bcd7fd510de0ce16955289c42f4199e7 SHA512 3bec2388298c201d9d6992cdd36330f1109d26a37b3411ba633f006f40da9e494ba0565051b763a7d3014e6113cd1e7754e6b95d5cbb2d7b50cee55193f0fdc1 WHIRLPOOL c211419407e80893b66fa7586a8148e9b2e45c89d2d31878658a4ae7f0b1ca72e269cef234ca8b30e27e4bac5a48715520dd546f6605af773d6e165ef76f81b0
diff --git a/dev-libs/utf8proc/files/utf8proc-1.2-buildflags.patch b/dev-libs/utf8proc/files/utf8proc-1.2-buildflags.patch
new file mode 100644
index 000000000..4d583e417
--- /dev/null
+++ b/dev-libs/utf8proc/files/utf8proc-1.2-buildflags.patch
@@ -0,0 +1,14 @@
+Adjust build flags. Proted from 1.1.6.
+
+Patch by Marius Brehler.
+--- Makefile
++++ Makefile
+@@ -6,7 +6,7 @@ AR=ar
+ INSTALL=install
+
+ # compiler settings
+-cflags = -O2 -std=c99 -pedantic -Wall -fpic -DUTF8PROC_EXPORTS $(CFLAGS)
++cflags = -std=c99 -pedantic -fpic -DUTF8PROC_EXPORTS $(CFLAGS)
+ cc = $(CC) $(cflags)
+
+ # shared-library version MAJOR.MINOR.PATCH ... this may be *different*
diff --git a/dev-libs/utf8proc/utf8proc-1.2.ebuild b/dev-libs/utf8proc/utf8proc-1.2.ebuild
new file mode 100644
index 000000000..349806f39
--- /dev/null
+++ b/dev-libs/utf8proc/utf8proc-1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="library for processing UTF-8 encoded Unicode strings"
+HOMEPAGE="http://www.public-software-group.org/utf8proc"
+SRC_URI="https://github.com/JuliaLang/${PN}/archive/v1.2.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-buildflags.patch
+}
+
+src_compile() {
+ emake libutf8proc.so
+ use static-libs & emake libutf8proc.a
+}
+
+src_install() {
+ doheader utf8proc.h
+ dolib.so libutf8proc.so
+ use static-libs && dolib.a libutf8proc.a
+}
diff --git a/dev-util/f90cache/ChangeLog b/dev-util/f90cache/ChangeLog
index 4b14c0a2f..69945470b 100644
--- a/dev-util/f90cache/ChangeLog
+++ b/dev-util/f90cache/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-util/f90cache
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*f90cache-0.95 (19 May 2015)
+
+ 19 May 2015; Marius Brehler <marbre@linux.sungazer.de> +f90cache-0.95.ebuild:
+ Version bump
+
*f90cache-0.94 (24 Dec 2012)
24 Dec 2012; Christoph Junghans <ottxor@gentoo.org> +f90cache-0.94.ebuild,
diff --git a/dev-util/f90cache/Manifest b/dev-util/f90cache/Manifest
index 73afa26e3..61e613037 100644
--- a/dev-util/f90cache/Manifest
+++ b/dev-util/f90cache/Manifest
@@ -1 +1,2 @@
DIST f90cache-0.94.tar.bz2 64670 SHA256 0ddc06ad98dcfb2b4b2a45561eabdd9c31e872eaef83d0719d5546e5a1dd775b SHA512 bd36a20614e82a8728fbb5ba7897c13d6e59243a4fbb8878cfb8019ca4ee976280cfe8ba5a00c19b620756910f257cd7fe72de6bdfc06f4ee2f7f17c5f9b892d WHIRLPOOL c2509d420228eb839dc1a4e92c2de27a45a74ff45c660e3379f2b3ad8f12ffd9be5e13331cf898e66be9dd72833856aa2de46129c80b410b9e10dc168f7409d1
+DIST f90cache-0.95.tar.bz2 74843 SHA256 3976a15d99442f96d8a4d5f1d468339167a1e7538079b647f6ed2ef9e970a5b8 SHA512 21b19a1bc3b5b329eab3669cf5396085a454b6745d7c6f02ad73472be59346388953e62daaccd414df5b183eef580b6f5673ba16a012942bef160e1d6848f331 WHIRLPOOL 2cb69ff47125edf1d77049a3b466aba484ed2a9f0ad4c32a8b68596d93b7c62b70f77a142431c9a97066b5f7397b3432f8851edd45814bd9b00c447f79116bfe
diff --git a/dev-util/f90cache/f90cache-0.95.ebuild b/dev-util/f90cache/f90cache-0.95.ebuild
new file mode 100644
index 000000000..43e04c269
--- /dev/null
+++ b/dev-util/f90cache/f90cache-0.95.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit fortran-2 multilib toolchain-funcs
+
+DESCRIPTION="a compiler cache for fortran"
+HOMEPAGE="http://people.irisa.fr/Edouard.Canot/f90cache/"
+SRC_URI="http://people.irisa.fr/Edouard.Canot/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-util/ccache"
+
+src_prepare() {
+ sed -i -e '/OBJS/s/CFLAGS/LDFLAGS/' -e '/strip/d' Makefile.in || die
+}
+
+src_install() {
+ default
+ dohtml web/*
+
+ #we depend on ccache, put links in there so that portage fined it
+ #TODO improve this
+ dosym "/usr/bin/f90cache" "${ROOT}/usr/$(get_libdir)/ccache/bin/gfortran"
+}
+
+pkg_postinst() {
+ elog "Please add F90CACHE_DIR=\"${ROOT%/}/var/tmp/f90cache\""
+ elog "to your make.conf otherwise f90cache files end up in"
+ elog "home of the user executing portage"
+}
diff --git a/media-gfx/brlcad/ChangeLog b/media-gfx/brlcad/ChangeLog
index 98759c562..584b0bb1a 100644
--- a/media-gfx/brlcad/ChangeLog
+++ b/media-gfx/brlcad/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/media-gfx/brlcad/ChangeLog,v 1.3 2011/04/18 22:47:37 dilfridge Exp $
+ 21 May 2015; Dongxu Li <dongxuli2011@gmail.com>
+ brlcad-7.24.2.ebuild, brlcad-9999.ebuild:
+ Fixed deps tcl/tk slots
+
28 April 2015; Dongxu Li <dongxuli2011@gmail.com>
brlcad-7.24.2.ebuild, brlcad-9999.ebuild:
Fixed a deps issue
diff --git a/media-gfx/brlcad/brlcad-7.24.2.ebuild b/media-gfx/brlcad/brlcad-7.24.2.ebuild
index 23ac7c059..86477a34c 100644
--- a/media-gfx/brlcad/brlcad-7.24.2.ebuild
+++ b/media-gfx/brlcad/brlcad-7.24.2.ebuild
@@ -25,8 +25,8 @@ DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex
media-libs/libpng:0
- <dev-lang/tcl-8.6:0
- <dev-lang/tk-8.6:0
+ <dev-lang/tcl-8.6:0/8.5
+ <dev-lang/tk-8.6:0/8.5
dev-tcltk/tktable
sys-libs/zlib
sys-libs/libtermcap-compat
diff --git a/media-gfx/brlcad/brlcad-9999.ebuild b/media-gfx/brlcad/brlcad-9999.ebuild
index 5b5a2a3b3..fb891d8f2 100644
--- a/media-gfx/brlcad/brlcad-9999.ebuild
+++ b/media-gfx/brlcad/brlcad-9999.ebuild
@@ -25,8 +25,8 @@ DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex
media-libs/libpng:0
- <dev-lang/tcl-8.6:0
- <dev-lang/tk-8.6:0
+ <dev-lang/tcl-8.6:0/8.5
+ <dev-lang/tk-8.6:0/8.5
dev-tcltk/tktable
sys-libs/zlib
sys-libs/libtermcap-compat
diff --git a/sci-biology/kallisto/ChangeLog b/sci-biology/kallisto/ChangeLog
new file mode 100644
index 000000000..6b15b362c
--- /dev/null
+++ b/sci-biology/kallisto/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-biology/kallisto
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*kallisto-0.42.1 (21 May 2015)
+*kallisto-9999 (21 May 2015)
+
+ 21 May 2015; Michael Schubert <mschu.dev@gmail.com> +kallisto-0.42.1.ebuild,
+ +kallisto-9999.ebuild, +metadata.xml:
+ sci-biology/kallisto: add kallisto
diff --git a/sci-biology/kallisto/Manifest b/sci-biology/kallisto/Manifest
new file mode 100644
index 000000000..9994a955e
--- /dev/null
+++ b/sci-biology/kallisto/Manifest
@@ -0,0 +1 @@
+DIST kallisto-0.42.1.tar.gz 1047963 SHA256 e620623fe36ee183cf7e1245aba8e0b7490f530c2b68c81d6e8f0c21e2c97381 SHA512 bcfec13ac9c281610486f128a72b112616823d007cccf170f1e5846f1bd206759d5b3e94c5bc26f66e458f20b04fc4ed68d0bda6a46a23636bd61483e28c21e7 WHIRLPOOL 6b2b3cc50b24534ce4e6845447f619a2b06f0d5da608f202092ef9463c6be7e7f2f812a131e6475cd5918af96034cce1613b8b74151abebb411cab0e84543cfd
diff --git a/sci-biology/kallisto/kallisto-0.42.1.ebuild b/sci-biology/kallisto/kallisto-0.42.1.ebuild
new file mode 100644
index 000000000..dfc4eafb5
--- /dev/null
+++ b/sci-biology/kallisto/kallisto-0.42.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Near-optimal RNA-Seq quantification"
+HOMEPAGE="http://pachterlab.github.io/kallisto/"
+SRC_URI="https://github.com/pachterlab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="sci-libs/hdf5"
+RDEPEND="${DEPEND}"
diff --git a/sci-biology/kallisto/kallisto-9999.ebuild b/sci-biology/kallisto/kallisto-9999.ebuild
new file mode 100644
index 000000000..cc5b26957
--- /dev/null
+++ b/sci-biology/kallisto/kallisto-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit git-r3 cmake-utils
+
+DESCRIPTION="Near-optimal RNA-Seq quantification"
+HOMEPAGE="http://pachterlab.github.io/kallisto/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/pachterlab/kallisto.git"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="sci-libs/hdf5"
+RDEPEND="${DEPEND}"
diff --git a/sci-biology/kallisto/metadata.xml b/sci-biology/kallisto/metadata.xml
new file mode 100644
index 000000000..b7551a6aa
--- /dev/null
+++ b/sci-biology/kallisto/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <maintainer>
+ <email>mschu.dev@gmail.com</email>
+ <name>Michael Schubert</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-libs/amdlibm/amdlibm-3.1.ebuild b/sci-libs/amdlibm/amdlibm-3.1.ebuild
index 4b8d041c4..5d62ae37b 100644
--- a/sci-libs/amdlibm/amdlibm-3.1.ebuild
+++ b/sci-libs/amdlibm/amdlibm-3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -48,7 +48,7 @@ src_prepare() {
}
src_test() {
- cd examples
+ cd examples || die
sh build_and_run.sh || die
}
diff --git a/sci-libs/arrayfire/ChangeLog b/sci-libs/arrayfire/ChangeLog
index 0ba626039..61231847c 100644
--- a/sci-libs/arrayfire/ChangeLog
+++ b/sci-libs/arrayfire/ChangeLog
@@ -1,6 +1,15 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 23 May 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +files/FindBoostCompute.cmake,
+ +files/arrayfire-3.0_beta-FindBoostCompute.patch,
+ +files/arrayfire-3.0_beta-FindCBLAS.patch,
+ +files/arrayfire-3.0_beta-opencl_CMakeLists.patch,
+ +files/arrayfire-9999-FindCBLAS.patch, -files/FindBoostCompute.patch,
+ -files/FindCBLAS.patch, -files/opencl_CMakeLists.patch, arrayfire-9999.ebuild:
+ Split up ebuilds to fix 9999
+
24 Mar 2015; Marius Brehler <marbre@linux.sungazer.de>
-files/arrayfire-0.9999-build_gtest.patch:
Drop patch, fixed upstream
diff --git a/sci-libs/arrayfire/arrayfire-9999.ebuild b/sci-libs/arrayfire/arrayfire-9999.ebuild
index dda442eb6..b976a150b 100644
--- a/sci-libs/arrayfire/arrayfire-9999.ebuild
+++ b/sci-libs/arrayfire/arrayfire-9999.ebuild
@@ -13,13 +13,6 @@ HOMEPAGE="http://www.arrayfire.com/"
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git git://github.com/${PN}/${PN}.git"
SRC_URI="test? ( https://googletest.googlecode.com/files/gtest-${GTEST_PV}.zip )"
KEYWORDS=""
-if [[ ${PV} == "0.9999" ]] ; then
- # the remote HEAD points to devel, but we want to pull the master instead
- EGIT_BRANCH="master"
-elif [[ ${PV} == "3.0_beta" ]] ; then
- EGIT_COMMIT="v3.0beta"
- KEYWORDS="~amd64"
-fi
LICENSE="BSD"
SLOT="0"
@@ -34,6 +27,7 @@ RDEPEND="
cpu? (
virtual/blas
virtual/cblas
+ virtual/lapacke
sci-libs/fftw:3.0
)
opencl? (
@@ -48,9 +42,7 @@ BUILD_DIR="${S}/build"
CMAKE_BUILD_TYPE=Release
PATCHES=(
- "${FILESDIR}"/FindCBLAS.patch
- "${FILESDIR}"/FindBoostCompute.patch
- "${FILESDIR}"/opencl_CMakeLists.patch
+ "${FILESDIR}"/${P}-FindCBLAS.patch
)
# We need write acccess /dev/nvidiactl, /dev/nvidia0 and /dev/nvidia-uvm and the portage
@@ -74,6 +66,9 @@ src_unpack() {
unpack ${A}
mv "${BUILD_DIR}"/third_party/src/gtest-"${GTEST_PV}" "${BUILD_DIR}"/third_party/src/googletest || die
fi
+
+ rm "${S}"/CMakeModules/build_boost_compute.cmake || die
+ cp "${FILESDIR}"/FindBoostCompute.cmake "${S}"/CMakeModules/ || die
}
src_configure() {
diff --git a/sci-libs/arrayfire/files/FindBoostCompute.cmake b/sci-libs/arrayfire/files/FindBoostCompute.cmake
new file mode 100644
index 000000000..d98ea4b67
--- /dev/null
+++ b/sci-libs/arrayfire/files/FindBoostCompute.cmake
@@ -0,0 +1,18 @@
+# Downloads and builds the Boost Compute library from github.com
+# Defines the following variables
+# * BoostCompute_FOUND Flag for Boost Compute
+# * BoostCompute_INCLUDE_DIR Location of the Boost Compute headers
+
+
+set(BoostCompute_INCLUDE_DIR "/usr/include/compute")
+SET( BoostCompute_FOUND ON CACHE BOOL "BoostCompute Found" )
+
+
+IF(NOT BoostCompute_FOUND)
+ MESSAGE(FATAL_ERROR, "Boost.Compute not found! Clone Boost.Compute from https://github.com/kylelutz/compute.git")
+ENDIF(NOT BoostCompute_FOUND)
+
+MARK_AS_ADVANCED(
+ BoostCompute_FOUND
+ BoostCompute_INCLUDE_DIR
+ )
diff --git a/sci-libs/arrayfire/files/FindBoostCompute.patch b/sci-libs/arrayfire/files/arrayfire-3.0_beta-FindBoostCompute.patch
index 3052df20d..3052df20d 100644
--- a/sci-libs/arrayfire/files/FindBoostCompute.patch
+++ b/sci-libs/arrayfire/files/arrayfire-3.0_beta-FindBoostCompute.patch
diff --git a/sci-libs/arrayfire/files/FindCBLAS.patch b/sci-libs/arrayfire/files/arrayfire-3.0_beta-FindCBLAS.patch
index 263c62aaf..263c62aaf 100644
--- a/sci-libs/arrayfire/files/FindCBLAS.patch
+++ b/sci-libs/arrayfire/files/arrayfire-3.0_beta-FindCBLAS.patch
diff --git a/sci-libs/arrayfire/files/opencl_CMakeLists.patch b/sci-libs/arrayfire/files/arrayfire-3.0_beta-opencl_CMakeLists.patch
index 7279afaa6..7279afaa6 100644
--- a/sci-libs/arrayfire/files/opencl_CMakeLists.patch
+++ b/sci-libs/arrayfire/files/arrayfire-3.0_beta-opencl_CMakeLists.patch
diff --git a/sci-libs/arrayfire/files/arrayfire-9999-FindCBLAS.patch b/sci-libs/arrayfire/files/arrayfire-9999-FindCBLAS.patch
new file mode 100644
index 000000000..7f757e8a2
--- /dev/null
+++ b/sci-libs/arrayfire/files/arrayfire-9999-FindCBLAS.patch
@@ -0,0 +1,52 @@
+Use pkg-config to find cblas.
+
+Patch by Marius Brehler.
+
+--- CMakeModules/FindCBLAS.cmake 2015-05-23 17:12:41.000000000 +0200
++++ CMakeModules/FindCBLAS.cmake.new 2015-05-23 17:13:51.000000000 +0200
+@@ -1,3 +1,9 @@
++#
++# Version modified for Gentoo Linux
++# If a valid PkgConfig configuration for cblas is found, this overrides and cancels
++# all further checks.
++#
++
+ # Using FindCBLAS.cmake from the following repo
+ # https://github.com/clementfarabet/THC/blob/master/COPYRIGHT.txt
+
+@@ -21,6 +27,29 @@ SET(CBLAS_INCLUDE_DIR CACHE STRING
+ SET(CBLAS_INCLUDE_FILE CACHE STRING
+ "CBLAS header name")
+
++
++#
++# first, try PkgConfig
++#
++find_package(PkgConfig REQUIRED)
++pkg_check_modules(PC_CBLAS cblas)
++if(PC_CBLAS_FOUND)
++ foreach(PC_LIB ${PC_CBLAS_LIBRARIES})
++ find_library(${PC_LIB}_LIBRARY NAMES ${PC_LIB} HINTS ${PC_CBLAS_LIBRARY_DIRS} )
++ if (NOT ${PC_LIB}_LIBRARY)
++ message(FATAL_ERROR "Something is wrong in your pkg-config file - lib ${PC_LIB} not found in ${PC_CBLAS_LIBRARY_DIRS}")
++ endif (NOT ${PC_LIB}_LIBRARY)
++ list(APPEND CBLAS_LIBRARIES ${${PC_LIB}_LIBRARY})
++ endforeach(PC_LIB)
++ find_package_handle_standard_args(CBLAS DEFAULT_MSG CBLAS_LIBRARIES)
++ mark_as_advanced(CBLAS_LIBRARIES)
++else(PC_CBLAS_FOUND)
++message(STATUS "No PkgConfig configuration for CBLAS found; starting more extensive search.")
++
++
++
++
++
+ SET(INTEL_MKL_ROOT_DIR CACHE STRING
+ "Root directory of the Intel MKL")
+
+@@ -277,3 +306,5 @@ IF(NOT CBLAS_FIND_QUIETLY)
+ MESSAGE(STATUS "CBLAS library not found.")
+ ENDIF()
+ ENDIF(NOT CBLAS_FIND_QUIETLY)
++
++endif(PC_CBLAS_FOUND)
diff --git a/sci-libs/calculix-ccx/Manifest b/sci-libs/calculix-ccx/Manifest
index 62639c473..9f4a5bdaa 100644
--- a/sci-libs/calculix-ccx/Manifest
+++ b/sci-libs/calculix-ccx/Manifest
@@ -1,3 +1,6 @@
DIST ccx_2.7.ps.tar.bz2 2395486 SHA256 e757b93d6279d49aa33c623a4d598382c55f1b35a4f0ffa43b2651c1f2baccc5 SHA512 987b5fb33ebbf8ebc989e276d7fe7c33edae8b72c52c3ad06c4a5c31476082b1a225387636ecc312b1cac5f6cbc4873bd94c74eb6cdb8f36b506db316c5089aa WHIRLPOOL 8a49560523f4045263e0ddc8dfb47ce32dc7fada099abe1998a95835f880eeefdf06097dc70fb3beed26a326a33781514089145d088205a45b02ac1cfc3db908
DIST ccx_2.7.src.tar.bz2 825264 SHA256 85fa68ec855e4e445f01be011f4cada238043ba4c5b7eaa38e19777bce2382d7 SHA512 e66c7df2d5c195112bf117aaf11ed9d1e9fc73b530a828f0f45a5574accc4093683307a637bba38cb9af1063a5b3f507e53570c970e38c48893758612de52cc8 WHIRLPOOL 5df3cada0ba41a5c2015907884c14f0e2d1c272e55a8b9c044f303c073624e7b5083a5605a83965505246ded428a0a291cf932520f2d404dd147f1711829282c
DIST ccx_2.7.test.tar.bz2 8450942 SHA256 e339c9093b876c43b4a9b4a8ee80af60eb4146a1a89ff01f1dcf2f13aaaeb0d5 SHA512 01830b50524da5116c1dea8867ed8178577e665e29fffc33394490023111cebc3739293e2de5ec89b73c62ed913aa6a80bec58dcb989d9f24aa781f61e679afc WHIRLPOOL 320517c68da32ccca0fcc1bb8ee12357a1978f1d32e9ec989a63fbd82d5aab0b84d2978b46a555b1b0d3e3ea83b65ac6b5adaa1b8721b53bd19b1f70a041cbfd
+DIST ccx_2.8p2.ps.tar.bz2 2404566 SHA256 8dda526c5b7911446ecadb3ded32e3d2b3daa7f232bfc88a2ad69d807acacc61 SHA512 abfe8d76e2c4fa55dea43c9a819e84dd4f8511bdb1f97c2862eb8faaa5bf314f88efabf1d8507db45d10e698cf0da0e546e108919bf4e82099f817237c1f08de WHIRLPOOL 635d5def9ae884bd2407c062afb727ab0235b64e844f6d5c302bea2fcd8e6798b930bba68c855b77ea4b4276c151bb0588e4132cd583d097908ceffa49ade4c4
+DIST ccx_2.8p2.src.tar.bz2 919489 SHA256 a21feb1a498b5925ddc9f7f58cb486d930435db4a47d5c583dd73f5160431eb2 SHA512 0ec53027ec7b072da33432b903048c5932cc51d43f5156a1ae64daf08924ed68f6bc70ea4b7fa4db9ad750bccd64c347fc7aec24418c67acaaf75c05a5988ab3 WHIRLPOOL 80587ca75690e7252303950e68b4071f14ce224d32297870589841ea1cbc7a3ad1ca257e87d84ef5ad47d688623b8cf950f2f508f4b8b9b235c9493657ada5a7
+DIST ccx_2.8p2.test.tar.bz2 9014544 SHA256 a859389cb1405a6130e06215715d4aac93b7877825d7d30a78ef3ab1f3df3662 SHA512 3d96041307b36fe342bf8ca63b041357ba818c0f72ff6217d07e0e72613aec1322a797ff2c03ecdf9cbd853f0bb79fb2e32868dc4a8ed2f20dc936a9142f9c2f WHIRLPOOL 7c859d25b3f8a9595b65bc6bb5a5f5fd8c7cd4fd0857a29b114cc0bcafc17aaf3c0c487a81ff4521ec70b2e076c4119e4913649507ea6db7900cfcf6fc79f052
diff --git a/sci-libs/calculix-ccx/calculix-ccx-2.7-r1.ebuild b/sci-libs/calculix-ccx/calculix-ccx-2.7-r1.ebuild
index a511dc9a0..5dc1f0073 100644
--- a/sci-libs/calculix-ccx/calculix-ccx-2.7-r1.ebuild
+++ b/sci-libs/calculix-ccx/calculix-ccx-2.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -59,7 +59,7 @@ src_install () {
dosym ${MY_P} /usr/bin/ccx
if use doc; then
- cd "${S}/../doc"
+ cd "${S}/../doc" || die
ps2pdf ${MY_P}.ps ${MY_P}.pdf
dodoc ${MY_P}.pdf
fi
diff --git a/sci-libs/calculix-ccx/calculix-ccx-2.8_p2.ebuild b/sci-libs/calculix-ccx/calculix-ccx-2.8_p2.ebuild
new file mode 100644
index 000000000..61feea216
--- /dev/null
+++ b/sci-libs/calculix-ccx/calculix-ccx-2.8_p2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P=ccx_${PV/_/}
+
+DESCRIPTION="A Free Software Three-Dimensional Structural Finite Element Program"
+HOMEPAGE="http://www.calculix.de/"
+SRC_URI="
+ http://www.dhondt.de/${MY_P}.src.tar.bz2
+ doc? ( http://www.dhondt.de/${MY_P}.ps.tar.bz2 )
+ examples? ( http://www.dhondt.de/${MY_P}.test.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="arpack doc examples threads"
+
+RDEPEND="
+ arpack? ( >=sci-libs/arpack-3.1.3 )
+ >=sci-libs/spooles-2.2[threads=]
+ virtual/lapack
+ virtual/blas"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/ghostscript-gpl )"
+
+S=${WORKDIR}/CalculiX/${MY_P}/src
+
+src_prepare (){
+ epatch "${FILESDIR}/01_${MY_P}_Makefile_custom_cc_flags_spooles_arpack.patch"
+}
+
+src_configure() {
+ # Technically we currently only need this when arpack is not used.
+ # Keeping things this way in case we change pkgconfig for arpack
+ export LAPACK=$($(tc-getPKG_CONFIG) --libs lapack)
+
+ append-cflags "-I/usr/include/spooles -DSPOOLES"
+ if use threads; then
+ append-cflags "-DUSE_MT"
+ fi
+
+ if use arpack; then
+ export ARPACKLIB=$($(tc-getPKG_CONFIG) --libs arpack)
+ append-cflags "-DARPACK"
+ fi
+ export CC="$(tc-getCC)"
+ export FC="$(tc-getFC)"
+}
+
+src_install () {
+ dobin ${MY_P}
+ dosym ${MY_P} /usr/bin/ccx
+
+ if use doc; then
+ cd "${S}/../doc" || die
+ ps2pdf ${MY_P}.ps ${MY_P}.pdf || die "ps2pdf failed"
+ dodoc ${MY_P}.pdf
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${S}"/../test/*
+ fi
+}
diff --git a/sci-libs/calculix-ccx/files/01_ccx_2.8p2_Makefile_custom_cc_flags_spooles_arpack.patch b/sci-libs/calculix-ccx/files/01_ccx_2.8p2_Makefile_custom_cc_flags_spooles_arpack.patch
new file mode 100644
index 000000000..a47fdc6f1
--- /dev/null
+++ b/sci-libs/calculix-ccx/files/01_ccx_2.8p2_Makefile_custom_cc_flags_spooles_arpack.patch
@@ -0,0 +1,32 @@
+Fix Makefile to make it use custom CFLAGS and system libraries.
+
+--- CalculiX.orig/ccx_2.8p2/src/Makefile 2015-05-21 11:04:58.125111330 +0300
++++ CalculiX/ccx_2.8p2/src/Makefile 2015-05-21 11:08:26.848130631 +0300
+@@ -1,9 +1,9 @@
+
+-CFLAGS = -Wall -O3 -I ../../../SPOOLES.2.2 -DARCH="Linux" -DSPOOLES -DARPACK -DMATRIXSTORAGE
+-FFLAGS = -Wall -O3 -fopenmp
++CFLAGS := -Wall -O3 -DARCH="Linux" -DMATRIXSTORAGE $(CFLAGS)
++FFLAGS := -Wall -O3 $(FFLAGS)
+
+-CC=cc
+-FC=gfortran
++#CC=cc
++#FC=gfortran
+
+ .c.o :
+ $(CC) $(CFLAGS) -c $<
+@@ -18,12 +18,7 @@
+ OCCXC = $(SCCXC:.c=.o)
+ OCCXMAIN = $(SCCXMAIN:.c=.o)
+
+-DIR=../../../SPOOLES.2.2
+-
+-LIBS = \
+- $(DIR)/spooles.a \
+- ../../../ARPACK/libarpack_INTEL.a \
+- -lpthread -lm -lc
++LIBS = $(ARPACKLIB) $(LAPACK) -lm -lc -lspooles -lpthread
+
+ ccx_2.8p2: $(OCCXMAIN) ccx_2.8p2.a $(LIBS)
+ ./date.pl; $(CC) $(CFLAGS) -c ccx_2.8p2.c; $(FC) -fopenmp -Wall -O3 -o $@ $(OCCXMAIN) ccx_2.8p2.a $(LIBS)
diff --git a/sci-libs/ccif/ChangeLog b/sci-libs/ccif/ChangeLog
index 09ecdb00d..15efc4d8f 100644
--- a/sci-libs/ccif/ChangeLog
+++ b/sci-libs/ccif/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-libs/ccif
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 23 May 2015; Marius Brehler <marbre@linux.sungazer.de>
+ ccif-0.3.20111209.ebuild:
+ Bump to EAPI=5
+
24 Jan 2012; Justin Lecher <jlec@gentoo.org> ccif-0.3.20111209.ebuild:
Dropped DOCS as it is handled by default
@@ -13,4 +17,3 @@
04 Jan 2012; Justin Lecher <jlec@gentoo.org> +ccif-0.3.20111209.ebuild,
+metadata.xml:
Initial commit
-
diff --git a/sci-libs/ccif/ccif-0.3.20111209.ebuild b/sci-libs/ccif/ccif-0.3.20111209.ebuild
index 792067ee8..b4e066a34 100644
--- a/sci-libs/ccif/ccif-0.3.20111209.ebuild
+++ b/sci-libs/ccif/ccif-0.3.20111209.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
inherit autotools-utils fortran-2
diff --git a/sci-libs/geom/ChangeLog b/sci-libs/geom/ChangeLog
index bef4c80d9..d488d7f8e 100644
--- a/sci-libs/geom/ChangeLog
+++ b/sci-libs/geom/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for sci-libs/geom
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 23 May 2015; Marius Brehler <marbre@linux.sungazer.de> geom-5.1.2.7.ebuild:
+ Bump to EAPI=5
+
*geom-5.1.2.7 (09 Mar 2011)
09 Mar 2011; Oliver Borm (boroli) <oli.borm@web.de> +geom-5.1.2.7.ebuild,
+metadata.xml:
sci-libs/geom: New ebuild from bug 358061
-
diff --git a/sci-libs/geom/Manifest b/sci-libs/geom/Manifest
index ed41324cf..557594be2 100644
--- a/sci-libs/geom/Manifest
+++ b/sci-libs/geom/Manifest
@@ -1 +1 @@
-DIST geom-5.1.2.7.tar.gz 612914 SHA256 c0685d82535db3899d9321d72237b5d1be2dbafd1c85f990f767d5cd88571055
+DIST geom-5.1.2.7.tar.gz 612914 SHA256 c0685d82535db3899d9321d72237b5d1be2dbafd1c85f990f767d5cd88571055 SHA512 06454a4a92959fa08f2e81d8e5fcfdb957a49cdf51bd5e7efd6895ab2d1aedbd99dfb30ddc4b278b10d125f9d2d66260eff584e670716c96e2d0ec10b169fb08 WHIRLPOOL 0d9d11efe518c98788e921336552435639eb3bd8f53e39381babc1baaa3c609c37c9aa21e320a3342fbe03472f557e32f94e8fd8658e8b1017d99672ee618fc3
diff --git a/sci-libs/geom/geom-5.1.2.7.ebuild b/sci-libs/geom/geom-5.1.2.7.ebuild
index 5ad13c7a9..98331d566 100644
--- a/sci-libs/geom/geom-5.1.2.7.ebuild
+++ b/sci-libs/geom/geom-5.1.2.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=5
inherit autotools eutils
@@ -27,14 +27,14 @@ src_prepare() {
}
src_compile() {
- emake || die 'emake failed'
+ default
if use doc ; then
- cd ../../doc/src
+ cd ../../doc/src || die
doxygen || die 'doxygen failed'
fi
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed!"
+ default
use doc && dohtml -r ../../doc/html/*
}