aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2022-07-20 19:47:51 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-21 17:21:40 +0200
commit1b9474e146a8b1dd1c531dad356f21745f510c9d (patch)
tree71055da61cdf500482c47daf093bf2d3e45ae7fa
parentsci-physics/formcalc: new package, add 9.9, 9.10 (diff)
downloadsci-1b9474e146a8b1dd1c531dad356f21745f510c9d.tar.gz
sci-1b9474e146a8b1dd1c531dad356f21745f510c9d.tar.bz2
sci-1b9474e146a8b1dd1c531dad356f21745f510c9d.zip
sci-physics/feyncalc: new package, add 9.3.1, 9999
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/sci/pull/1159 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-physics/feyncalc/Manifest2
-rw-r--r--sci-physics/feyncalc/feyncalc-9.3.1.ebuild43
-rw-r--r--sci-physics/feyncalc/feyncalc-9999.ebuild47
-rw-r--r--sci-physics/feyncalc/metadata.xml22
4 files changed, 114 insertions, 0 deletions
diff --git a/sci-physics/feyncalc/Manifest b/sci-physics/feyncalc/Manifest
new file mode 100644
index 000000000..9514cfd33
--- /dev/null
+++ b/sci-physics/feyncalc/Manifest
@@ -0,0 +1,2 @@
+DIST FeynCalc-9.3.1.tar.gz 4296784 BLAKE2B bb9e2e17ee8c51ec9417f900982af494e44a19cad651065d769820756056d6accfa8955da1c03dcc054e32c8ca5a5b1974594e77f95cc0a8e7100919783d20ad SHA512 3e7f4e87920e26712008754498f2d7e3a5873f6adf3e7dbea1e98f7f0f9ff20e1e08941b959e18143d3f602aa3f0c1ac4c574f450bcd6d2e8ad68e775e95aeee
+DIST FeynCalc-9999.tar.gz 4298804 BLAKE2B a4b404aed41d510f32ddf5a242d0c6129174ace1eeb92a19c2cf6f9620f82b37f3b01709d063619567590d38d4506431b5d9af6fbf3fe1184c07c683c1f2d3b4 SHA512 30ef3f0249b9dd639e0d83767d1aaea272c6ce3083d0a36a96ced11c68bd4d9c499efcd95abb209d56cd8ae3142b925c6b723c541821c7856e4ac787c2c52e34
diff --git a/sci-physics/feyncalc/feyncalc-9.3.1.ebuild b/sci-physics/feyncalc/feyncalc-9.3.1.ebuild
new file mode 100644
index 000000000..2f54f878b
--- /dev/null
+++ b/sci-physics/feyncalc/feyncalc-9.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=$(ver_rs 1-3 '_')
+MY_PN=FeynCalc
+
+DESCRIPTION="FeynCalc is a Mathematica package for computing Feynman diagrams."
+HOMEPAGE="https://feyncalc.github.io/"
+SLOT="0"
+SRC_URI="https://github.com/FeynCalc/feyncalc/archive/refs/tags/Release-${MY_PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/feyncalc-Release-${MY_PV}"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+IUSE="+FCtraditionalFormOutput"
+
+RDEPEND="
+ sci-mathematics/mathematica
+ "
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ mv "${MY_PN}/DocOutput" "${MY_PN}/Documentation" || die
+ if use FCtraditionalFormOutput; then
+ echo '$FCTraditionalFormOutput=True;' > "${MY_PN}/FCConfig.m" || die
+ fi
+}
+
+src_install() {
+ MMADIR=/usr/share/Mathematica/Applications
+ dodir "${MMADIR}/${MY_PN}"
+ insinto "${MMADIR}/"
+ doins -r "${S}/${MY_PN}"
+ # copy permissions
+ for f in $(find "${MY_PN}/*" ! -type l); do
+ fperms --reference="${S}/$f" "${MMADIR}/$f"
+ done
+ # documentation are notebook(.nb) files
+ dodoc -r ${MY_PN}/Documentation/English/*
+ docompress -x /usr/share/doc/${PF}/
+}
diff --git a/sci-physics/feyncalc/feyncalc-9999.ebuild b/sci-physics/feyncalc/feyncalc-9999.ebuild
new file mode 100644
index 000000000..1c26d976e
--- /dev/null
+++ b/sci-physics/feyncalc/feyncalc-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV=$(ver_rs 1-3 '_')
+MY_PN=FeynCalc
+
+DESCRIPTION="FeynCalc is a Mathematica package for computing Feynman diagrams."
+HOMEPAGE="https://feyncalc.github.io/"
+SLOT="0"
+SRC_URI="https://github.com/FeynCalc/feyncalc/archive/hotfix-stable.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/feyncalc-hotfix-stable"
+
+LICENSE="GPL-3+"
+IUSE="+FCtraditionalFormOutput"
+REQUIRED_USE=""
+PROPERTIES+=" live"
+
+RDEPEND="
+ sci-mathematics/mathematica
+ "
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ mv "${MY_PN}/DocOutput" "${MY_PN}/Documentation" || die
+ if use FCtraditionalFormOutput; then
+ echo '$FCTraditionalFormOutput=True;' > "${MY_PN}/FCConfig.m" || die
+ fi
+}
+
+src_install() {
+ MMADIR=/usr/share/Mathematica/Applications
+ dodir "${MMADIR}/${MY_PN}"
+ insinto "${MMADIR}/"
+ doins -r "${S}/${MY_PN}"
+ # copy permissions
+ for f in $(find "${MY_PN}/*" ! -type l); do
+ fperms --reference="${S}/$f" "${MMADIR}/$f"
+ done
+ # documentation are notebook(.nb) files
+ dodoc -r ${MY_PN}/Documentation/English/*
+ docompress -x /usr/share/doc/${PF}/
+}
diff --git a/sci-physics/feyncalc/metadata.xml b/sci-physics/feyncalc/metadata.xml
new file mode 100644
index 000000000..9e87f772e
--- /dev/null
+++ b/sci-physics/feyncalc/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <longdescription lang="en">
+ FeynCalc is a Mathematica package for symbolic evaluation of Feynman diagrams and algebraic calculations in quantum field theory and elementary particle physics.
+ </longdescription>
+ <use>
+ <flag name="FCtraditionalFormOutput">Use TraditionalForm typesetting.</flag>
+ </use>
+</pkgmetadata>