aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-06-05 12:10:59 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-06-05 12:10:59 +0200
commit1d6b89951f6d82039c7d2216c4a774bde14be8bd (patch)
treeaf190dada3d9e0cc91928ab00fec1d2e7757a563
parentRevert "sci-libs/arrayfire: Fetch tarball instead of getting src from git" (diff)
downloadsci-1d6b89951f6d82039c7d2216c4a774bde14be8bd.tar.gz
sci-1d6b89951f6d82039c7d2216c4a774bde14be8bd.tar.bz2
sci-1d6b89951f6d82039c7d2216c4a774bde14be8bd.zip
dev-libs/boost-compute: Fix BoostComputeConfig.cmake location
Package-Manager: portage-2.2.18
-rw-r--r--dev-libs/boost-compute/ChangeLog9
l---------dev-libs/boost-compute/boost-compute-0.4-r1.ebuild (renamed from dev-libs/boost-compute/boost-compute-0.4.ebuild)0
-rw-r--r--dev-libs/boost-compute/boost-compute-9999.ebuild4
-rw-r--r--dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch14
4 files changed, 26 insertions, 1 deletions
diff --git a/dev-libs/boost-compute/ChangeLog b/dev-libs/boost-compute/ChangeLog
index eefb055eb..37d9336bf 100644
--- a/dev-libs/boost-compute/ChangeLog
+++ b/dev-libs/boost-compute/ChangeLog
@@ -1,10 +1,17 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*boost-compute-0.4-r1 (05 Jun 2015)
+
+ 05 Jun 2015; Marius Brehler <marbre@linux.sungazer.de>
+ +boost-compute-0.4-r1.ebuild, +files/boost-compute-0.4-CMakeLists.patch,
+ -boost-compute-0.4.ebuild, boost-compute-9999.ebuild:
+ Fix BoostComputeConfig.cmake location
+
*boost-compute-9999 (01 Feb 2015)
*boost-compute-0.4 (01 Feb 2015)
01 Feb 2015; Marius Brehler <marbre@linux.sungazer.de>
+metadata.xml, +boost-compute-9999.ebuild, +boost-compute-0.4.ebuild:
Add Boost.Compute to overlay
- \ No newline at end of file
+
diff --git a/dev-libs/boost-compute/boost-compute-0.4.ebuild b/dev-libs/boost-compute/boost-compute-0.4-r1.ebuild
index 9782d2a2f..9782d2a2f 120000
--- a/dev-libs/boost-compute/boost-compute-0.4.ebuild
+++ b/dev-libs/boost-compute/boost-compute-0.4-r1.ebuild
diff --git a/dev-libs/boost-compute/boost-compute-9999.ebuild b/dev-libs/boost-compute/boost-compute-9999.ebuild
index 320fa9d85..b9b09c936 100644
--- a/dev-libs/boost-compute/boost-compute-9999.ebuild
+++ b/dev-libs/boost-compute/boost-compute-9999.ebuild
@@ -26,3 +26,7 @@ RDEPEND="
virtual/opencl
"
DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-0.4-CMakeLists.patch
+)
diff --git a/dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch b/dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch
new file mode 100644
index 000000000..86d3a9e29
--- /dev/null
+++ b/dev-libs/boost-compute/files/boost-compute-0.4-CMakeLists.patch
@@ -0,0 +1,14 @@
+Install the BoostComputeConfig to /usr/lib/cmake instead of /usr/share/cmake.
+
+Patch by Marius Brehler.
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -81,7 +81,7 @@ configure_file(
+ # install cmake config file
+ install(
+ FILES ${BoostCompute_BINARY_DIR}/BoostComputeConfig.cmake
+- DESTINATION share/cmake/BoostCompute
++ DESTINATION lib/cmake/BoostCompute
+ )
+
+ # install header files