aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-03 08:35:37 +0100
committerJustin Lecher <jlec@gentoo.org>2013-12-03 08:35:37 +0100
commit1ed4cb766c2586d284e99d98ed36b52162495a3c (patch)
tree632dad2abaaad2ca6eeafad13b48bf28e3f8a528
parentMerge branch 'billyonthemountain-master' into asd (diff)
downloadsci-1ed4cb766c2586d284e99d98ed36b52162495a3c.tar.gz
sci-1ed4cb766c2586d284e99d98ed36b52162495a3c.tar.bz2
sci-1ed4cb766c2586d284e99d98ed36b52162495a3c.zip
dev-python/pythonqt: Fix linending problem when patching
Package-Manager: portage-2.2.7
-rw-r--r--dev-python/pythonqt/ChangeLog5
-rw-r--r--dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch44
-rw-r--r--dev-python/pythonqt/files/pythonqt-9999-lib_location.patch40
-rw-r--r--dev-python/pythonqt/pythonqt-2.1.ebuild1
-rw-r--r--dev-python/pythonqt/pythonqt-9999.ebuild1
5 files changed, 49 insertions, 42 deletions
diff --git a/dev-python/pythonqt/ChangeLog b/dev-python/pythonqt/ChangeLog
index 731422ef1..83e1f6d32 100644
--- a/dev-python/pythonqt/ChangeLog
+++ b/dev-python/pythonqt/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 03 Dec 2013; Justin Lecher <jlec@gentoo.org> pythonqt-2.1.ebuild,
+ pythonqt-9999.ebuild, files/pythonqt-2.1-lib_location.patch,
+ files/pythonqt-9999-lib_location.patch:
+ Fix linending problem when patching
+
02 Dec 2013; Justin Lecher <jlec@gentoo.org> -pythonqt-1.1.ebuild,
pythonqt-2.1.ebuild, pythonqt-9999.ebuild,
files/pythonqt-2.1-lib_location.patch,
diff --git a/dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch b/dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch
index dd3bcc624..f86772ad1 100644
--- a/dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch
+++ b/dev-python/pythonqt/files/pythonqt-2.1-lib_location.patch
@@ -1,22 +1,22 @@
---- PythonQt2.1_Qt4.8/CMakeLists.txt.auto-diff-temp 2012-11-30 16:38:06.374358937 +0100
-+++ PythonQt2.1_Qt4.8/CMakeLists.txt 2012-11-30 16:39:37.421438916 +0100
-@@ -215,7 +215,7 @@
- # See http://blog.onesadcookie.com/2008/01/installname-magic.html
- #
- set_target_properties(PythonQt PROPERTIES
-- INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib"
-+ INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}"
- )
-
- target_link_libraries(PythonQt
-@@ -228,8 +228,8 @@
-
- install(TARGETS PythonQt
- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib)
-+ LIBRARY DESTINATION lib${LIB_SUFFIX}
-+ ARCHIVE DESTINATION lib${LIB_SUFFIX})
- install(FILES ${headers} DESTINATION include/PythonQt)
-
- MESSAGE(STATUS "<<< Gentoo configuration >>>
+--- PythonQt2.1_Qt4.8/CMakeLists.txt.auto-diff-temp 2012-11-30 16:38:06.374358937 +0100
++++ PythonQt2.1_Qt4.8/CMakeLists.txt 2012-11-30 16:39:37.421438916 +0100
+@@ -215,7 +215,7 @@
+ # See http://blog.onesadcookie.com/2008/01/installname-magic.html
+ #
+ set_target_properties(PythonQt PROPERTIES
+- INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib"
++ INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}"
+ )
+
+ target_link_libraries(PythonQt
+@@ -228,8 +228,8 @@
+
+ install(TARGETS PythonQt
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ install(FILES ${headers} DESTINATION include/PythonQt)
+
+ MESSAGE(STATUS "<<< Gentoo configuration >>>
diff --git a/dev-python/pythonqt/files/pythonqt-9999-lib_location.patch b/dev-python/pythonqt/files/pythonqt-9999-lib_location.patch
index 111db4780..f8d5322ae 100644
--- a/dev-python/pythonqt/files/pythonqt-9999-lib_location.patch
+++ b/dev-python/pythonqt/files/pythonqt-9999-lib_location.patch
@@ -1,20 +1,20 @@
---- pythonqt-9999/CMakeLists.txt.auto-diff-temp 2012-11-30 17:02:28.754418411 +0100
-+++ pythonqt-9999/CMakeLists.txt 2012-11-30 17:02:58.158429034 +0100
-@@ -215,7 +215,7 @@
- # See http://blog.onesadcookie.com/2008/01/installname-magic.html
- #
- set_target_properties(PythonQt PROPERTIES
-- INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib"
-+ INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}"
- )
-
- target_link_libraries(PythonQt
-@@ -228,6 +228,6 @@
-
- install(TARGETS PythonQt
- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib
-- ARCHIVE DESTINATION lib)
-+ LIBRARY DESTINATION lib${LIB_SUFFIX}
-+ ARCHIVE DESTINATION lib${LIB_SUFFIX})
- install(FILES ${headers} DESTINATION include/PythonQt)
+--- pythonqt-9999/CMakeLists.txt.auto-diff-temp 2012-11-30 17:02:28.754418411 +0100
++++ pythonqt-9999/CMakeLists.txt 2012-11-30 17:02:58.158429034 +0100
+@@ -215,7 +215,7 @@
+ # See http://blog.onesadcookie.com/2008/01/installname-magic.html
+ #
+ set_target_properties(PythonQt PROPERTIES
+- INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib"
++ INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}"
+ )
+
+ target_link_libraries(PythonQt
+@@ -228,6 +228,6 @@
+
+ install(TARGETS PythonQt
+ RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ install(FILES ${headers} DESTINATION include/PythonQt)
diff --git a/dev-python/pythonqt/pythonqt-2.1.ebuild b/dev-python/pythonqt/pythonqt-2.1.ebuild
index 99e078608..e6daaf0ab 100644
--- a/dev-python/pythonqt/pythonqt-2.1.ebuild
+++ b/dev-python/pythonqt/pythonqt-2.1.ebuild
@@ -30,3 +30,4 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}_Qt4.8"
PATCHES=( "${FILESDIR}"/${P}-lib_location.patch )
+EPATCH_OPTS="--binary"
diff --git a/dev-python/pythonqt/pythonqt-9999.ebuild b/dev-python/pythonqt/pythonqt-9999.ebuild
index 1444bd420..6559346bd 100644
--- a/dev-python/pythonqt/pythonqt-9999.ebuild
+++ b/dev-python/pythonqt/pythonqt-9999.ebuild
@@ -29,6 +29,7 @@ DEPEND="${PYTHON_DEPS}
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${P}-lib_location.patch )
+EPATCH_OPTS="--binary"
src_prepare() {
subversion_src_prepare