aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-03-20 22:14:56 +0100
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-03-20 22:49:21 +0100
commit29b630b625e28ee43a93a5fced298735829bf25c (patch)
treed1cc8a424890243442817ac04e6e227d47e40141
parentRemoved ggobi, now in main tree (diff)
downloadsci-29b630b625e28ee43a93a5fced298735829bf25c.tar.gz
sci-29b630b625e28ee43a93a5fced298735829bf25c.tar.bz2
sci-29b630b625e28ee43a93a5fced298735829bf25c.zip
dev-tcltk/togl added
-rw-r--r--dev-tcltk/togl/ChangeLog10
-rw-r--r--dev-tcltk/togl/Manifest4
-rw-r--r--dev-tcltk/togl/metadata.xml8
-rw-r--r--dev-tcltk/togl/togl-2.0.ebuild36
-rw-r--r--licenses/Togl28
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-tcltk/togl/ChangeLog b/dev-tcltk/togl/ChangeLog
new file mode 100644
index 000000000..595fef288
--- /dev/null
+++ b/dev-tcltk/togl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-tcltk/togl
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*togl-2.0 (20 Mar 2009)
+
+ 20 Mar 2009; Justin Lecher (jlec) <jlec@j-schmitz.net> +metadata.xml,
+ +togl-2.0.ebuild:
+ Initial checkin
+
diff --git a/dev-tcltk/togl/Manifest b/dev-tcltk/togl/Manifest
new file mode 100644
index 000000000..2421868ce
--- /dev/null
+++ b/dev-tcltk/togl/Manifest
@@ -0,0 +1,4 @@
+DIST Togl2.0-src.tar.gz 244968 RMD160 a0124141b824922306af3a1b4ba6ddcf857f6218 SHA1 7ebb028a75f733d0ac2dca851e23c03f33cc4843 SHA256 b7d4a90bbad3aca618d505ee99e7fd8fb04c829f63231dda2360f557ba3f7610
+EBUILD togl-2.0.ebuild 682 RMD160 85a7e98c70339b54822332ef59ff6a7798fa5713 SHA1 6514ea73ca10bf5af63b2d82fc92a222116698ec SHA256 b8b24bd3bab6669f7cfca789953f7413295edca7a78a5b8f921f396da2884551
+MISC ChangeLog 251 RMD160 32c3bc8b19e8fba2d640f646281a9babbf95e6e8 SHA1 7d04c0f710b134eea21fc67e0c0e4469eee24749 SHA256 7ffea1177835d0af6a70a5fbfb810dc8e34218301bd3fa03d023936e1f6495f4
+MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
diff --git a/dev-tcltk/togl/metadata.xml b/dev-tcltk/togl/metadata.xml
new file mode 100644
index 000000000..efb490d78
--- /dev/null
+++ b/dev-tcltk/togl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-tcltk/togl/togl-2.0.ebuild b/dev-tcltk/togl/togl-2.0.ebuild
new file mode 100644
index 000000000..141abeda6
--- /dev/null
+++ b/dev-tcltk/togl/togl-2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# inherit
+
+MY_P="Togl${PV}"
+
+DESCRIPTION="A Tk widget for OpenGL rendering"
+HOMEPAGE="http://togl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="Togl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+
+RDEPEND="dev-lang/tk"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_compile() {
+
+ econf \
+ $(use_enable amd64 64bit) \
+ $(use_enable threads)
+
+ emake || die "compilation error"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+ dohtml doc/* || die "no html"
+ dodoc README* || die "no README"
+}
diff --git a/licenses/Togl b/licenses/Togl
new file mode 100644
index 000000000..a40bd5cd3
--- /dev/null
+++ b/licenses/Togl
@@ -0,0 +1,28 @@
+This software is copyrighted by Brian Paul (brian@mesa3d.org),
+Benjamin Bederson (bederson@cs.umd.edu), and Greg Couch
+(gregcouch@users.sourceforge.net). The following terms apply to all
+files associated with the software unless explicitly disclaimed in
+individual files.
+
+The authors hereby grant permission to use, copy, modify, distribute,
+and license this software and its documentation for any purpose, provided
+that existing copyright notices are retained in all copies and that this
+notice is included verbatim in any distributions. No written agreement,
+license, or royalty fee is required for any of the authorized uses.
+Modifications to this software may be copyrighted by their authors
+and need not follow the licensing terms described here, provided that
+the new terms are clearly indicated on the first page of each file where
+they apply.
+
+IN NO EVENT SHALL THE AUTHORS OR DISTRIBUTORS BE LIABLE TO ANY PARTY
+FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES
+ARISING OUT OF THE USE OF THIS SOFTWARE, ITS DOCUMENTATION, OR ANY
+DERIVATIVES THEREOF, EVEN IF THE AUTHORS HAVE BEEN ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
+
+THE AUTHORS AND DISTRIBUTORS SPECIFICALLY DISCLAIM ANY WARRANTIES,
+INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT. THIS SOFTWARE
+IS PROVIDED ON AN "AS IS" BASIS, AND THE AUTHORS AND DISTRIBUTORS HAVE
+NO OBLIGATION TO PROVIDE MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR
+MODIFICATIONS.