aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-27 15:32:26 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-09-27 15:32:26 +0000
commit2d25882dc4028dc8092fcb0c8dbe111f1c401e0b (patch)
tree00167e7d851fad5c5da46a8666045ce4133aa42f
parentsys-cluster/{mpich{,2},mvapich,openmpi}: drop packages (diff)
downloadsci-2d25882dc4028dc8092fcb0c8dbe111f1c401e0b.tar.gz
sci-2d25882dc4028dc8092fcb0c8dbe111f1c401e0b.tar.bz2
sci-2d25882dc4028dc8092fcb0c8dbe111f1c401e0b.zip
sys-cluster/mpe2: drop package
present in ::gentoo Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--sys-cluster/mpe2/Manifest1
-rw-r--r--sys-cluster/mpe2/metadata.xml8
-rw-r--r--sys-cluster/mpe2/mpe2-1.3.0.ebuild147
3 files changed, 0 insertions, 156 deletions
diff --git a/sys-cluster/mpe2/Manifest b/sys-cluster/mpe2/Manifest
deleted file mode 100644
index 7b0ec3089..000000000
--- a/sys-cluster/mpe2/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST mpe2-1.3.0.tar.gz 9703024 BLAKE2B 1fe8db10968602270e296368ea90ede3998d480fe27c68b6fb9375d83a193e8d909fc27055541561acd97b03b8cf6c56b13d1e3032e6ff3018d17ed31f6942fe SHA512 84f0be89f4c17e5b86bc4d067be650b65938af4f7e71224e8f65b723f217649da3d5b8991f3eb9c83823d9c0831d9847c90e6940d9f30958803984efb2e028ca
diff --git a/sys-cluster/mpe2/metadata.xml b/sys-cluster/mpe2/metadata.xml
deleted file mode 100644
index 8bf4b5f36..000000000
--- a/sys-cluster/mpe2/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>cluster@gentoo.org</email>
- <name>Gentoo Cluster Project</name>
- </maintainer>
-</pkgmetadata>
diff --git a/sys-cluster/mpe2/mpe2-1.3.0.ebuild b/sys-cluster/mpe2/mpe2-1.3.0.ebuild
deleted file mode 100644
index d1bf59c08..000000000
--- a/sys-cluster/mpe2/mpe2-1.3.0.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED=fortran
-
-inherit eutils fortran-2 java-utils-2 toolchain-funcs
-
-MY_P=${P/_/}
-DESCRIPTION="MPI development tools"
-HOMEPAGE="http://www-unix.mcs.anl.gov/perfvis/download/index.htm"
-SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/${PN%2}/${MY_P}.tar.gz"
-
-LICENSE="mpich2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="minimal fortran threads debug"
-
-COMMON_DEPEND="
- !minimal? (
- x11-libs/libXtst
- x11-libs/libXi
- )
- || (
- sys-cluster/openmpi[fortran?,threads?]
- sys-cluster/mpich2[fortran?,threads?]
- )"
-
-DEPEND="!minimal? ( >=virtual/jdk-1.4 )
- ${COMMON_DEPEND}"
-
-RDEPEND="
-!minimal? ( >=virtual/jre-1.4 )
- ${COMMON_DEPEND}"
-
-S="${WORKDIR}"/${MY_P}
-MPE_IMP=""
-
-# README:
-# This ebuild is created to handle building with both mpich2 and openmpi.
-# However, without empi (in the science overlay), and some further
-# conversion to use mpi.eclass, we can only handle one implementation
-# at a time. I still believe it's better to have the ebuild setup
-# correctly in preperation.
-
-pkg_setup() {
- fortran-2_pkg_setup
- local i
-
- if has_version sys-cluster/openmpi; then
- MPE_IMP=openmpi
- elif has_version sys-cluster/mpich2; then
- MPE_IMP=mpich2
- else
- die "Unknown MPI implementation"
- fi
-
- export JFLAGS="${JFLAGS} $(java-pkg_javac-args)"
-
- if [[ "${MPE_IMP}" == openmpi ]] && [ -z "${MPE2_FORCE_OPENMPI_TEST}" ]; then
- echo
- elog "Currently src_test fails on collchk with openmpi, hence"
- elog "testing is disabled by default. If you would like to"
- elog "force testing, please add MPE_FORCE_OPENMPI_TEST=1"
- elog "to your environment."
- echo
- fi
-
- einfo "Building with support for: sys-cluster/${MPE_IMP}"
-}
-
-src_prepare() {
- default
- # Don't assume path contains ./
- sed -i 's,\($MPERUN\) $pgm,\1 ./$pgm,' sbin/mpetestexeclog.in || die
-
- # No parallel make:
- # http://trac.mcs.anl.gov/projects/mpich2/ticket/1095#comment:1
- MAKEOPTS+=" -j1"
-}
-
-src_configure() {
- local c="--with-mpicc=/usr/bin/mpicc"
-
- if use fortran; then
- c="${c} --with-mpif77=/usr/bin/mpif77"
- else
- c="${c} --disable-f77"
- fi
-
- if use minimal; then
- c="${c} --enable-slog2=no --disable-rlog --disable-sample"
- else
- c="${c} --with-java2=$(java-config --jdk-home) --enable-slog2=build"
- fi
-
- if [[ "${MPE_IMP}" == openmpi ]]; then
- c="${c} --disable-rlog --disable-sample"
- fi
-
- econf ${c} \
- --sysconfdir=/etc/${PN} \
- --datadir=/usr/share/${PN} \
- --with-htmldir=/usr/share/${PN} \
- --with-docdir=/usr/share/${PN} \
- --enable-collchk \
- --enable-wrappers \
- $(use_enable !minimal graphics) \
- $(use_enable threads threadlogging) \
- $(use_enable debug g)
-}
-
-src_test() {
- local rc
-
- cd "${S}" || die
- if [[ "${MPE_IMP}" == mpich2 ]]; then
- echo "MPD_SECRETWORD=junk" > "${T}"/mpd.conf
- chmod 600 "${T}"/mpd.conf
- export MPD_CONF_FILE="${T}/mpd.conf"
- "${ROOT}"usr/bin/mpd -d --pidfile="${T}"/mpd.pid
- elif [[ "${MPE_IMP}" == openmpi* ]] && [ -z "${MPE2_FORCE_OPENMPI_TEST}" ]; then
- elog
- elog "Skipping tests for openmpi"
- elog
- return 0
- fi
-
- emake \
- CC="${S}"/bin/mpecc \
- FC="${S}"/bin/mpefc \
- MPERUN="${ROOT}/usr/bin/mpiexec -n 4" \
- CLOG2TOSLOG2="${S}/src/slog2sdk/bin/clog2TOslog2" \
- check;
- rc=${?}
- if [[ "${MPE_IMP}" == mpich2 ]]; then
- "${ROOT}"usr/bin/mpdallexit || kill $(<"${T}"/mpd.pid)
- fi
-
- return ${rc}
-}
-
-src_install() {
- default
- rm -f "${D}"/usr/sbin/mpeuninstall || die
-}