aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-03-07 15:13:02 -0700
committerChristoph Junghans <ottxor@gentoo.org>2013-03-07 15:13:02 -0700
commit3ec2e2ccc209f11690c71da9161b602f1916b8dd (patch)
tree7329c980602c31aed0fc7727a5be5fbaeb9175cc
parentFix typo (diff)
downloadsci-3ec2e2ccc209f11690c71da9161b602f1916b8dd.tar.gz
sci-3ec2e2ccc209f11690c71da9161b602f1916b8dd.tar.bz2
sci-3ec2e2ccc209f11690c71da9161b602f1916b8dd.zip
sync wit gx86
Package-Manager: portage-2.2.0_alpha166
-rw-r--r--sci-visualization/gnuplot/ChangeLog4
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.6.9999.ebuild198
-rw-r--r--sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild196
3 files changed, 186 insertions, 212 deletions
diff --git a/sci-visualization/gnuplot/ChangeLog b/sci-visualization/gnuplot/ChangeLog
index 9910d921f..d5598be8b 100644
--- a/sci-visualization/gnuplot/ChangeLog
+++ b/sci-visualization/gnuplot/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 07 Mar 2013; Christoph Junghans <ottxor@gentoo.org> gnuplot-4.6.9999.ebuild,
+ gnuplot-4.7.9999.ebuild:
+ sync wit gx86
+
03 Mar 2013; Justin Lecher <jlec@gentoo.org> gnuplot-4.6.9999.ebuild,
gnuplot-4.7.9999.ebuild, metadata.xml:
Update to new qt deps names
diff --git a/sci-visualization/gnuplot/gnuplot-4.6.9999.ebuild b/sci-visualization/gnuplot/gnuplot-4.6.9999.ebuild
index da20e42d4..698c277ea 100644
--- a/sci-visualization/gnuplot/gnuplot-4.6.9999.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.6.9999.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.6_rc1.ebuild,v 1.7 2012/03/07 00:33:49 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.6.1-r1.ebuild,v 1.5 2013/03/07 20:35:32 ottxor Exp $
-EAPI=4
+EAPI=5
-inherit elisp-common multilib wxwidgets
+inherit elisp-common eutils flag-o-matic multilib readme.gentoo toolchain-funcs wxwidgets
DESCRIPTION="Command-line driven interactive plotting program"
HOMEPAGE="http://www.gnuplot.info/"
if [[ -z ${PV%%*9999} ]]; then
inherit autotools cvs
- ECVS_SERVER="gnuplot.cvs.sourceforge.net:/cvsroot/gnuplot/gnuplot"
+ ECVS_SERVER="gnuplot.cvs.sourceforge.net:/cvsroot/gnuplot"
ECVS_MODULE="gnuplot"
ECVS_BRANCH="branch-4-6-stable"
ECVS_USER="anonymous"
@@ -26,14 +26,16 @@ fi
LICENSE="gnuplot GPL-2 bitmap? ( free-noncomm )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="bitmap cairo doc emacs examples +gd ggi latex lua plotutils qt4 readline svga thin-splines wxwidgets X xemacs"
-RESTRICT="wxwidgets? ( test )"
+IUSE="aqua bitmap cairo doc emacs examples +gd ggi latex lua plotutils qt4 readline svga thin-splines wxwidgets X xemacs"
RDEPEND="
cairo? (
x11-libs/cairo
x11-libs/pango )
emacs? ( virtual/emacs )
+ !emacs? ( xemacs? (
+ app-editors/xemacs
+ app-xemacs/xemacs-base ) )
gd? ( media-libs/gd[png] )
ggi? ( media-libs/libggi )
latex? (
@@ -43,9 +45,9 @@ RDEPEND="
>=dev-texlive/texlive-latexrecommended-2008-r2 ) )
lua? ( dev-lang/lua )
plotutils? ( media-libs/plotutils )
- qt4? ( >=dev-qt/qtcore-4.5
- >=dev-qt/qtgui-4.5
- >=dev-qt/qtsvg-4.5 )
+ qt4? ( >=dev-qt/qtcore-4.5:4
+ >=dev-qt/qtgui-4.5:4
+ >=dev-qt/qtsvg-4.5:4 )
readline? ( sys-libs/readline )
svga? ( media-libs/svgalib )
wxwidgets? (
@@ -53,10 +55,7 @@ RDEPEND="
x11-libs/cairo
x11-libs/pango
x11-libs/gtk+:2 )
- X? ( x11-libs/libXaw )
- xemacs? (
- app-editors/xemacs
- app-xemacs/xemacs-base )"
+ X? ( x11-libs/libXaw )"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? (
@@ -68,13 +67,13 @@ DEPEND="${RDEPEND}
if [[ -z ${PV%%*9999} ]]; then
# The live ebuild always needs an Emacs for building of gnuplot.texi
DEPEND="${DEPEND}
- !emacs? ( !xemacs? ( || ( virtual/emacs app-xemacs/texinfo ) ) )"
+ || ( virtual/emacs app-xemacs/texinfo )"
fi
S="${WORKDIR}/${MY_P}"
GP_VERSION="${PV%.*}"
-E_SITEFILE="50${PN}-gentoo.el"
+E_SITEFILE="lisp/50${PN}-gentoo.el"
TEXMF="${EPREFIX}/usr/share/texmf-site"
src_prepare() {
@@ -89,6 +88,24 @@ src_prepare() {
# Add special version identification as required by provision 2
# of the gnuplot license
sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
+
+ # hacky workaround
+ # Please hack the buildsystem if you like
+ if use prefix && use qt4; then
+ append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir)/qt4
+ fi
+
+ DOC_CONTENTS='Gnuplot no longer links against pdflib, see the ChangeLog
+ for details. You can use the "pdfcairo" terminal for PDF output.'
+ use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
+ use svga && DOC_CONTENTS+='\n\nIn order to enable ordinary users to use
+ SVGA console graphics, gnuplot needs to be set up as setuid root.
+ Please note that this is usually considered to be a security hazard.
+ As root, manually "chmod u+s /usr/bin/gnuplot".'
+ use gd && DOC_CONTENTS+='\n\nFor font support in png/jpeg/gif output,
+ you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
+ environment variables. See the FAQ file in /usr/share/doc/${PF}/
+ for more information.'
}
src_configure() {
@@ -101,51 +118,49 @@ src_configure() {
need-wxwidgets unicode
fi
- local myconf
- myconf="${myconf} --without-lisp-files"
- myconf="${myconf} --without-pdf"
- myconf="${myconf} --enable-stats" #extra command save to be enabled
- myconf="${myconf} --with-texdir=${TEXMF}/tex/latex/${PN}"
- myconf="${myconf} $(use_with bitmap bitmap-terminals)"
- myconf="${myconf} $(use_with cairo)"
- myconf="${myconf} $(use_with doc tutorial)"
- myconf="${myconf} $(use_with gd)"
- myconf="${myconf} $(use_with ggi ggi ${EPREFIX}/usr/$(get_libdir))"
- myconf="${myconf} $(use_with ggi xmi ${EPREFIX}/usr/$(get_libdir))"
- myconf="${myconf} $(use_with lua)"
- myconf="${myconf} $(use_with plotutils plot "${EPREFIX}"/usr/$(get_libdir))"
- myconf="${myconf} $(use_with svga linux-vga)"
- myconf="${myconf} $(use_enable thin-splines)"
- myconf="${myconf} $(use_enable wxwidgets)"
- myconf="${myconf} $(use_with X x)"
- myconf="${myconf} $(use_enable qt4 qt)"
- use readline \
- && myconf="${myconf} --with-readline=gnu" \
- || myconf="${myconf} --with-readline=builtin"
+ tc-export CC CXX #453174
- local emacs=$(usev emacs || usev xemacs || echo no)
- if [[ -z ${PV%%*9999} && ${emacs} = no ]]; then
- # Live ebuild needs an Emacs to build gnuplot.texi
- if has_version virtual/emacs; then emacs=emacs
- elif has_version app-xemacs/texinfo; then emacs=xemacs; fi
+ local emacs lispdir
+ if use emacs; then
+ emacs=emacs
+ lispdir="${EPREFIX}${SITELISP}/${PN}"
+ use xemacs \
+ && ewarn "USE flag \"xemacs\" ignored (superseded by \"emacs\")"
+ elif use xemacs; then
+ emacs=xemacs
+ lispdir="${EPREFIX}/usr/lib/xemacs/site-packages/${PN}"
+ else
+ emacs=no
+ lispdir=""
+ if [[ -z ${PV%%*9999} ]]; then
+ # Live ebuild needs an Emacs to build gnuplot.texi
+ if has_version virtual/emacs; then emacs=emacs
+ elif has_version app-xemacs/texinfo; then emacs=xemacs; fi
+ fi
fi
- econf ${myconf} \
+ econf \
+ --without-pdf \
+ --with-texdir="${TEXMF}/tex/latex/${PN}" \
+ --with-readline=$(usex readline gnu builtin) \
+ --with-lispdir="${lispdir}" \
+ --with$([[ -z ${lispdir} ]] && echo out)-lisp-files \
+ $(use_with bitmap bitmap-terminals) \
+ $(use_with cairo) \
+ $(use_with doc tutorial) \
+ $(use_with gd) \
+ "$(use_with ggi ggi "${EPREFIX}/usr/$(get_libdir)")" \
+ "$(use_with ggi xmi "${EPREFIX}/usr/$(get_libdir)")" \
+ $(use_with lua) \
+ "$(use_with plotutils plot "${EPREFIX}/usr/$(get_libdir)")" \
+ $(use_with svga linux-vga) \
+ $(use_with X x) \
+ --enable-stats \
+ $(use_enable qt4 qt) \
+ $(use_enable thin-splines) \
+ $(use_enable wxwidgets) \
DIST_CONTACT="http://bugs.gentoo.org/" \
- EMACS=${emacs}
-
- if use xemacs; then
- einfo "Configuring gnuplot-mode for XEmacs ..."
- use emacs && cp -Rp lisp lisp-xemacs || ln -s lisp lisp-xemacs
- cd "${S}/lisp-xemacs"
- econf --with-lispdir="${EPREFIX}/usr/lib/xemacs/site-packages/${PN}" EMACS=xemacs
- fi
-
- if use emacs; then
- einfo "Configuring gnuplot-mode for GNU Emacs ..."
- cd "${S}/lisp"
- econf --with-lispdir="${EPREFIX}${SITELISP}/${PN}" EMACS=emacs
- fi
+ EMACS="${emacs}"
}
src_compile() {
@@ -158,56 +173,30 @@ src_compile() {
emake all info
- if use xemacs; then
- cd "${S}/lisp-xemacs"
- emake
- fi
-
- if use emacs; then
- cd "${S}/lisp"
- emake
- fi
-
if use doc; then
# Avoid sandbox violation in epstopdf/ghostscript
addpredict /var/cache/fontconfig
- cd "${S}/docs"
- emake pdf
- cd "${S}/tutorial"
- emake pdf
-
- if use emacs || use xemacs; then
- cd "${S}/lisp"
- emake pdf
- fi
+ emake -C docs pdf
+ emake -C tutorial pdf
+ use emacs || use xemacs && emake -C lisp pdf
fi
}
src_install () {
emake DESTDIR="${D}" install
- if use xemacs; then
- cd "${S}/lisp-xemacs"
- emake DESTDIR="${D}" install
- fi
-
if use emacs; then
- cd "${S}/lisp"
- emake DESTDIR="${D}" install
- # info-look* is included with >=emacs-21
- rm -f "${ED}${SITELISP}/${PN}"/info-look*
-
- # Gentoo emacs site-lisp configuration
+ # Gentoo Emacs site-lisp configuration
echo "(add-to-list 'load-path \"@SITELISP@\")" > ${E_SITEFILE}
- sed '/^;; move/,+3 d' dotemacs >> ${E_SITEFILE} || die
+ sed '/^;; move/,+3 d' lisp/dotemacs >> ${E_SITEFILE} || die
elisp-site-file-install ${E_SITEFILE} || die
fi
- cd "${S}"
dodoc BUGS ChangeLog NEWS PGPKEYS PORTING README*
newdoc term/PostScript/README README-ps
newdoc term/js/README README-js
use lua && newdoc term/lua/README README-lua
+ readme.gentoo_create_doc
if use examples; then
# Demo files
@@ -216,13 +205,10 @@ src_install () {
rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
fi
+
if use doc; then
- # Manual
- dodoc docs/gnuplot.pdf
- # Tutorial
- dodoc tutorial/{tutorial.dvi,tutorial.pdf}
- # FAQ
- dodoc FAQ.pdf
+ # Manual, tutorial, FAQ
+ dodoc docs/gnuplot.pdf tutorial/{tutorial.dvi,tutorial.pdf} FAQ.pdf
# Documentation for making PostScript files
docinto psdoc
dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
@@ -235,28 +221,14 @@ src_install () {
fi
}
+src_test() {
+ GNUTERM="unknown" default_src_test
+}
+
pkg_postinst() {
use emacs && elisp-site-regen
use latex && texmf-update
-
- elog "Gnuplot no longer links against pdflib, see the ChangeLog for"
- elog "details. You can use the \"pdfcairo\" terminal for PDF output."
- use cairo || elog "It is available with USE=\"cairo\"."
-
- if use svga; then
- echo
- elog "In order to enable ordinary users to use SVGA console graphics"
- elog "gnuplot needs to be set up as setuid root. Please note that"
- elog "this is usually considered to be a security hazard."
- elog "As root, manually \"chmod u+s /usr/bin/gnuplot\"."
- fi
- if use gd; then
- echo
- elog "For font support in png/jpeg/gif output, you may have to"
- elog "set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT environment"
- elog "variables. See the FAQ file in /usr/share/doc/${PF}/"
- elog "for more information."
- fi
+ readme.gentoo_print_elog
}
pkg_postrm() {
diff --git a/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild b/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
index 2b14927c4..8bca26939 100644
--- a/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-4.7.9999.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.6_rc1.ebuild,v 1.7 2012/03/07 00:33:49 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/gnuplot/gnuplot-4.6.1-r1.ebuild,v 1.5 2013/03/07 20:35:32 ottxor Exp $
EAPI=5
-inherit elisp-common multilib wxwidgets
+inherit elisp-common eutils flag-o-matic multilib readme.gentoo toolchain-funcs wxwidgets
DESCRIPTION="Command-line driven interactive plotting program"
HOMEPAGE="http://www.gnuplot.info/"
-if [[ ${PV} = *9999 ]]; then
- inherit autotools
- #inherit cvs
- #ECVS_SERVER="gnuplot.cvs.sourceforge.net:/cvsroot/gnuplot/gnuplot"
- #ECVS_MODULE="gnuplot"
- #ECVS_BRANCH="HEAD"
- #ECVS_USER="anonymous"
- #ECVS_CVS_OPTIONS="-dP"
- inherit git-2
- EGIT_REPO_URI="git://github.com/gnuplot/gnuplot.git"
+if [[ -z ${PV%%*9999} ]]; then
+ inherit autotools cvs
+ ECVS_SERVER="gnuplot.cvs.sourceforge.net:/cvsroot/gnuplot"
+ ECVS_MODULE="gnuplot"
+ ECVS_BRANCH="HEAD"
+ ECVS_USER="anonymous"
+ ECVS_CVS_OPTIONS="-dP"
MY_P="${PN}"
+ SRC_URI=""
else
MY_P="${P/_/.}"
SRC_URI="mirror://sourceforge/gnuplot/${MY_P}.tar.gz"
@@ -28,15 +26,16 @@ fi
LICENSE="gnuplot GPL-2 bitmap? ( free-noncomm )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="bitmap cairo doc emacs examples +gd ggi latex lua qt4 readline svga thin-splines wxwidgets X xemacs"
-REQUIRED_USE="?? ( emacs xemacs )"
-RESTRICT="wxwidgets? ( test )"
+IUSE="aqua bitmap cairo doc emacs examples +gd ggi latex lua qt4 readline svga thin-splines wxwidgets X xemacs"
RDEPEND="
cairo? (
x11-libs/cairo
x11-libs/pango )
emacs? ( virtual/emacs )
+ !emacs? ( xemacs? (
+ app-editors/xemacs
+ app-xemacs/xemacs-base ) )
gd? ( media-libs/gd[png] )
ggi? ( media-libs/libggi )
latex? (
@@ -45,9 +44,9 @@ RDEPEND="
dev-tex/pgf
>=dev-texlive/texlive-latexrecommended-2008-r2 ) )
lua? ( dev-lang/lua )
- qt4? ( >=dev-qt/qtcore-4.5
- >=dev-qt/qtgui-4.5
- >=dev-qt/qtsvg-4.5 )
+ qt4? ( >=dev-qt/qtcore-4.5:4
+ >=dev-qt/qtgui-4.5:4
+ >=dev-qt/qtsvg-4.5:4 )
readline? ( sys-libs/readline )
svga? ( media-libs/svgalib )
wxwidgets? (
@@ -55,32 +54,29 @@ RDEPEND="
x11-libs/cairo
x11-libs/pango
x11-libs/gtk+:2 )
- X? ( x11-libs/libXaw )
- xemacs? (
- app-editors/xemacs
- app-xemacs/xemacs-base )"
+ X? ( x11-libs/libXaw )"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? (
virtual/latex-base
dev-texlive/texlive-latexextra
app-text/ghostscript-gpl )
- xemacs? ( app-xemacs/texinfo )"
+ !emacs? ( xemacs? ( app-xemacs/texinfo ) )"
-if [[ ${PV} = *9999 ]]; then
+if [[ -z ${PV%%*9999} ]]; then
# The live ebuild always needs an Emacs for building of gnuplot.texi
DEPEND="${DEPEND}
- !emacs? ( !xemacs? ( || ( virtual/emacs app-xemacs/texinfo ) ) )"
+ || ( virtual/emacs app-xemacs/texinfo )"
fi
S="${WORKDIR}/${MY_P}"
GP_VERSION="${PV%.*}"
-E_SITEFILE="50${PN}-gentoo.el"
+E_SITEFILE="lisp/50${PN}-gentoo.el"
TEXMF="${EPREFIX}/usr/share/texmf-site"
src_prepare() {
- if [[ ${PV} = *9999 ]]; then
+ if [[ -z ${PV%%*9999} ]]; then
local dir
for dir in config demo m4 term tutorial; do
emake -C "$dir" -f Makefile.am.in Makefile.am
@@ -91,6 +87,24 @@ src_prepare() {
# Add special version identification as required by provision 2
# of the gnuplot license
sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
+
+ # hacky workaround
+ # Please hack the buildsystem if you like
+ if use prefix && use qt4; then
+ append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir)/qt4
+ fi
+
+ DOC_CONTENTS='Gnuplot no longer links against pdflib, see the ChangeLog
+ for details. You can use the "pdfcairo" terminal for PDF output.'
+ use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
+ use svga && DOC_CONTENTS+='\n\nIn order to enable ordinary users to use
+ SVGA console graphics, gnuplot needs to be set up as setuid root.
+ Please note that this is usually considered to be a security hazard.
+ As root, manually "chmod u+s /usr/bin/gnuplot".'
+ use gd && DOC_CONTENTS+='\n\nFor font support in png/jpeg/gif output,
+ you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
+ environment variables. See the FAQ file in /usr/share/doc/${PF}/
+ for more information.'
}
src_configure() {
@@ -103,38 +117,48 @@ src_configure() {
need-wxwidgets unicode
fi
- local myconf
- myconf="${myconf} --with-lisp-files" #need to build info file
- myconf="${myconf} --with-lispdir=${EPREFIX}${SITELISP}/${PN}"
- myconf="${myconf} --without-pdf"
- myconf="${myconf} --enable-stats" #extra command save to be enabled
- myconf="${myconf} --with-texdir=${TEXMF}/tex/latex/${PN}"
- myconf="${myconf} $(use_with bitmap bitmap-terminals)"
- myconf="${myconf} $(use_with cairo)"
- myconf="${myconf} $(use_with doc tutorial)"
- myconf="${myconf} $(use_with gd)"
- myconf="${myconf} $(use_with ggi ggi ${EPREFIX}/usr/$(get_libdir))"
- myconf="${myconf} $(use_with ggi xmi ${EPREFIX}/usr/$(get_libdir))"
- myconf="${myconf} $(use_with lua)"
- myconf="${myconf} $(use_with svga linux-vga)"
- myconf="${myconf} $(use_enable thin-splines)"
- myconf="${myconf} $(use_enable wxwidgets)"
- myconf="${myconf} $(use_with X x)"
- myconf="${myconf} $(use_enable qt4 qt)"
- use readline \
- && myconf="${myconf} --with-readline=gnu" \
- || myconf="${myconf} --with-readline=builtin"
-
- local emacs=$(usev emacs || usev xemacs || echo no)
- if [[ ${PV} = *9999 && ${emacs} = no ]]; then
- # Live ebuild needs an Emacs to build gnuplot.texi
- if has_version virtual/emacs; then emacs=emacs
- elif has_version app-xemacs/texinfo; then emacs=xemacs; fi
+ tc-export CC CXX #453174
+
+ local emacs lispdir
+ if use emacs; then
+ emacs=emacs
+ lispdir="${EPREFIX}${SITELISP}/${PN}"
+ use xemacs \
+ && ewarn "USE flag \"xemacs\" ignored (superseded by \"emacs\")"
+ elif use xemacs; then
+ emacs=xemacs
+ lispdir="${EPREFIX}/usr/lib/xemacs/site-packages/${PN}"
+ else
+ emacs=no
+ lispdir=""
+ if [[ -z ${PV%%*9999} ]]; then
+ # Live ebuild needs an Emacs to build gnuplot.texi
+ if has_version virtual/emacs; then emacs=emacs
+ elif has_version app-xemacs/texinfo; then emacs=xemacs; fi
+ fi
fi
- econf ${myconf} \
+ econf \
+ --without-pdf \
+ --with-texdir="${TEXMF}/tex/latex/${PN}" \
+ --with-readline=$(usex readline gnu builtin) \
+ --with-lispdir="${lispdir}" \
+ --with$([[ -z ${lispdir} ]] && echo out)-lisp-files \
+ $(use_with bitmap bitmap-terminals) \
+ $(use_with cairo) \
+ $(use_with doc tutorial) \
+ $(use_with gd) \
+ "$(use_with ggi ggi "${EPREFIX}/usr/$(get_libdir)")" \
+ "$(use_with ggi xmi "${EPREFIX}/usr/$(get_libdir)")" \
+ $(use_with lua) \
+ $(use_with svga linux-vga) \
+ $(use_with X x) \
+ --enable-stats \
+ $(use_enable qt4 qt) \
+ $(use_enable thin-splines) \
+ $(use_enable wxwidgets) \
DIST_CONTACT="http://bugs.gentoo.org/" \
- EMACS=${emacs}
+ EMACS="${emacs}"
}
src_compile() {
@@ -150,36 +174,27 @@ src_compile() {
if use doc; then
# Avoid sandbox violation in epstopdf/ghostscript
addpredict /var/cache/fontconfig
- cd "${S}/docs"
- emake pdf
- cd "${S}/tutorial"
- emake pdf
-
- if use emacs; then
- cd "${S}/lisp"
- emake pdf
- fi
+ emake -C docs pdf
+ emake -C tutorial pdf
+ use emacs || use xemacs && emake -C lisp pdf
fi
}
src_install () {
- emake DESTDIR="${D}" install install-info
+ emake DESTDIR="${D}" install
if use emacs; then
- # info-look* is included with >=emacs-21
- rm -f "${ED}${SITELISP}/${PN}"/info-look*
-
- # Gentoo emacs site-lisp configuration
+ # Gentoo Emacs site-lisp configuration
echo "(add-to-list 'load-path \"@SITELISP@\")" > ${E_SITEFILE}
- sed '/^;; move/,+3 d' "${S}"/lisp/dotemacs >> ${E_SITEFILE} || die
+ sed '/^;; move/,+3 d' lisp/dotemacs >> ${E_SITEFILE} || die
elisp-site-file-install ${E_SITEFILE} || die
fi
- cd "${S}"
- dodoc BUGS ChangeLog NEWS PGPKEYS PORTING README* TODO
+ dodoc BUGS ChangeLog NEWS PGPKEYS PORTING README*
newdoc term/PostScript/README README-ps
newdoc term/js/README README-js
use lua && newdoc term/lua/README README-lua
+ readme.gentoo_create_doc
if use examples; then
# Demo files
@@ -188,47 +203,30 @@ src_install () {
rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/Makefile*
rm -f "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/binary*
fi
+
if use doc; then
- # Manual
- dodoc docs/gnuplot.pdf
- # Tutorial
- dodoc tutorial/{tutorial.dvi,tutorial.pdf}
- # FAQ
- dodoc FAQ.pdf
+ # Manual, tutorial, FAQ
+ dodoc docs/gnuplot.pdf tutorial/{tutorial.dvi,tutorial.pdf} FAQ.pdf
# Documentation for making PostScript files
docinto psdoc
dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
fi
- if use emacs; then
+ if use emacs || use xemacs; then
docinto emacs
dodoc lisp/ChangeLog lisp/README
use doc && dodoc lisp/gpelcard.pdf
fi
}
+src_test() {
+ GNUTERM="unknown" default_src_test
+}
+
pkg_postinst() {
use emacs && elisp-site-regen
use latex && texmf-update
-
- elog "Gnuplot no longer links against pdflib, see the ChangeLog for"
- elog "details. You can use the \"pdfcairo\" terminal for PDF output."
- use cairo || elog "It is available with USE=\"cairo\"."
-
- if use svga; then
- echo
- elog "In order to enable ordinary users to use SVGA console graphics"
- elog "gnuplot needs to be set up as setuid root. Please note that"
- elog "this is usually considered to be a security hazard."
- elog "As root, manually \"chmod u+s /usr/bin/gnuplot\"."
- fi
- if use gd; then
- echo
- elog "For font support in png/jpeg/gif output, you may have to"
- elog "set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT environment"
- elog "variables. See the FAQ file in /usr/share/doc/${PF}/"
- elog "for more information."
- fi
+ readme.gentoo_print_elog
}
pkg_postrm() {