aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-07-31 16:14:03 +0200
committerHorea Christian <horea.christ@yandex.com>2018-07-31 16:14:03 +0200
commit3fd203a789a08050fc4801d4c2c4ca9d3f40de24 (patch)
tree1d0733a05bce50350aa4d681f806f0b8b6ed578b
parentsci-libs/nipy: Version bump and removed deprecated version (diff)
downloadsci-3fd203a789a08050fc4801d4c2c4ca9d3f40de24.tar.gz
sci-3fd203a789a08050fc4801d4c2c4ca9d3f40de24.tar.bz2
sci-3fd203a789a08050fc4801d4c2c4ca9d3f40de24.zip
sci-libs/nibabel: version bump
Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--sci-libs/nibabel/Manifest1
-rw-r--r--sci-libs/nibabel/nibabel-2.3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/nibabel/Manifest b/sci-libs/nibabel/Manifest
index 405a3fd18..c495917b9 100644
--- a/sci-libs/nibabel/Manifest
+++ b/sci-libs/nibabel/Manifest
@@ -1,3 +1,4 @@
DIST nibabel-1.3.0.tar.gz 2184060 BLAKE2B d5366ced3fce28b8b3fe931988ca5562e2dfcbbfcaf5a67b9c335a90b9f15f33c559e657748b344b31c9651e3515783b3ed492d5f8f2c10e7a38f3721b2012c3 SHA512 6970a1345ce9c4ead484a15696bdcd918a292c354d0d5799359f1260a26e0b49a32507511ad5a9446a50c1d374113863e4d717c9b7bd16feecbe49d4f3da6119
DIST nibabel-2.0.1.tar.gz 3390853 BLAKE2B 862e3482f73f335207d74c1384a4c608aef0879752c722af2b5cfaba728d862168aa8ce601e840ef196dd1c5536f4ad0cb1a5613caf2ae3eedd910fed7749775 SHA512 ed7bc0d8e8b4f31ed16215fe768b5c1ed27cd6459248b8600b92455e770fc83fc81361eb9533a15ff334352e72bc0400a924df40853c2fad23940f9d3c230b14
DIST nibabel-2.1.0.tar.gz 3609462 BLAKE2B 26246f59ac6f5982884eb3316e96f6d484db763135c6dde4ed77b29576a9062aff4f7b2326e84851f5d6b3f0bb7381c7016df66a3672b5b742c8e86309bfc22f SHA512 772e216b68d4d26601d99daaa3a08b53a8d21cbbe5c5eef9e5829d10d9667850f5528f5ec02d1f98e3e98158f639c39aa806c41b28889062430c7f1f6a052f0d
+DIST nibabel-2.3.0.tar.gz 4174114 BLAKE2B 9f0561f4a82fb23302406704d5147ea248601e86ecf4a5423172ccd7cf76ef5b8a8169d29e1cb6c6c7409bb9b1a55447139447bc1813f60c3dc48dc57659bcdf SHA512 9d6cb394152b4e5d49ed750958077998185d78bd01386f267733276a68455024af83b98f9b1f1ca1528655bd4becaec8ded1a02141a8e7464b528ffcec607f4a
diff --git a/sci-libs/nibabel/nibabel-2.3.0.ebuild b/sci-libs/nibabel/nibabel-2.3.0.ebuild
new file mode 100644
index 000000000..d25151e1a
--- /dev/null
+++ b/sci-libs/nibabel/nibabel-2.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Access a cacophony of neuro-imaging file formats"
+HOMEPAGE="http://nipy.org/nibabel/"
+SRC_URI="https://github.com/nipy/nibabel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="dicom doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dicom? (
+ sci-libs/pydicom[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+ "
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ distutils-r1_install_for_testing
+ cd "${BUILD_DIR}" || die
+ echo "backend: Agg" > matplotlibrc
+ MPLCONFIGDIR=. nosetests || die
+}