aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gmail.com>2012-03-22 03:45:37 +0400
committerAndrew Savchenko <bircoph@gmail.com>2012-03-22 03:45:37 +0400
commit4d1e31f7099763ae3dbe9655b594288648ab3b02 (patch)
tree6b925b9966ee8862a6ff2a3f85fb72b71ab1ae1f
parentNew addition, written by me, #408995 (diff)
downloadsci-4d1e31f7099763ae3dbe9655b594288648ab3b02.tar.gz
sci-4d1e31f7099763ae3dbe9655b594288648ab3b02.tar.bz2
sci-4d1e31f7099763ae3dbe9655b594288648ab3b02.zip
sci-physics/root: bug fix for #406817
-rw-r--r--sci-physics/root/ChangeLog8
-rw-r--r--sci-physics/root/files/root-5.32.00-chklib64.patch23
-rw-r--r--sci-physics/root/root-5.32.01-r2.ebuild2
3 files changed, 32 insertions, 1 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index 8478ce818..de4fe3472 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -2,6 +2,14 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.93 2012/03/02 05:34:01 bicatali Exp $
+ 21 Mar 2012; Andrew Savchenko <bircoph@gmail.com>
+ +files/root-5.32.00-chklib64.patch, root-5.32.01-r2.ebuild:
+ Fix library architecture check (32/64 bit) for libraries having .so
+ file installed as an ld script instead of normal binary file.
+ See bug 406817 for details.
+ Thanks to Jean-Francois Ostiguy and Jauhien Piatlicki for their
+ major work on this bug.
+
*root-9999 (09 Mar 2012)
*root-5.32.01-r2 (09 Mar 2012)
diff --git a/sci-physics/root/files/root-5.32.00-chklib64.patch b/sci-physics/root/files/root-5.32.00-chklib64.patch
new file mode 100644
index 000000000..a5c052cdd
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-chklib64.patch
@@ -0,0 +1,23 @@
+--- configure.orig 2012-02-29 19:46:41.000000000 +0400
++++ configure 2012-03-22 03:28:43.458968696 +0400
+@@ -441,14 +441,13 @@
+ fi
+ else
+ if file $filearg $chklib64 | grep 'ASCII' > /dev/null 2>& 1 ; then
+- check_link $chklib64
+- ret=$link_result
+- else
+- logmsg " file $filearg $chklib64 | grep '64-bit'"
+- if file $filearg $chklib64 | grep '64-bit' > /dev/null 2>& 1 ; then
+- ret=1
+- fi
++ # get real binary .so name from .so ld script
++ chklib64=$(gawk '($1 == "GROUP") { print $3 }' $chklib64)
+ fi
++ logmsg " file $filearg $chklib64 | grep '64-bit'"
++ if file $filearg $chklib64 | grep '64-bit' > /dev/null 2>& 1 ; then
++ ret=1
++ fi
+ fi
+ logmsg " result: $ret"
+ if test $ret -eq 1 ; then
diff --git a/sci-physics/root/root-5.32.01-r2.ebuild b/sci-physics/root/root-5.32.01-r2.ebuild
index c0a794425..35728a97e 100644
--- a/sci-physics/root/root-5.32.01-r2.ebuild
+++ b/sci-physics/root/root-5.32.01-r2.ebuild
@@ -128,6 +128,7 @@ src_prepare() {
"${FILESDIR}"/${PN}-${PATCH_PV}-unuran.patch \
"${FILESDIR}"/${PN}-${PATCH_PV2}-afs.patch \
"${FILESDIR}"/${PN}-${PATCH_PV2}-cfitsio.patch \
+ "${FILESDIR}"/${PN}-${PATCH_PV2}-chklib64.patch \
"${FILESDIR}"/${PN}-${PATCH_PV2}-explicit-functions.patch
# make sure we use system libs and headers
@@ -138,7 +139,6 @@ src_prepare() {
rm -rf graf3d/glew/{inc,src}
rm -rf core/pcre/src
rm -rf math/unuran/src/unuran-*.tar.gz
- LANG=C LC_ALL=C find core/zip -type f -name "[a-z]*" | xargs rm
rm -rf core/lzma/src/*.tar.gz
rm graf3d/gl/{inc,src}/gl2ps.*
sed -i -e 's/^GLLIBS *:= .* $(OPENGLLIB)/& -lgl2ps/' graf3d/gl/Module.mk