aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-03-23 04:13:37 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2017-03-23 04:13:37 +0100
commit55e206075e962a1f2a2d160cdd738116924ea05e (patch)
treee9fd897b969fe2a33b1205e79c6d43ea31c29ec0
parentsys-cluster/openmpi: remove dead symlinks (diff)
parentsci-visualization/forge: Make forge use system glm and freetype, they are alr... (diff)
downloadsci-55e206075e962a1f2a2d160cdd738116924ea05e.tar.gz
sci-55e206075e962a1f2a2d160cdd738116924ea05e.tar.bz2
sci-55e206075e962a1f2a2d160cdd738116924ea05e.zip
Merge remote-tracking branch 'github/master'
-rw-r--r--sci-mathematics/gismo/files/2017.03.21/gsAxel-CMakeLists.txt.patch42
-rw-r--r--sci-mathematics/gismo/gismo-2017.03.21.ebuild13
-rw-r--r--sci-mathematics/gismo/metadata.xml1
-rw-r--r--sci-visualization/forge/forge-9999.ebuild4
4 files changed, 57 insertions, 3 deletions
diff --git a/sci-mathematics/gismo/files/2017.03.21/gsAxel-CMakeLists.txt.patch b/sci-mathematics/gismo/files/2017.03.21/gsAxel-CMakeLists.txt.patch
new file mode 100644
index 000000000..fb2347373
--- /dev/null
+++ b/sci-mathematics/gismo/files/2017.03.21/gsAxel-CMakeLists.txt.patch
@@ -0,0 +1,42 @@
+--- a/plugins/gsAxel/CMakeLists.txt 2016-10-14 02:04:17.303985030 +0200
++++ b/plugins/gsAxel/CMakeLists.txt 2016-10-14 02:06:30.251979470 +0200
+@@ -150,7 +150,7 @@
+
+ qt5_use_modules(${PROJECT_NAME} Quick)
+ qt5_use_modules(${PROJECT_NAME} Network)
+-qt5_use_modules(${PROJECT_NAME} Declarative)
++#qt5_use_modules(${PROJECT_NAME} Declarative)
+ qt5_use_modules(${PROJECT_NAME} Xml)
+ qt5_use_modules(${PROJECT_NAME} Core)
+ qt5_use_modules(${PROJECT_NAME} Gui)
+@@ -169,21 +169,21 @@
+
+ # note: policy CMP0026: The LOCATION property should not be read from target
+ #get_property(gsAxelPlugin_location TARGET ${PROJECT_NAME} PROPERTY LOCATION)
+-ADD_CUSTOM_COMMAND(
+- TARGET ${PROJECT_NAME}
+- POST_BUILD
+- COMMAND ${CMAKE_COMMAND} -E copy $<TARGET_FILE:${PROJECT_NAME}> ${AXEL_PLUGIN_DIR}
+- COMMAND ${CMAKE_COMMAND} -E echo 'The plugin has been copied to ${AXEL_PLUGIN_DIR}.'
+- )
++#ADD_CUSTOM_COMMAND(
++# TARGET ${PROJECT_NAME}
++# POST_BUILD
++# COMMAND ${CMAKE_COMMAND} -E copy $<TARGET_FILE:${PROJECT_NAME}> ${AXEL_PLUGIN_DIR}
++# COMMAND ${CMAKE_COMMAND} -E echo 'The plugin has been copied to ${AXEL_PLUGIN_DIR}.'
++# )
+
+ ## #################################################################
+ ## Install rules
+ ## #################################################################
+
+ install(TARGETS ${PROJECT_NAME}
+- RUNTIME DESTINATION include/gismo/plugins
+- LIBRARY DESTINATION include/gismo/plugins
+- ARCHIVE DESTINATION include/gismo/plugins)
++ RUNTIME DESTINATION lib/axel-plugins/
++ LIBRARY DESTINATION lib/axel-plugins/
++ ARCHIVE DESTINATION lib/axel-plugins/)
+
+
+ ##########CPACK
diff --git a/sci-mathematics/gismo/gismo-2017.03.21.ebuild b/sci-mathematics/gismo/gismo-2017.03.21.ebuild
index e3a8f1869..1e505d55f 100644
--- a/sci-mathematics/gismo/gismo-2017.03.21.ebuild
+++ b/sci-mathematics/gismo/gismo-2017.03.21.ebuild
@@ -12,16 +12,25 @@ SRC_URI="https://timeraider4u.github.io/distfiles/files/${P}.tar.gz"
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
+IUSE="doc examples vtk"
# Unbundling in progress,
# preparing local changes to get upstream
DEPEND="
- doc? ( >=app-doc/doxygen-1.8 )"
+ doc? ( >=app-doc/doxygen-1.8 )
+ vtk? ( dev-qt/qtwidgets:5
+ sci-mathematics/axel
+ sci-mathematics/axel-vtkview
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PV}/gsAxel-CMakeLists.txt.patch"
+)
src_configure() {
local mycmakeargs=(
-DGISMO_BUILD_EXAMPLES=$(usex examples)
+ -DGISMO_BUILD_AXL=$(usex vtk)
# set to same directory as the one used by einstalldocs
-DDOC_INSTALL_DIR="/usr/share/doc/${PF}"
)
diff --git a/sci-mathematics/gismo/metadata.xml b/sci-mathematics/gismo/metadata.xml
index ce39098f1..37c33ad5e 100644
--- a/sci-mathematics/gismo/metadata.xml
+++ b/sci-mathematics/gismo/metadata.xml
@@ -8,5 +8,6 @@
<use>
<flag name="doc">Build doxygen-documentation</flag>
<flag name="examples">Build examples</flag>
+ <flag name="vtk">Build plug-in for sci-mathematics/axel-vtkview</flag>
</use>
</pkgmetadata>
diff --git a/sci-visualization/forge/forge-9999.ebuild b/sci-visualization/forge/forge-9999.ebuild
index ed52bdbf5..d34b350ee 100644
--- a/sci-visualization/forge/forge-9999.ebuild
+++ b/sci-visualization/forge/forge-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -37,6 +37,8 @@ src_configure() {
local mycmakeargs=(
-DBUILD_EXAMPLES="$(examples EXAMPLES)"
-DUSE_SYSTEM_GLBINDING=ON
+ -DUSE_SYSTEM_GLM=ON
+ -DUSE_SYSTEM_FREETYPE=ON
-DFG_INSTALL_CMAKE_DIR=/usr/$(get_libdir)/cmake/Forge
)
cmake-utils_src_configure