aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortimcera <timcera@32389bae-6d03-0410-99cf-db05cde120eb>2008-07-15 01:09:49 +0000
committertimcera <timcera@32389bae-6d03-0410-99cf-db05cde120eb>2008-07-15 01:09:49 +0000
commit56e169e22ccf073f47c17292824682958b96fd61 (patch)
treee85053524e9452402f47369be55d1a77c21a856a
parentAdded pythia (6 and 8) (diff)
downloadsci-56e169e22ccf073f47c17292824682958b96fd61.tar.gz
sci-56e169e22ccf073f47c17292824682958b96fd61.tar.bz2
sci-56e169e22ccf073f47c17292824682958b96fd61.zip
sci-mathematics/mdp
* Initial ebuild git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1216 32389bae-6d03-0410-99cf-db05cde120eb
-rw-r--r--sci-mathematics/mdp/ChangeLog8
-rw-r--r--sci-mathematics/mdp/Manifest4
-rw-r--r--sci-mathematics/mdp/mdp-2.3.ebuild27
-rw-r--r--sci-mathematics/mdp/metadata.xml17
4 files changed, 56 insertions, 0 deletions
diff --git a/sci-mathematics/mdp/ChangeLog b/sci-mathematics/mdp/ChangeLog
new file mode 100644
index 000000000..5d01b4051
--- /dev/null
+++ b/sci-mathematics/mdp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-mathematics/mdp
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 15 Jul 2008; Tim Cera <timcera@earthlink.net> +mdp-2.3.ebuild,
+ +metadata.xml:
+ Initial ebuild.
+
diff --git a/sci-mathematics/mdp/Manifest b/sci-mathematics/mdp/Manifest
new file mode 100644
index 000000000..282b75f24
--- /dev/null
+++ b/sci-mathematics/mdp/Manifest
@@ -0,0 +1,4 @@
+DIST MDP-2.3.tar.gz 133071 RMD160 b807dca615c8e249a4484aa316a1b545bc89ff7c SHA1 68cbb5ba97398a3471f26aaae84ec17227bfe6a2 SHA256 e5e78670d211e1ca8ad48305fd17af141df60e830e3816a4fa00d4d5ce5318fa
+EBUILD mdp-2.3.ebuild 617 RMD160 992017ac8c8c5baae4154464d5344401f4953965 SHA1 9f91a168691071adb8c74e4908ecf3ddb0917a85 SHA256 81a4c49962341d62da1c3f138302305e7a650567d3f7cf7976fa584a5afc3eba
+MISC ChangeLog 221 RMD160 2019d0ac644a31ffe9c1b2cd81641193f5c7df31 SHA1 93e9e253540094188b09277a744fcd443604cca2 SHA256 e6d0a33d9fe457313f4b3b297e393031122069fb01b6c74b736485d960ce3593
+MISC metadata.xml 690 RMD160 ed4cf64e00309f9392595cfff9c5fae9034f252d SHA1 9db6ee0717246d2e588733dc9e5c339164c39ec2 SHA256 1dc442202528ffd5c0d9d256ad33868ad935664f30c3b143401866634af5a2d9
diff --git a/sci-mathematics/mdp/mdp-2.3.ebuild b/sci-mathematics/mdp/mdp-2.3.ebuild
new file mode 100644
index 000000000..016b46b51
--- /dev/null
+++ b/sci-mathematics/mdp/mdp-2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="A Python data processing framework."
+HOMEPAGE="http://mdp-toolkit.sourceforge.net/index.html"
+
+MY_P="${P/mdp/MDP}"
+MY_P="${MY_P/_rc/RC}"
+S="${WORKDIR}/${MY_P}"
+
+SRC_URI="mirror://sourceforge/mdp-toolkit/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND="virtual/python
+ >=dev-lang/python-2.4
+ >=dev-python/numpy-0.9.8"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ PYTHONPATH="${S}/src" "${python}" -c "import mdp;mdp.test()" || die "tests failed"
+}
+
diff --git a/sci-mathematics/mdp/metadata.xml b/sci-mathematics/mdp/metadata.xml
new file mode 100644
index 000000000..00a8ae210
--- /dev/null
+++ b/sci-mathematics/mdp/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>timcera@earthlink.net</email>
+<name>Tim Cera</name>
+</maintainer>
+<longdescription lang="en">
+ Modular toolkit for Data Processing (MDP) is a Python data processing
+ framework. Implemented algorithms include: Principal Component Analysis
+ (PCA), Independent Component Analysis (ICA), Slow Feature Analysis (SFA),
+ Independent Slow Feature Analysis (ISFA), Growing Neural Gas (GNG), Factor
+ Analysis, Fisher Discriminant Analysis (FDA), Gaussian Classifiers, and
+ Restricted Boltzmann Machines.
+</longdescription>
+</pkgmetadata>