aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2018-06-05 12:04:18 -0400
committerJustin Bronder <jsbronder@gentoo.org>2018-06-05 12:41:20 -0400
commit6ad9af83c1a0b28aa05acaacdb3c4eba1580219e (patch)
tree5cc679d16b6e1c8df5e12ac26aff9b9c4a3826c1
parentsys-cluster/openmpi: bump 2.0.4 (diff)
downloadsci-6ad9af83c1a0b28aa05acaacdb3c4eba1580219e.tar.gz
sci-6ad9af83c1a0b28aa05acaacdb3c4eba1580219e.tar.bz2
sci-6ad9af83c1a0b28aa05acaacdb3c4eba1580219e.zip
sys-cluster/openmpi: sys-cluster/pmix blocker
Quick resolution of #652432. The ideal fix would be to have openmpi use the system install of pmix, but neither pmix nor most of its dependencies are using multilib. In the meantime, resolution is blocking recent releases of openmpi (#656080). Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-cluster/openmpi/openmpi-1.10.7.ebuild3
-rw-r--r--sys-cluster/openmpi/openmpi-1.8.8.ebuild3
-rw-r--r--sys-cluster/openmpi/openmpi-2.0.4.ebuild1
-rw-r--r--sys-cluster/openmpi/openmpi-2.1.3.ebuild1
4 files changed, 6 insertions, 2 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.10.7.ebuild b/sys-cluster/openmpi/openmpi-1.10.7.ebuild
index 2c13c88e7..04274d323 100644
--- a/sys-cluster/openmpi/openmpi-1.10.7.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.10.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -48,6 +48,7 @@ REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
MPI_UNCLASSED_DEP_STR="
!>=dev-libs/intel-common-16[mpi]
+ !sys-cluster/pmix
vt? (
!dev-libs/libotf
!app-text/lcdf-typetools
diff --git a/sys-cluster/openmpi/openmpi-1.8.8.ebuild b/sys-cluster/openmpi/openmpi-1.8.8.ebuild
index 9cc09c47f..c703b9aa9 100644
--- a/sys-cluster/openmpi/openmpi-1.8.8.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.8.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -49,6 +49,7 @@ REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
MPI_UNCLASSED_DEP_STR="
!>=dev-libs/intel-common-16[mpi]
+ !sys-cluster/pmix
vt? (
!dev-libs/libotf
!app-text/lcdf-typetools
diff --git a/sys-cluster/openmpi/openmpi-2.0.4.ebuild b/sys-cluster/openmpi/openmpi-2.0.4.ebuild
index 3ef7466a7..fa5e73f45 100644
--- a/sys-cluster/openmpi/openmpi-2.0.4.ebuild
+++ b/sys-cluster/openmpi/openmpi-2.0.4.ebuild
@@ -48,6 +48,7 @@ REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
MPI_UNCLASSED_DEP_STR="
!>=dev-libs/intel-common-16[mpi]
+ !sys-cluster/pmix
"
CDEPEND="
diff --git a/sys-cluster/openmpi/openmpi-2.1.3.ebuild b/sys-cluster/openmpi/openmpi-2.1.3.ebuild
index c422e7e8e..1b746d2f1 100644
--- a/sys-cluster/openmpi/openmpi-2.1.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-2.1.3.ebuild
@@ -44,6 +44,7 @@ REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
MPI_UNCLASSED_DEP_STR="
!>=dev-libs/intel-common-16[mpi]
+ !sys-cluster/pmix
"
CDEPEND="