aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-05-05 00:28:05 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-05-05 01:04:52 -0500
commit6e280fa7307e3ea0eb41a4ed4bb49ffba0d09de2 (patch)
treeedcc01542da546e180af7af238595be84d1a62a4
parentdev-lang/vtune: version bump to 2020 update 1 (diff)
downloadsci-6e280fa7307e3ea0eb41a4ed4bb49ffba0d09de2.tar.gz
sci-6e280fa7307e3ea0eb41a4ed4bb49ffba0d09de2.tar.bz2
sci-6e280fa7307e3ea0eb41a4ed4bb49ffba0d09de2.zip
sci-libs/ipp: version bump to 2020 update 1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sci-libs/ipp/Manifest1
-rw-r--r--sci-libs/ipp/ipp-2020.1.217.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sci-libs/ipp/Manifest b/sci-libs/ipp/Manifest
index e20607e91..0007a0681 100644
--- a/sci-libs/ipp/Manifest
+++ b/sci-libs/ipp/Manifest
@@ -1,2 +1,3 @@
DIST parallel_studio_xe_2018_update2_professional_edition.tgz 3877755304 BLAKE2B c8852df23abf080f482002a37af7781b3fbae3ecec448914ea5a237fa2b925073d1a3dc2dd94ba64002ff0f6c7e9b18b25fa7ada811a83b10344eb9b92cb37ff SHA512 a9b644b0305d83a9d0daa14d146cb3ce79949db55a410afe48d62259414e6256d9ef533a04bb50807103511db2016c4abcbbf769146854a25638f402a6d0f2be
DIST parallel_studio_xe_2019_update4_professional_edition.tgz 2629662464 BLAKE2B a5619f33535063ccd7310378504ca960aa8512527cef7e0884fae5570633c1823e50ff7135adbbc571b4d47e0b6fcc01afe8639e09feb50a7f289eeec3f61ca0 SHA512 d8f6780a3671f30a1bad5d3a9792062c73b31188dc31fbd38212e98abc593f1c8f64bb970a8a4fce9ce237afef18ed38adf8fd81aa73b63ec964224590d4a34d
+DIST parallel_studio_xe_2020_update1_professional_edition.tgz 2783012958 BLAKE2B 975103ec4551a0e3bd84034ce771a5fc459d5de47f4247b5915b54d9c827e50e913f9054a103424b764f730190675d42b52a97e68551b34df6b3d8d9b922517a SHA512 00a3334bcdb8b30216ecb40fcfc709b27d043697606a53f522c90b05cf8598e1e60311d629ec17b6fe1016a7d2a27f4b428abddc9eba39badebfd8a9b53de404
diff --git a/sci-libs/ipp/ipp-2020.1.217.ebuild b/sci-libs/ipp/ipp-2020.1.217.ebuild
new file mode 100644
index 000000000..2c0be6abf
--- /dev/null
+++ b/sci-libs/ipp/ipp-2020.1.217.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+INTEL_DIST_PV=2020_update1_professional_edition
+
+inherit intel-sdp-r1
+
+DESCRIPTION="Intel Integrated Performance Primitive library"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-ipp/"
+
+IUSE="doc"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND=""
+RDEPEND="~dev-libs/intel-common-19.1.1.217[compiler]"
+
+CHECKREQS_DISK_BUILD=6500M
+
+MY_PV="$(ver_rs 2 '-')" # 2020.1-217
+
+QA_PREBUILT="*"
+
+INTEL_DIST_DAT_RPMS=(
+ "ipp-common-${MY_PV}-${MY_PV}.noarch.rpm"
+ "ipp-common-ps-${MY_PV}-${MY_PV}.noarch.rpm")
+INTEL_DIST_AMD64_RPMS=(
+ "ipp-mt-${MY_PV}-${MY_PV}.x86_64.rpm"
+ "ipp-mt-devel-${MY_PV}-${MY_PV}.x86_64.rpm"
+ "ipp-st-${MY_PV}-${MY_PV}.x86_64.rpm"
+ "ipp-st-devel-${MY_PV}-${MY_PV}.x86_64.rpm")
+INTEL_DIST_X86_RPMS=(
+ "ipp-mt-32bit-${MY_PV}-${MY_PV}.x86_64.rpm"
+ "ipp-mt-devel-32bit-${MY_PV}-${MY_PV}.x86_64.rpm"
+ "ipp-st-32bit-${MY_PV}-${MY_PV}.x86_64.rpm"
+ "ipp-st-devel-32bit-${MY_PV}-${MY_PV}.x86_64.rpm")
+
+pkg_setup() {
+ if use doc; then
+ INTEL_DIST_DAT_RPMS+=(
+ "ipp-doc-2020-${MY_PV}.noarch.rpm")
+ fi
+}