aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 11:05:05 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-01-05 19:21:54 +0100
commit704db64ed869a89a3b0df65fb1e183816604b075 (patch)
tree2e19310a7a1d113c22c79ef510ff09fb1c04cd8f
parentsci-biology/ncbi-blast+: depend on gcc<10, add 2.11.0 version (diff)
downloadsci-704db64ed869a89a3b0df65fb1e183816604b075.tar.gz
sci-704db64ed869a89a3b0df65fb1e183816604b075.tar.bz2
sci-704db64ed869a89a3b0df65fb1e183816604b075.zip
sci-biology/ncbi-tools++: depend on gcc<10, bump py targets
Closes: https://github.com/gentoo/sci/pull/1014 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild32
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-18.0.0.ebuild60
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-22.0.0.ebuild12
3 files changed, 55 insertions, 49 deletions
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
index 68341a338..0aa05e878 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-12.0.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python2_7 )
@@ -38,6 +38,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# sys-libs/db should be compiled with USE=cxx
# dev-libs/boost must have Boost.Test suite, probably dev-libs/boost[test] then?
DEPEND="
+ <sys-devel/gcc-10:=
!sci-biology/sra_sdk
app-arch/cpio
berkdb? ( sys-libs/db:4.3[cxx] )
@@ -83,7 +84,21 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-conf-opts.patch
+ "${FILESDIR}"/${P}-fix-svn-URL-upstream.patch
+ "${FILESDIR}"/${P}-linkage-tuneups.patch
+ "${FILESDIR}"/${P}-more-patches.patch
+ "${FILESDIR}"/${P}-linkage-tuneups-addons.patch
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-drop-STATIC-from-LIB.patch
+ "${FILESDIR}"/${P}-fix-install.patch
+ "${FILESDIR}"/${P}-bdb6.patch
+ "${FILESDIR}"/${P}-never_build_test_boost.patch # bug #579248
+ )
+
src_prepare() {
+ default
# filter-ldflags -Wl,--as-needed
# append-ldflags -Wl,--no-undefined
# sed -i -e 's/-print-file-name=libstdc++.a//' \
@@ -110,24 +125,11 @@ src_prepare() {
# use prefix && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/${PN}"
# The conf-opts.patch and as-needed.patch need to be adjusted for 12.0.0 line numbers
- local PATCHES=(
- "${FILESDIR}"/${P}-conf-opts.patch
- "${FILESDIR}"/${P}-fix-svn-URL-upstream.patch
- "${FILESDIR}"/${P}-linkage-tuneups.patch
- "${FILESDIR}"/${P}-more-patches.patch
- "${FILESDIR}"/${P}-linkage-tuneups-addons.patch
- "${FILESDIR}"/${P}-configure.patch
- "${FILESDIR}"/${P}-drop-STATIC-from-LIB.patch
- "${FILESDIR}"/${P}-fix-install.patch
- "${FILESDIR}"/${P}-bdb6.patch
- "${FILESDIR}"/${P}-never_build_test_boost.patch # bug #579248
- )
# "${FILESDIR}"/${P}-as-needed.patch
# "${FILESDIR}"/${P}-fix-creaders-linking.patch
# "${FILESDIR}"/${P}-fix-FreeTDS-upstream.patch
# )
# "${FILESDIR}"/${P}-support-autoconf-2.60.patch
- epatch ${PATCHES[@]}
# make sure this one is the last one and contains the actual patches applied unless we can have autoconf-2.59 or 2.60
# https://bugs.gentoo.org/show_bug.cgi?id=514706
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-18.0.0.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-18.0.0.ebuild
index c737392fd..c3014adca 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-18.0.0.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-18.0.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python2_7 )
@@ -30,13 +30,14 @@ IUSE="
berkdb boost bzip2 cppunit curl expat fastcgi fltk freetype gif
glut gnutls hdf5 icu jpeg lzo mesa mysql muparser opengl pcre png python
sablotron sqlite tiff xerces xalan xml xpm xslt X"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# sys-libs/db should be compiled with USE=cxx
# dev-libs/boost must have Boost.Test suite, probably dev-libs/boost[test] then?
DEPEND="
+ <sys-devel/gcc-10:=
!sci-biology/sra_sdk
app-arch/cpio
berkdb? ( sys-libs/db:4.3[cxx] )
@@ -82,7 +83,34 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-fix-install.patch
+ "${FILESDIR}"/${P}-never_build_test_boost.patch # bug #579248
+ "${FILESDIR}"/${P}-fix-annotwriter-linking.patch
+ "${FILESDIR}"/${P}-fix-undefined-xobjread.patch
+ "${FILESDIR}"/${P}-fix-apps-blast-linking.patch
+ "${FILESDIR}"/${P}-fix-sample-app-cgi-linking.patch
+ "${FILESDIR}"/${P}-fix-app-compartp-linking.patch
+ "${FILESDIR}"/${P}-fix-app-convert_seq-linking.patch
+ "${FILESDIR}"/${P}-fix-app-hfilter-linking.patch
+ "${FILESDIR}"/${P}-fix-app-igblast-linking.patch
+ "${FILESDIR}"/${P}-fix-ncfetch-linking.patch
+ "${FILESDIR}"/${P}-fix-netcache_cgi_sample-linking.patch
+ "${FILESDIR}"/${P}-fix-netstorage_gc-linking.patch
+ "${FILESDIR}"/${P}-fix-speedtest-linking.patch
+ "${FILESDIR}"/${P}-fix-splign-linking.patch
+ "${FILESDIR}"/${P}-fix-srcchk-linking.patch
+ "${FILESDIR}"/${P}-fix-app-rmblastn-linking.patch
+ "${FILESDIR}"/${P}-remove-old-symlinks.patch
+ "${FILESDIR}"/${P}-fix-app-table2asn-linking.patch
+ "${FILESDIR}"/${P}-fix-app-tls-linking.patch
+ "${FILESDIR}"/${P}-fix-app-vecscreen-linking.patch
+ "${FILESDIR}"/${P}-fix-app-blast_sample-linking.patch
+ )
+
src_prepare() {
+ default
# filter-ldflags -Wl,--as-needed
# append-ldflags -Wl,--no-undefined
# sed -i -e 's/-print-file-name=libstdc++.a//' \
@@ -109,33 +137,7 @@ src_prepare() {
# use prefix && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/${PN}"
# The conf-opts.patch and as-needed.patch need to be adjusted for 12.0.0 line numbers
- local PATCHES=(
- "${FILESDIR}"/${P}-configure.patch
- "${FILESDIR}"/${P}-fix-install.patch
- "${FILESDIR}"/${P}-never_build_test_boost.patch # bug #579248
- "${FILESDIR}"/${P}-fix-annotwriter-linking.patch
- "${FILESDIR}"/${P}-fix-undefined-xobjread.patch
- "${FILESDIR}"/${P}-fix-apps-blast-linking.patch
- "${FILESDIR}"/${P}-fix-sample-app-cgi-linking.patch
- "${FILESDIR}"/${P}-fix-app-compartp-linking.patch
- "${FILESDIR}"/${P}-fix-app-convert_seq-linking.patch
- "${FILESDIR}"/${P}-fix-app-hfilter-linking.patch
- "${FILESDIR}"/${P}-fix-app-igblast-linking.patch
- "${FILESDIR}"/${P}-fix-ncfetch-linking.patch
- "${FILESDIR}"/${P}-fix-netcache_cgi_sample-linking.patch
- "${FILESDIR}"/${P}-fix-netstorage_gc-linking.patch
- "${FILESDIR}"/${P}-fix-speedtest-linking.patch
- "${FILESDIR}"/${P}-fix-splign-linking.patch
- "${FILESDIR}"/${P}-fix-srcchk-linking.patch
- "${FILESDIR}"/${P}-fix-app-rmblastn-linking.patch
- "${FILESDIR}"/${P}-remove-old-symlinks.patch
- "${FILESDIR}"/${P}-fix-app-table2asn-linking.patch
- "${FILESDIR}"/${P}-fix-app-tls-linking.patch
- "${FILESDIR}"/${P}-fix-app-vecscreen-linking.patch
- "${FILESDIR}"/${P}-fix-app-blast_sample-linking.patch
- )
#ncbi-tools++-18.0.0-fix-undefined-lxncbi.patch
- epatch ${PATCHES[@]}
# make sure this one is the last one and contains the actual patches applied unless we can have autoconf-2.59 or 2.60
# https://bugs.gentoo.org/show_bug.cgi?id=514706
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-22.0.0.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-22.0.0.ebuild
index 0c0e1b24c..ffa36ad4d 100644
--- a/sci-biology/ncbi-tools++/ncbi-tools++-22.0.0.ebuild
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-22.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit eutils flag-o-matic multilib python-single-r1 toolchain-funcs
@@ -30,13 +30,14 @@ IUSE="
berkdb boost bzip2 cppunit curl expat fastcgi fltk freetype gif
glut gnutls hdf5 icu jpeg lzo mesa mysql muparser opengl pcre png python
sablotron sqlite tiff xerces xalan xml xpm xslt X"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# sys-libs/db should be compiled with USE=cxx
# dev-libs/boost must have Boost.Test suite, probably dev-libs/boost[test] then?
DEPEND="
+ <sys-devel/gcc-10:=
!sci-biology/sra_sdk
app-arch/cpio
berkdb? ( sys-libs/db:4.3[cxx] )
@@ -83,6 +84,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ default
# filter-ldflags -Wl,--as-needed
# append-ldflags -Wl,--no-undefined
# sed -i -e 's/-print-file-name=libstdc++.a//' \
@@ -254,7 +256,7 @@ src_configure() {
$(use_with mesa mesa "${EPREFIX}/usr")
$(use_with opengl glut "${EPREFIX}/usr")
$(use_with opengl glew "${EPREFIX}/usr")
- $(use_with opengl glew-mx)
+# $(use_with opengl glew-mx) can't find this with any version of media-libs/glew installed: explicitly specified, but no usable version found.
$(use_with wxwidgets wxwidgets "${EPREFIX}/usr")
$(use_with wxwidgets wxwidgets-ucs)
$(use_with freetype freetype "${EPREFIX}/usr")