aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2023-01-31 16:24:44 -0500
committerHorea Christian <chr@chymera.eu>2023-01-31 16:24:44 -0500
commit70e2057641f5a42ec3eb46de196fea112a6955d0 (patch)
treeda74105ea529eae16c4c9adb9bbbc483fe70b7de
parentdev-python/distinctipy: new package, add 1.2.2 (diff)
downloadsci-70e2057641f5a42ec3eb46de196fea112a6955d0.tar.gz
sci-70e2057641f5a42ec3eb46de196fea112a6955d0.tar.bz2
sci-70e2057641f5a42ec3eb46de196fea112a6955d0.zip
dev-python/heudiconv: new package, add 0.11.6
Signed-off-by: Horea Christian <chr@chymera.eu>
-rw-r--r--dev-python/heudiconv/Manifest1
-rw-r--r--dev-python/heudiconv/files/pynwb-2.0.0-versions.patch21
-rw-r--r--dev-python/heudiconv/files/pynwb-2.1.0-versions.patch21
-rw-r--r--dev-python/heudiconv/files/pynwb-2.2.0-versions.patch21
-rw-r--r--dev-python/heudiconv/heudiconv-0.11.6.ebuild51
-rw-r--r--dev-python/heudiconv/metadata.xml16
6 files changed, 131 insertions, 0 deletions
diff --git a/dev-python/heudiconv/Manifest b/dev-python/heudiconv/Manifest
new file mode 100644
index 000000000..55669a6ad
--- /dev/null
+++ b/dev-python/heudiconv/Manifest
@@ -0,0 +1 @@
+DIST heudiconv-0.11.6.tar.gz 9070519 BLAKE2B df6c66080bbaa89f74490f136674eabd64e9b2844ae7daef82ef4b4ef8c42ed16d3ae3b790534cc13ec121e63de8486838eb7e7becbcdbffff2df6e8bd2bd54c SHA512 c4d1f0caaed9713360ad2614bc276f2cc0e356c54b1b37c8912d762db429313c75d0f081886cb6ea0b8fd171bc5fc5a338fd3b670a8b10a3fbed0c6f9dfb7477
diff --git a/dev-python/heudiconv/files/pynwb-2.0.0-versions.patch b/dev-python/heudiconv/files/pynwb-2.0.0-versions.patch
new file mode 100644
index 000000000..d09c50594
--- /dev/null
+++ b/dev-python/heudiconv/files/pynwb-2.0.0-versions.patch
@@ -0,0 +1,21 @@
+diff --git a/setup.py b/tmp/setup.py
+index 39e75824..f7948f64 100755
+--- a/setup.py
++++ b/setup.py
+@@ -19,11 +19,11 @@ print('found these packages:', pkgs)
+ schema_dir = 'nwb-schema/core'
+
+ reqs = [
+- 'h5py>=2.9,<4',
+- 'hdmf>=3.1.1,<4',
+- 'numpy>=1.16,<1.22',
+- 'pandas>=1.0.5,<2',
+- 'python-dateutil>=2.7,<3',
++ 'h5py',
++ 'hdmf',
++ 'numpy',
++ 'pandas',
++ 'python-dateutil',
+ 'setuptools'
+ ]
+
diff --git a/dev-python/heudiconv/files/pynwb-2.1.0-versions.patch b/dev-python/heudiconv/files/pynwb-2.1.0-versions.patch
new file mode 100644
index 000000000..8c816d226
--- /dev/null
+++ b/dev-python/heudiconv/files/pynwb-2.1.0-versions.patch
@@ -0,0 +1,21 @@
+diff --git a/setup.py b/tmp/setup.py
+index 39e75824..f7948f64 100755
+--- a/setup.py
++++ b/setup.py
+@@ -19,11 +19,11 @@ print('found these packages:', pkgs)
+ schema_dir = 'nwb-schema/core'
+
+ reqs = [
+- 'h5py>=2.10,<4',
+- 'hdmf>=3.3.2,<4',
+- 'numpy>=1.16,<1.23',
+- 'pandas>=1.0.5,<2',
+- 'python-dateutil>=2.7,<3',
++ 'h5py',
++ 'hdmf',
++ 'numpy',
++ 'pandas',
++ 'python-dateutil',
+ 'setuptools'
+ ]
+
diff --git a/dev-python/heudiconv/files/pynwb-2.2.0-versions.patch b/dev-python/heudiconv/files/pynwb-2.2.0-versions.patch
new file mode 100644
index 000000000..6141f629a
--- /dev/null
+++ b/dev-python/heudiconv/files/pynwb-2.2.0-versions.patch
@@ -0,0 +1,21 @@
+diff --git a/setup.py b/tmp/setup.py
+index 39e75824..f7948f64 100755
+--- a/setup.py
++++ b/setup.py
+@@ -19,11 +19,11 @@ print('found these packages:', pkgs)
+ schema_dir = 'nwb-schema/core'
+
+ reqs = [
+- 'h5py>=2.10,<4',
+- 'hdmf>=3.4.2,<4',
+- 'numpy>=1.16,<1.24',
+- 'pandas>=1.1.5,<2',
+- 'python-dateutil>=2.7.3,<3',
++ 'h5py',
++ 'hdmf',
++ 'numpy',
++ 'pandas',
++ 'python-dateutil',
+ 'setuptools'
+ ]
+
diff --git a/dev-python/heudiconv/heudiconv-0.11.6.ebuild b/dev-python/heudiconv/heudiconv-0.11.6.ebuild
new file mode 100644
index 000000000..6c3c6b59d
--- /dev/null
+++ b/dev-python/heudiconv/heudiconv-0.11.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+inherit distutils-r1
+
+DESCRIPTION="Flexible DICOM conversion to structured directory layouts"
+HOMEPAGE="
+ https://github.com/nipy/heudiconv
+ https://heudiconv.readthedocs.io/en/latest/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sci-libs/nibabel[${PYTHON_USEDEP}]
+ sci-libs/pydicom[${PYTHON_USEDEP}]
+ sci-libs/nipype[${PYTHON_USEDEP}]
+ sci-biology/dcmstack[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/versioningit[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+# Reported upstream:
+# https://github.com/nipy/heudiconv/issues/627
+EPYTEST_DESELECT=(
+ "heudiconv/tests/test_convert.py::test_b0dwi_for_fmap"
+ "heudiconv/tests/test_dicoms.py::test_embed_dicom_and_nifti_metadata"
+ "heudiconv/tests/test_heuristics.py::test_reproin_largely_smoke"
+ "heudiconv/tests/test_heuristics.py::test_scans_keys_reproin"
+ "heudiconv/tests/test_heuristics.py::test_scout_conversion"
+ "heudiconv/tests/test_heuristics.py::test_notop[bidsoptions0]"
+ "heudiconv/tests/test_heuristics.py::test_notop[bidsoptions1]"
+ "heudiconv/tests/test_heuristics.py::test_phoenix_doc_conversion"
+ "heudiconv/tests/test_main.py::test_prepare_for_datalad"
+ "heudiconv/tests/test_main.py::test_cache"
+ "heudiconv/tests/test_regression.py::test_grouping[merged]"
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/heudiconv/metadata.xml b/dev-python/heudiconv/metadata.xml
new file mode 100644
index 000000000..a98cbf459
--- /dev/null
+++ b/dev-python/heudiconv/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">heudiconv</remote-id>
+ <remote-id type="github">nipy/heudiconv</remote-id>
+ </upstream>
+</pkgmetadata>