aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-25 20:24:30 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-09-25 20:24:30 +0000
commit72ad0b806262cbc73ca923ac1a6b50a19c3a0ef7 (patch)
tree52b15bf33bac47205febf31ce134c53b2099bcff
parentdev-python/gmsh_interop: version bump to 2019.1 (diff)
downloadsci-72ad0b806262cbc73ca923ac1a6b50a19c3a0ef7.tar.gz
sci-72ad0b806262cbc73ca923ac1a6b50a19c3a0ef7.tar.bz2
sci-72ad0b806262cbc73ca923ac1a6b50a19c3a0ef7.zip
dev-libs/boost-compute: version bump to 1.74.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 RepoMan-Options: --force Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-libs/boost-compute/Manifest1
-rw-r--r--dev-libs/boost-compute/boost-compute-1.74.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/boost-compute/Manifest b/dev-libs/boost-compute/Manifest
index cc8fea806..5a4741cbe 100644
--- a/dev-libs/boost-compute/Manifest
+++ b/dev-libs/boost-compute/Manifest
@@ -1,2 +1,3 @@
DIST boost-compute-0.4.tar.gz 282477 BLAKE2B 0160ae319c54fe93162471b4db5520f08016c1837e9d1140b2362ef403466bb7e486310784a6b29b1aefb38425e575686091f4821b5e33998592ec2ebb401f0f SHA512 7a2b4f227b2f0a46ba44aeddc4b562e125949f262ef057c92b9261c9e0fa7a824323b3dbb0bb5129b76fce4be93bbb1fccf5d681d63663731c83c3ab80e5ceed
DIST boost-compute-0.5.tar.gz 333192 BLAKE2B 08ef2978db4d3f3dce4c03c00496cb4823cf97947c1bb1780fe9a9e3d0fa8c8233e936a1bedbe16a5ef217ac5abca50bf64d3f11cde5f9d6ac4cb24b8ca9f59a SHA512 1caa067342698ec3a6a8e23aaf194f8ced41ac9d5b5a6d3d195911116af4a8a778667065681a8b0e0004887258d7cae71f3c7187ebc50c390200d66fd8688002
+DIST boost-compute-1.74.0.tar.gz 376653 BLAKE2B 72a1f76ab865e17270561699c02f6fcbfc6efa657fd5b6ce774039590bb8ca2dbd95a22721d669cbaa1764c52b63a360c12112cec19ca830288c6315c23fb888 SHA512 484fa370cc4dc98d40a6d0227d1313ff8097653390fde87928963b32bc30e43b0c81da542cc85bb17cfc6348e801d244fe177e6640f825b7899e5f0a6884ad46
diff --git a/dev-libs/boost-compute/boost-compute-1.74.0.ebuild b/dev-libs/boost-compute/boost-compute-1.74.0.ebuild
new file mode 100644
index 000000000..f01c5c268
--- /dev/null
+++ b/dev-libs/boost-compute/boost-compute-1.74.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A header-only C++ Computing Library for OpenCL"
+HOMEPAGE="https://github.com/boostorg/compute"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/boostorg/compute"
+else
+ SRC_URI="https://github.com/boostorg/compute/archive/boost-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/compute-boost-${PV}
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="benchmark bolt cache cuda eigen examples opencv qt tbb test threads vtk"
+
+RDEPEND="
+ dev-libs/boost
+ virtual/opencl
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOST_COMPUTE_USE_OFFLINE_CACHE=$(usex cache)
+ -DBOOST_COMPUTE_THREAD_SAFE=$(usex threads)
+ -DBOOST_COMPUTE_HAVE_EIGEN=$(usex eigen)
+ -DBOOST_COMPUTE_HAVE_OPENCV=$(usex opencv)
+ -DBOOST_COMPUTE_HAVE_QT=$(usex qt)
+ -DBOOST_COMPUTE_HAVE_VTK=$(usex vtk)
+ -DBOOST_COMPUTE_HAVE_CUDA=$(usex cuda)
+ -DBOOST_COMPUTE_HAVE_TBB=$(usex tbb)
+ -DBOOST_COMPUTE_HAVE_BOLT=$(usex bolt)
+ -DBOOST_COMPUTE_BUILD_TESTS=$(usex test)
+ -DBOOST_COMPUTE_BUILD_BENCHMARKS=$(usex benchmark)
+ -DBOOST_COMPUTE_BUILD_EXAMPLES=$(usex examples)
+ )
+ cmake_src_configure
+}