aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-07-14 11:24:08 -0600
committerChristoph Junghans <ottxor@gentoo.org>2014-07-14 11:24:08 -0600
commit72f0f81a5863c56c9191c49cd827d345fc55094d (patch)
treef5fa7c421051a76f43f1987f913c195e554d04d4
parentadded support for libcerf (diff)
downloadsci-72f0f81a5863c56c9191c49cd827d345fc55094d.tar.gz
sci-72f0f81a5863c56c9191c49cd827d345fc55094d.tar.bz2
sci-72f0f81a5863c56c9191c49cd827d345fc55094d.zip
fix make install/check
Package-Manager: portage-2.2.8-r1
-rw-r--r--sci-libs/libcerf/ChangeLog4
-rw-r--r--sci-libs/libcerf/files/libcerf-1.3-autotools.patch48
-rw-r--r--sci-libs/libcerf/libcerf-1.3.ebuild18
3 files changed, 55 insertions, 15 deletions
diff --git a/sci-libs/libcerf/ChangeLog b/sci-libs/libcerf/ChangeLog
index d4679f004..798151cbe 100644
--- a/sci-libs/libcerf/ChangeLog
+++ b/sci-libs/libcerf/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Jul 2014; Christoph Junghans <ottxor@gentoo.org>
+ +files/libcerf-1.3-autotools.patch, libcerf-1.3.ebuild:
+ fix make install/check
+
*libcerf-1.3 (14 Jul 2014)
14 Jul 2014; Christoph Junghans <ottxor@gentoo.org> +libcerf-1.3.ebuild,
diff --git a/sci-libs/libcerf/files/libcerf-1.3-autotools.patch b/sci-libs/libcerf/files/libcerf-1.3-autotools.patch
new file mode 100644
index 000000000..bd22e3196
--- /dev/null
+++ b/sci-libs/libcerf/files/libcerf-1.3-autotools.patch
@@ -0,0 +1,48 @@
+diff -Naur libcerf-1.3.orig/libcerf.pc.in libcerf-1.3/libcerf.pc.in
+--- libcerf-1.3.orig/libcerf.pc.in 2013-07-17 03:51:59.000000000 -0600
++++ libcerf-1.3/libcerf.pc.in 2014-07-14 11:18:01.646512503 -0600
+@@ -7,4 +7,5 @@
+ Description: Complex error function library
+ Version: @PACKAGE_VERSION@
+ Libs: -L${libdir} -lcerf
++Libs.private: -lm
+ Cflags: -I${includedir}
+diff -Naur libcerf-1.3.orig/man/Makefile.am libcerf-1.3/man/Makefile.am
+--- libcerf-1.3.orig/man/Makefile.am 2013-02-01 02:00:14.000000000 -0700
++++ libcerf-1.3/man/Makefile.am 2014-07-14 11:17:36.266182267 -0600
+@@ -19,9 +19,8 @@
+ # Website:
+ # http://apps.jcns.fz-juelich.de/libcerf
+
+-man_MANS = w_of_z.3 im_w_of_x.3 dawson.3 cdawson.3 cerf.3 cerfc.3 erfcx.3 cerfcx.3 erfi.3 cerfi.3 voigt.3
+-auxdir = $(datadir)/man/html
+-aux_DATA = w_of_z.html voigt.html dawson.html cerf.html erfcx.html erfi.html
++man_MANS = w_of_z.3 im_w_of_x.3 dawson.3 cdawson.3 libcerf-cerf.3 cerfc.3 erfcx.3 cerfcx.3 erfi.3 cerfi.3 voigt.3
++html_DATA = w_of_z.html voigt.html dawson.html cerf.html erfcx.html erfi.html
+
+ w_of_z.3 : w_of_z.pod
+ pod2man -s 3 -c "libcerf manual" $< > $@
+@@ -35,7 +34,7 @@
+ cdawson.3 : dawson.pod
+ pod2man -s 3 -c "libcerf manual" $< > $@
+
+-cerf.3 : cerf.pod
++libcerf-cerf.3 : cerf.pod
+ pod2man -s 3 -c "libcerf manual" $< > $@
+
+ cerfc.3 : cerf.pod
+diff -Naur libcerf-1.3.orig/test/Makefile.am libcerf-1.3/test/Makefile.am
+--- libcerf-1.3.orig/test/Makefile.am 2013-07-17 01:45:37.000000000 -0600
++++ libcerf-1.3/test/Makefile.am 2014-07-14 11:16:00.204932368 -0600
+@@ -20,8 +20,10 @@
+ # http://apps.jcns.fz-juelich.de/libcerf
+
+ AM_CFLAGS += -I$(srcdir)/../lib
+-noinst_PROGRAMS = test_libcerf_1 runvoigt run_w_of_z
++noinst_PROGRAMS = runvoigt run_w_of_z
+ test_libcerf_1_SOURCES = test1.c
+ runvoigt_SOURCES = runvoigt.c
+ run_w_of_z_SOURCES = run_w_of_z.c
+ AM_LDFLAGS = -lm -L../lib -lcerf
++check_PROGRAMS = test_libcerf_1
++TESTS = test_libcerf_1
diff --git a/sci-libs/libcerf/libcerf-1.3.ebuild b/sci-libs/libcerf/libcerf-1.3.ebuild
index 0be610e36..2a61e84bd 100644
--- a/sci-libs/libcerf/libcerf-1.3.ebuild
+++ b/sci-libs/libcerf/libcerf-1.3.ebuild
@@ -13,22 +13,10 @@ SRC_URI="http://apps.jcns.fz-juelich.de/src/${PN}/${P}.tgz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc static-libs"
+IUSE="doc static-libs test"
DEPEND=""
RDEPEND="${DEPEND}"
-src_install() {
- autotools-utils_src_install
-
- #avoid collision with future glibc's cerf function
- mv "${ED}"/usr/share/man/man3/{,${PN}-}cerf.3 || die
-
- #htmldir is hard-coded
- if use doc; then
- dohtml "${ED}"/usr/share/man/html/*
- fi
- rm -r "${ED}"/usr/share/man/html || die
-
- echo 'Libs.private: -lm' >> "${ED}/usr/$(get_libdir)/pkgconfig/${PN}.pc" || die
-}
+PATCHES=( "${FILESDIR}/${P}-autotools.patch" )
+AUTOTOOLS_AUTORECONF=1