aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorje_fro <je_fro@gentoo.org>2009-08-03 00:31:28 -0500
committerje_fro <je_fro@gentoo.org>2009-08-03 00:31:28 -0500
commit75d244da01ba7067037d51dbc89e288e9fd87c0c (patch)
tree0da9a8cc909539a0d873f46b425050fb0f728b26
parentremoved keywords (diff)
downloadsci-75d244da01ba7067037d51dbc89e288e9fd87c0c.tar.gz
sci-75d244da01ba7067037d51dbc89e288e9fd87c0c.tar.bz2
sci-75d244da01ba7067037d51dbc89e288e9fd87c0c.zip
Added to portage tree.
-rw-r--r--sci-chemistry/pymol/pymol-1.2.1.ebuild115
1 files changed, 0 insertions, 115 deletions
diff --git a/sci-chemistry/pymol/pymol-1.2.1.ebuild b/sci-chemistry/pymol/pymol-1.2.1.ebuild
deleted file mode 100644
index d8d77b3c4..000000000
--- a/sci-chemistry/pymol/pymol-1.2.1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-PYTHON_MODNAME="chempy pmg_tk pymol"
-APBS_PATCH="090618"
-REV="3825"
-
-inherit distutils subversion
-
-ESVN_REPO_URI="https://pymol.svn.sourceforge.net/svnroot/pymol/trunk/pymol@${REV}"
-
-DESCRIPTION="A Python-extensible molecular graphics system."
-HOMEPAGE="http://pymol.sourceforge.net/"
-SRC_URI="apbs? ( http://dev.gentooexperimental.org/~jlec/distfiles/apbs_tools.py.${APBS_PATCH}.bz2 )"
-
-LICENSE="PSF-2.2"
-IUSE="apbs shaders"
-SLOT="0"
-KEYWORDS=""
-
-RDEPEND="dev-python/pmw
- dev-python/numpy
- >=dev-lang/python-2.4[tk]
- media-libs/libpng
- sys-libs/zlib
- virtual/glut
- media-video/mpeg-tools
- apbs? ( dev-libs/maloc
- sci-chemistry/apbs
- sci-chemistry/pdb2pqr
- )"
-DEPEND="${RDEPEND}"
-
-pkg_setup(){
- python_version
-}
-
-src_unpack() {
- use apbs && unpack ${A}
- subversion_src_unpack
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-data-path.patch || die
-
- # Turn off splash screen. Please do make a project contribution
- # if you are able though.
- [[ -n ${WANT_SPLASH} ]] || epatch "${FILESDIR}"/nosplash-gentoo.patch
-
- # Respect CFLAGS
- sed -i \
- -e "s:\(ext_comp_args=\).*:\1[]:g" \
- "${S}"/setup.py
-
- use shaders && epatch "${FILESDIR}"/${P}-shaders.patch
-
- if use apbs; then
- cp -f "${WORKDIR}"/apbs_tools.py.${APBS_PATCH} modules/pmg_tk/startup/apbs_tools.py || die
- sed "s:LIBANDPYTHON:$(python_get_libdir):g" \
- -i modules/pmg_tk/startup/apbs_tools.py || die
- fi
-}
-
-src_configure() {
- :
-}
-
-src_install() {
- distutils_src_install
-
- # These environment variables should not go in the wrapper script, or else
- # it will be impossible to use the PyMOL libraries from Python.
- cat >> "${T}"/20pymol <<- EOF
- PYMOL_PATH=$(python_get_sitedir)/${PN}
- PYMOL_DATA="/usr/share/pymol/data"
- PYMOL_SCRIPTS="/usr/share/pymol/scripts"
- EOF
-
- use apbs && \
- echo "APBS_PSIZE=$(python_get_sitedir)/pdb2pqr/src/psize.py" >> "${T}"/20pymol
-
- doenvd "${T}"/20pymol || die "Failed to install env.d file."
-
- cat >> "${T}"/pymol <<- EOF
- #!/bin/sh
- ${python} -O \${PYMOL_PATH}/__init__.py \$*
- EOF
-
- dobin "${T}"/pymol || die "Failed to install wrapper."
-
- insinto /usr/share/pymol
- doins -r test data scripts || die "no shared data"
-
- insinto /usr/share/pymol/examples
- doins -r examples || die "Failed to install docs."
-
- dodoc DEVELOPERS README || die "Failed to install docs."
-
- if ! use apbs; then
- rm "${D}"$(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
- fi
-}
-
-pkg_postinst(){
- distutils_pkg_postinst
-
- # The apbs ebuild was just corrected and not bumped #213616
- if use apbs; then
- [ -e /usr/share/apbs-0.5* ] && \
- ewarn "You need to reemerge sci-chemistry/apbs!"
- fi
-}