aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelte Fennema <github-tech@jeltef.nl>2014-06-14 16:10:11 +0200
committerJelte Fennema <github-tech@jeltef.nl>2014-06-14 16:10:11 +0200
commit7ae1d96cee5e9375c8b0f4df7ef4584dc3403872 (patch)
tree44e63012108a9828f4726a140943a466569297a5
parentsci-chemistry/openbabel-python: Update PYTHON_COMPAT (diff)
downloadsci-7ae1d96cee5e9375c8b0f4df7ef4584dc3403872.tar.gz
sci-7ae1d96cee5e9375c8b0f4df7ef4584dc3403872.tar.bz2
sci-7ae1d96cee5e9375c8b0f4df7ef4584dc3403872.zip
Use CFLAGS needed to get a working executable
Package-Manager: portage-2.2.10
-rw-r--r--app-editors/neovim/ChangeLog4
-rw-r--r--app-editors/neovim/neovim-9999.ebuild7
2 files changed, 10 insertions, 1 deletions
diff --git a/app-editors/neovim/ChangeLog b/app-editors/neovim/ChangeLog
index fe88baa28..f48c78268 100644
--- a/app-editors/neovim/ChangeLog
+++ b/app-editors/neovim/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 14 Jun 2014; Jelte Fennema (JelteF) <github-tech@jeltef.nl>
+ neovim-9999.ebuild:
+ Use CFLAGS needed to get a working executable
+
10 May 2014; Jelte Fennema <github@jeltef.nl> neovim-9999.ebuild:
Add new cmsgpack and lpeg dependencies to neovim.
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 4b53e5768..dee1bc58d 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="git://github.com/neovim/neovim.git"
@@ -23,6 +23,11 @@ SLOT="0"
KEYWORDS=""
IUSE=""
+src_configure() {
+ append-flags "-DNDEBUG -Wno-error -D_FORTIFY_SOURCE=1"
+ cmake-utils_src_configure
+}
+
RDEPEND="app-admin/eselect-vi
sys-libs/ncurses"
DEPEND="${RDEPEND}