aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHonza Macháček <Hloupy.Honza@centrum.cz>2016-03-30 16:35:02 +0200
committerHonza Macháček <Hloupy.Honza@centrum.cz>2016-03-30 16:35:02 +0200
commit7ba147b184132c298c880d76e65de26c49900927 (patch)
treefe3f5803ed809300428812df2729d674b87de6af
parentsci-chemistry/nwchem version bumped to 6.6 with minor ebuild improvements; In... (diff)
parentsci-biology/artemis: install docs, cleanup ebuild and bring it in sync with s... (diff)
downloadsci-7ba147b184132c298c880d76e65de26c49900927.tar.gz
sci-7ba147b184132c298c880d76e65de26c49900927.tar.bz2
sci-7ba147b184132c298c880d76e65de26c49900927.zip
Merge branch 'master' of git+ssh://git.gentoo.org/proj/sci
-rw-r--r--sci-biology/act-bin/Manifest4
-rw-r--r--sci-biology/act-bin/act-bin-13.0.0.ebuild50
-rw-r--r--sci-biology/act-bin/metadata.xml12
-rw-r--r--sci-biology/artemis-bin/Manifest4
-rw-r--r--sci-biology/artemis-bin/artemis-bin-16.0.11.ebuild29
-rw-r--r--sci-biology/artemis/Manifest3
-rw-r--r--sci-biology/artemis/artemis-9999.ebuild19
7 files changed, 108 insertions, 13 deletions
diff --git a/sci-biology/act-bin/Manifest b/sci-biology/act-bin/Manifest
new file mode 100644
index 000000000..0ca1980c8
--- /dev/null
+++ b/sci-biology/act-bin/Manifest
@@ -0,0 +1,4 @@
+DIST act-bin-13.0.0.html_build.zip 2067725 SHA256 6a07ff70aef13e633884491c83832c150532eb0f199c0c382bab8dd4d23c3f4d SHA512 c119b12a68e52249f3a417c503129b8e538baae218cda07cd4d52b34eab9be7cdbfc86180c6675f26afe8bac556e18b66a94407f00a133c58a2e1c626f6d3571 WHIRLPOOL ca4b5367aabf22e56d394d18d0546d132400fb6d28a9433b9524f89ef181acc06406b7230563444b5a2df8dd08ea4ee740c9b94d928c6830d3e5736723071c41
+DIST act-bin-13.0.0.manual.pdf 946922 SHA256 460adb7a9c5cd6f6e5b0bf499ddec48fddf0c475824c363db9ae8e6e7b1f0ade SHA512 6af8bf6fb9cf762c078288a09cae053c9c08f5d44dd8d7324acaaa73b63d79e107a403c5dbef48a319408e0158d3ace146f6ed29d55cb553e668be711ae73914 WHIRLPOOL 01cbd2cc1139d732f61ea21782dc13935369746c1eee3b83babf07fc47f76425c00297af6c253fddbb9c4d3d16ff3ce9a03a7596dde1419f4128e30b128ec176
+DIST act_v13.jar 11005084 SHA256 5aa943b851a596d7ef9354c495d7fd7b86e05a942bab6f5db4a459fa7a580a19 SHA512 693e55d2c1f71e99f981114aa9715dac7386bedaf6bd753b49ea58f1a4ef30b5f603384cf7c5b43d3c95eebc71dc66eba04e51b0303a80566c0a8d186f473d4d WHIRLPOOL dbbaea5b3c239ceb342ad8b6cf41bdbf995abb58c5cbf28ee4330271ebcd7dc05a336f3154f88e7b0fc3b7aeab5e4a8229eb7628dfa04245b9883e08903ea1ec
+DIST sact_v13.jar 11533674 SHA256 c20b4bc0cafbd4d7aa577009c4ea89a78405230ab44b20aac01c715b03ecd8f6 SHA512 365c82933ebd4c20448a6872c4b3a5ddee313aa137bc83bf8b95a677fa7bcf32920be185971c00116d6e524357975ef633fe25496d124b6001eecdc698afcfaf WHIRLPOOL 22e576045369e251aa93a2da9081c841eaf11cc2f7804a354651ff9f40d4d36d3fed3662bd7596d3b5c633dab0ef688cecaae1bedd049d2dc97fd43f776eaeb0
diff --git a/sci-biology/act-bin/act-bin-13.0.0.ebuild b/sci-biology/act-bin/act-bin-13.0.0.ebuild
new file mode 100644
index 000000000..debf770c0
--- /dev/null
+++ b/sci-biology/act-bin/act-bin-13.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit java-pkg-2
+
+DESCRIPTION="DNA contig sequence comparison tool supplementing Artemis"
+HOMEPAGE="http://www.sanger.ac.uk/science/tools/artemis-comparison-tool-act"
+SRC_URI="ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/sact_v13.jar
+ ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/act_v13.jar
+ ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/act_manual_complete.pdf -> ${P}.manual.pdf
+ ftp://ftp.sanger.ac.uk/pub/resources/software/act/v13/act_html_build.zip -> ${P}.html_build.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ !sci-biology/artemis"
+RDEPEND="${DEPEND}
+ >=virtual/jre-1.6:*"
+
+S="${WORKDIR}"
+
+src_unpack(){
+ unzip "${DISTDIR}"/${P}.html_build.zip || die
+}
+
+src_prepare(){
+ default
+ cd act_html_build || die
+ rm -f .DS_Store HTML.index HTML.manifest || die
+}
+
+src_install(){
+ java-pkg_dojar "${DISTDIR}"/*.jar
+ dodoc "${DISTDIR}"/${P}.manual.pdf
+ insinto /usr/share/doc/"${PN}"/html
+ doins act_html_build/*
+}
+
+pkg_postinst(){
+ einfo "For BAM file support please install sci-biology/BamView"
+ einfo "You may find interesting the additional web resources:"
+ einfo "http://www.webact.org/WebACT"
+ einfo "http://www.hpa-bioinfotools.org.uk/pise/double_act.html"
+}
diff --git a/sci-biology/act-bin/metadata.xml b/sci-biology/act-bin/metadata.xml
new file mode 100644
index 000000000..f68a1b6fa
--- /dev/null
+++ b/sci-biology/act-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/artemis-bin/Manifest b/sci-biology/artemis-bin/Manifest
index 3bd261d96..5ea64c9bf 100644
--- a/sci-biology/artemis-bin/Manifest
+++ b/sci-biology/artemis-bin/Manifest
@@ -1,4 +1,6 @@
-DIST artemis.pdf 1149449 SHA256 ab573b4ea7b895cb7d2a97e4d42a71938f1feda44e2da22fe5b079583ad87ba6 SHA512 1c3056dab7239c3a68b2e76491d77612f22ac8f83eaf32e0ab0a3901e03d3c65d5ac02f5758d2d7728d94dd44c29517a498fa94a947d5d319ded43ddec4ba5fb WHIRLPOOL a75266ae72075ea7547560a9046c1e0f813956b94a5c3d9af3cd08a579ed60af842c6ece94e6b1dfa5db1820094069edb7d88b4ee6256410ebced4310739d79f
+DIST artemis-bin-16.0.11.html_build.zip 2284822 SHA256 d78ecbf8906395ca27bb3d45ebeae05a792923c98866632468dd2cd26c9bbddf SHA512 80c952fe20f98b647f38a08a469cb351bb44aa1b0a7d1a9b997fabbd37107d5d934a6d52fa2abfde243f90f4e752c99d418c4ad6b634d82de9744d089eb1cf8a WHIRLPOOL ea67f08ebf8284a186690880d7185e8991e1616f782fbde640021f44085dd6247d065e3bdae557aa10af0b2584a7f40421b9ae6199328f677f17082fa7716759
+DIST artemis-bin-16.0.11.manual.pdf 1149449 SHA256 ab573b4ea7b895cb7d2a97e4d42a71938f1feda44e2da22fe5b079583ad87ba6 SHA512 1c3056dab7239c3a68b2e76491d77612f22ac8f83eaf32e0ab0a3901e03d3c65d5ac02f5758d2d7728d94dd44c29517a498fa94a947d5d319ded43ddec4ba5fb WHIRLPOOL a75266ae72075ea7547560a9046c1e0f813956b94a5c3d9af3cd08a579ed60af842c6ece94e6b1dfa5db1820094069edb7d88b4ee6256410ebced4310739d79f
+DIST artemis-bin-16.0.11.release_notes.txt 2727 SHA256 f1facd291ffbe21758516eec421297ed8d4ddfa0f9d8ba5c201045e0aa56e648 SHA512 a9fadad47ee50a54b4036193afa6fa74e404c6b6cfd61e97885c8824f885d162c4b826910223ce1930ee55b74fe40e365c7d66019746d2fb2d70ecd3c1ceacb6 WHIRLPOOL c9fafe943b6c1e833effff8c004031d6e1156b312878aa099de57ecac6f3e2461f5675a8cf49830db7e0c8b0107516844e9c64d81d6ba8dcaf48faea912dc6d1
DIST artemis_compiled_v16.0.11.tar.gz 10722613 SHA256 0413c3f0deab4d813bc4f3af7aef8cca09ad2111b3497a0696c18a31857ffd4b SHA512 a0fb9f64b0fb869bde9fe2d1788ed938a16ea0bd75315abd93e65af89772fe9d4589b7e7813286c9b1d90f1f3133c16d9bc35ce78d1740c5631ca0e32633e421 WHIRLPOOL 0682bdfead9f95a17180816ed445226c128a804f8db3549c78627b510330694b60fd7ab0e419766bf08295f3a266eefd0dfd85c0d1244c80009b5aba0c29052a
DIST artemis_v16.0.11.jar 11292419 SHA256 f368714105646cfc31460cfcfb72b8b33490c7684ee5323d7dd181060039c80f SHA512 2fbd7c5ab12c2ca710906324eb5ee861d4821eaf923f630a800ce2b2de4e43c3971cf6c470140aa2654741ab79440a2039e8b9a17502ca955432d9ef311e9f84 WHIRLPOOL fc605625b536853ee7657b09bca93f04b9f1da67a093875bcfac0d4948f7daf020c26f0624b551aba36f21e87a7ee8b933e0e26c45a715ea2fe6cb9211d0f78f
DIST sartemis_v16.0.11.jar 11832144 SHA256 834ad0464405843904b173f38220f47867ec8eb779cb2c37d6de7ba585ef133c SHA512 6fd63ac81eed727816fe633cde3e9fab9eaf71a61c74aef4f82c8c4dc24efe93ce86494ebdf3fcb3d82e50aed5c277f383f67c1b7b68ae81cf872f2982bc1850 WHIRLPOOL 874ab57f11b011a222efd4b91278614941b096756faf0259b844453dfb082d99bae503faa2ffaeb6c4d56b4317b3bcc00a49f8b5b16d6c7cc02968b4911c503a
diff --git a/sci-biology/artemis-bin/artemis-bin-16.0.11.ebuild b/sci-biology/artemis-bin/artemis-bin-16.0.11.ebuild
index e0c9fe997..2949569f4 100644
--- a/sci-biology/artemis-bin/artemis-bin-16.0.11.ebuild
+++ b/sci-biology/artemis-bin/artemis-bin-16.0.11.ebuild
@@ -1,25 +1,27 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit java-pkg-2
MY_V="16"
-DESCRIPTION="DNA sequence viewer, annotation (Artemis) and comparison (ACT) tool"
+DESCRIPTION="DNA sequence viewer, annotation (Artemis) without comparison (ACT) tool"
HOMEPAGE="http://www.sanger.ac.uk/resources/software/artemis"
SRC_URI="ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v"${MY_V}"/v"${PV}"/artemis_compiled_v"${PV}".tar.gz
ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v"${MY_V}"/v"${PV}"/artemis_v"${PV}".jar
ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v"${MY_V}"/v"${PV}"/sartemis_v"${PV}".jar
- ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/artemis.pdf"
+ ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v"${MY_V}"/artemis_manual_complete.pdf -> ${P}.manual.pdf
+ ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v"${MY_V}"/release_notes.txt -> ${P}.release_notes.txt
+ ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v"${MY_V}"/art_html_build.zip -> ${P}.html_build.zip"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-S="${WORKDIR}"/artemis
+S="${WORKDIR}"
DEPEND="
!sci-biology/artemis
@@ -27,12 +29,24 @@ DEPEND="
RDEPEND="${DEPEND}
>=virtual/jre-1.6"
+src_unpack(){
+ unzip "${DISTDIR}"/${P}.html_build.zip || die
+}
+
+src_prepare(){
+ default
+ cd art_html_build || die
+ rm -f .DS_Store HTML.index HTML.manifest || die
+}
+
src_install(){
cp -p "${DISTDIR}"/artemis_v"${PV}".jar artemis.jar || die
java-pkg_dojar artemis.jar
cp -p "${DISTDIR}"/sartemis_v"${PV}".jar sartemis.jar || die
java-pkg_dojar sartemis.jar
- dodoc "${DISTDIR}"/artemis.pdf README
+ dodoc "${DISTDIR}"/${P}.manual.pdf "${DISTDIR}"/${P}.release_notes.txt
+ insinto /usr/share/doc/"${PN}"/html
+ doins art_html_build/*
}
# artemis_compiled_v16.0.11.tar.gz contains compiled binaries but also java *.class files
@@ -41,4 +55,7 @@ src_install(){
pkg_postinst(){
einfo "For BAM file support please install sci-biology/BamView"
+ einfo "You may find interesting the additional web resources:"
+ einfo "http://www.webact.org/WebACT"
+ einfo "http://www.hpa-bioinfotools.org.uk/pise/double_act.html"
}
diff --git a/sci-biology/artemis/Manifest b/sci-biology/artemis/Manifest
index 1c027d782..0a68bacef 100644
--- a/sci-biology/artemis/Manifest
+++ b/sci-biology/artemis/Manifest
@@ -1 +1,2 @@
-DIST artemis.pdf 1149449 SHA256 ab573b4ea7b895cb7d2a97e4d42a71938f1feda44e2da22fe5b079583ad87ba6 SHA512 1c3056dab7239c3a68b2e76491d77612f22ac8f83eaf32e0ab0a3901e03d3c65d5ac02f5758d2d7728d94dd44c29517a498fa94a947d5d319ded43ddec4ba5fb WHIRLPOOL a75266ae72075ea7547560a9046c1e0f813956b94a5c3d9af3cd08a579ed60af842c6ece94e6b1dfa5db1820094069edb7d88b4ee6256410ebced4310739d79f
+DIST artemis-9999.html_build.zip 2284822 SHA256 d78ecbf8906395ca27bb3d45ebeae05a792923c98866632468dd2cd26c9bbddf SHA512 80c952fe20f98b647f38a08a469cb351bb44aa1b0a7d1a9b997fabbd37107d5d934a6d52fa2abfde243f90f4e752c99d418c4ad6b634d82de9744d089eb1cf8a WHIRLPOOL ea67f08ebf8284a186690880d7185e8991e1616f782fbde640021f44085dd6247d065e3bdae557aa10af0b2584a7f40421b9ae6199328f677f17082fa7716759
+DIST artemis-9999.manual.pdf 1149449 SHA256 ab573b4ea7b895cb7d2a97e4d42a71938f1feda44e2da22fe5b079583ad87ba6 SHA512 1c3056dab7239c3a68b2e76491d77612f22ac8f83eaf32e0ab0a3901e03d3c65d5ac02f5758d2d7728d94dd44c29517a498fa94a947d5d319ded43ddec4ba5fb WHIRLPOOL a75266ae72075ea7547560a9046c1e0f813956b94a5c3d9af3cd08a579ed60af842c6ece94e6b1dfa5db1820094069edb7d88b4ee6256410ebced4310739d79f
diff --git a/sci-biology/artemis/artemis-9999.ebuild b/sci-biology/artemis/artemis-9999.ebuild
index 81da9cba2..d9e915dfc 100644
--- a/sci-biology/artemis/artemis-9999.ebuild
+++ b/sci-biology/artemis/artemis-9999.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit java-pkg-2 java-ant-2 git-r3
DESCRIPTION="DNA sequence viewer/annotation (Artemis) and comparison (ACT) tool"
HOMEPAGE="http://www.sanger.ac.uk/resources/software/artemis"
-SRC_URI="ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/artemis.pdf"
+SRC_URI="ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/artemis.pdf -> ${P}.manual.pdf
+ ftp://ftp.sanger.ac.uk/pub/resources/software/artemis/v16/art_html_build.zip -> ${P}.html_build.zip"
EGIT_REPO_URI="https://github.com/sanger-pathogens/Artemis"
LICENSE="GPL-2"
@@ -41,6 +42,10 @@ DEPEND="${RDEPEND}
# BamView is at http://bamview.sourceforge.net/
+src_unpack(){
+ unzip "${DISTDIR}"/art_html_build.zip || die
+}
+
src_compile(){
ant || die
}
@@ -48,7 +53,9 @@ src_compile(){
src_install(){
dobin act act.command art dnaplotter gff2embl
java-pkg_dojar ant-build/artemis.jar
- dodoc "${DISTDIR}"/artemis.pdf README
+ dodoc "${DISTDIR}"/"${P}".manual.pdf README
+ insinto /usr/share/doc/"${PN}"/html
+ doins art_html_build/*
}
# artemis_compiled_v16.0.11.tar.gz contains compiled binaries but also java *.class files
@@ -57,5 +64,7 @@ src_install(){
pkg_postinst(){
einfo "For BAM file support please install sci-biology/BamView"
- einfo " from http://bamview.sourceforge.net"
+ einfo "You may find interesting the additional web resources:"
+ einfo "http://www.webact.org/WebACT"
+ einfo "http://www.hpa-bioinfotools.org.uk/pise/double_act.html"
}