aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Mitrak <lucas@lucasmitrak.com>2021-09-19 01:37:31 -0400
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-20 10:50:51 +0200
commit8764b94161a13ddae10d7e2a24bb255cb3888aa1 (patch)
tree1653854c208f99820a80857d16a38308d9f71dc9
parentdev-python/datrie: fix homepage (diff)
downloadsci-8764b94161a13ddae10d7e2a24bb255cb3888aa1.tar.gz
sci-8764b94161a13ddae10d7e2a24bb255cb3888aa1.tar.bz2
sci-8764b94161a13ddae10d7e2a24bb255cb3888aa1.zip
sci-mathematics/acl2: Require >=dev-lisp/sbcl-1.5.2 in BDEPEND
* Require >=dev-lisp/sbcl-1.5.2 due to addition of "--tls-limit 16384" Currently, sci-mathematics/acl2-8.4 will not compile with the current stable dev-lisp/sbcl-1.4.9 due to the addition of "--tls-limit 16384" to sbcl within the created file saved_acl2. This addition is documented in the acl-8.4 release notes [1] as "Increased the number of special variables that can be created". Within sbcl, this new feature was added in version 1.5.2. The news for that version [2] reads "enhancement: command-line option '--tls-limit' can be used". Therefore attempting to use the argument "--tls-limit 16384" with sbcl versions prior to 1.5.2 causes it to fail. Thus a minimum version requirement is needed for acl2-8.4. [1] https://www.cs.utexas.edu/users/moore/acl2/v8-4/combined-manual/ index.html?topic=ACL2____NOTE-8-4 [2] http://www.sbcl.org/all-news.html Closes: https://github.com/gentoo/sci/issues/1113 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Lucas Mitrak <lucas@lucasmitrak.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-mathematics/acl2/acl2-8.4.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sci-mathematics/acl2/acl2-8.4.ebuild b/sci-mathematics/acl2/acl2-8.4.ebuild
index d0bb4eade..dfc3967ed 100644
--- a/sci-mathematics/acl2/acl2-8.4.ebuild
+++ b/sci-mathematics/acl2/acl2-8.4.ebuild
@@ -15,7 +15,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="books doc emacs"
BDEPEND="
- dev-lisp/sbcl
+ >=dev-lisp/sbcl-1.5.2
emacs? ( >=app-editors/emacs-23.1:* )
"
DEPEND="