aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-03-23 21:58:19 +0100
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-03-23 21:58:42 +0100
commit879575c1d1f78c04070e421efc8a86632806ebf8 (patch)
treeba1da3c21541fc3d8af30bf3c039f2f949ae9d35
parentsci-chemistry/ambertools masked (diff)
downloadsci-879575c1d1f78c04070e421efc8a86632806ebf8.tar.gz
sci-879575c1d1f78c04070e421efc8a86632806ebf8.tar.bz2
sci-879575c1d1f78c04070e421efc8a86632806ebf8.zip
sci-chemistry/ambertools added
-rw-r--r--sci-chemistry/ambertools/Manifest5
-rw-r--r--sci-chemistry/ambertools/ambertools-1.2.ebuild80
-rw-r--r--sci-chemistry/ambertools/files/1.2-Makefile_at.patch32
-rw-r--r--sci-chemistry/ambertools/files/1.2-configure_at.patch29
-rw-r--r--sci-chemistry/ambertools/metadata.xml8
5 files changed, 154 insertions, 0 deletions
diff --git a/sci-chemistry/ambertools/Manifest b/sci-chemistry/ambertools/Manifest
new file mode 100644
index 000000000..492da0ce5
--- /dev/null
+++ b/sci-chemistry/ambertools/Manifest
@@ -0,0 +1,5 @@
+AUX 1.2-Makefile_at.patch 830 RMD160 a6e007e5f86ea244e95b2e24955f487d2e5c4f72 SHA1 50c3d7cd3691a2d9e189f0f0c8138dbaf7111c3c SHA256 ed157fad8d36c35636ea2377723b1623669434c8ddac3c050beeea85f90cc178
+AUX 1.2-configure_at.patch 852 RMD160 57bd7b529c3be0ed5c94856f1603d5288e1fd338 SHA1 a9d7d003f6926cc79289d6924d44a5488a85f3d4 SHA256 84b219694b85edf6ed40546e769666e67844da1b68f44cfdae6c4bbf484bc627
+DIST AmberTools-1.2.tar.bz2 50621801 RMD160 01dd22dd86b90148111dc0616964384dfeda467c SHA1 001db6742fdbf0f0f8c862d1b08a59ea3da0b684 SHA256 1630e0c0135de05441226a08a5f60d861faeb7a06f5d1a4bc38e9eeff4b2f991
+EBUILD ambertools-1.2.ebuild 2030 RMD160 b4428ce5a569b03fdaa4e8cc9f36426de3ba304e SHA1 014451ef55d5060a941ee59476d61e149bd0a81b SHA256 e8479895c644cd3efc26f1daeb0ddd88c3adf31dcd92448abfa0cf69e57d9d50
+MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
diff --git a/sci-chemistry/ambertools/ambertools-1.2.ebuild b/sci-chemistry/ambertools/ambertools-1.2.ebuild
new file mode 100644
index 000000000..6275b486d
--- /dev/null
+++ b/sci-chemistry/ambertools/ambertools-1.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit toolchain-funcs eutils fortran
+
+FORTRAN="g77 gfortran ifc"
+
+DESCRIPTION="A suite of programs for carrying out complete molecular mechanics investigations"
+HOMEPAGE="http://ambermd.org/#AmberTools"
+SRC_URI="AmberTools-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mpi openmp scalapack X"
+RESTRICT="fetch"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}"/amber10
+
+pkg_nofetch() {
+ einfo "Go to ${HOMEPAGE} and get ${A}"
+ einfo "Place it in ${DISTDIR}"
+}
+
+pkg_setup() {
+ need_fortran "${FORTRAN}"
+ if use openmp &&
+ [[ $(tc-getCC)$ == *gcc* ]] &&
+ ( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
+ ! built_with_use sys-devel/gcc openmp )
+ then
+ ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
+ ewarn "If you want to build ${PN} with OpenMP, abort now,"
+ ewarn "and switch CC to an OpenMP capable compiler"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-configure_at.patch
+ epatch "${FILESDIR}"/${PV}-Makefile_at.patch
+}
+
+src_configure() {
+ cd src
+ sed -e "s:\\\\\$(LIBDIR)/arpack.a:/usr/$(get_libdir)/libarpack.a:g" \
+ -e "s:\\\\\$(LIBDIR)/lapack.a:/usr/$(get_libdir)/liblapack.a:g" \
+ -e "s:\\\\\$(LIBDIR)/blas.a:/usr/$(get_libdir)/libcblas.a:g" \
+ -e "s:\\\\\$(LIBDIR)/f2c.a:/usr/$(get_libdir)/libf2c.a:g" \
+ -e "s:CFLAGS=:CFLAGS=${CFLAGS} -DBINTRAJ :g" \
+ -e "s:FFLAGS=:FFLAGS=${FFLAGS} :g" \
+ -e "s:LDFLAGS=$ldflags:LDFLAGS=${LDFLAGS}:g" \
+ -e "s:fc=g77:fc=${FORTRANC}:g" \
+ -e "s:NETCDFLIB=\$netcdflib:NETCDFLIB=/usr/$(get_libdir)/libnetcdf.a:g" \
+ -e "s:NETCDF=\$netcdf:NETCDF=netcdf.mod:g" \
+ -e "s:-O3::g" \
+ -i configure_at
+
+ local myconf
+
+ use X || myconf="${myconf} -noX11"
+
+ for x in mpi openmp scalapack; do
+ use ${x} && myconf="${myconf} -${x}"
+ done
+
+ ./configure_at \
+ ${myconf} \
+ -nobintraj \
+ $(expr match "$(tc-getCC)" '.*\([a-z]cc\)')
+}
+
+src_compile() {
+ cd src
+ emake -f Makefile_at || die
+}
diff --git a/sci-chemistry/ambertools/files/1.2-Makefile_at.patch b/sci-chemistry/ambertools/files/1.2-Makefile_at.patch
new file mode 100644
index 000000000..36a9b75d3
--- /dev/null
+++ b/sci-chemistry/ambertools/files/1.2-Makefile_at.patch
@@ -0,0 +1,32 @@
+--- src/Makefile_at 2008-07-11 00:09:01.000000000 +0200
++++ src/Makefile_at.new 2009-03-22 20:44:20.818437912 +0100
+@@ -5,29 +5,19 @@
+ install:
+ -mkdir $(BINDIR) $(LIBDIR) $(INCDIR)
+ # utility routines and libraries:
+- (cd ucpp-1.3 && make $(UCPP) )
+- (cd byacc && make install )
+- (cd carpack && make install );
+- (cd clapack && make $(LAPACK) )
+- (cd cblas && make $(BLAS) )
+- (cd f2c && make $(F2C) )
+- (cd c9x-complex && make $(C9XCOMPLEX) )
+
+ # nab, leap, and sleap:
+- (cd cifparse && make install )
+ (cd nab && make install )
+ (cd nss && make install )
+
+ # antechamber:
+ (cd antechamber && make install )
+- (cd mopac6/src && make $(G77) )
+ (cd resp && make $(G77) )
+
+ # ptraj:
+ (cd ptraj && make install )
+
+ # miscellaneous:
+- (cd reduce && make install )
+
+ # leap and gleap:
+ (cd leap && make install )
diff --git a/sci-chemistry/ambertools/files/1.2-configure_at.patch b/sci-chemistry/ambertools/files/1.2-configure_at.patch
new file mode 100644
index 000000000..69e902131
--- /dev/null
+++ b/sci-chemistry/ambertools/files/1.2-configure_at.patch
@@ -0,0 +1,29 @@
+--- src/configure_at 2009-03-22 20:55:51.394457545 +0100
++++ src/configure_at.new 2009-03-22 20:50:01.155363408 +0100
+@@ -163,7 +163,7 @@
+ blas=install
+ f2c=install
+ ucpp=install
+-cpp="\$(BINDIR)/ucpp -l"
++cpp="/usr/bin/ucpp -l"
+
+ #-----------------------------------
+ # skip building of sleap?
+@@ -501,7 +501,7 @@
+ echo ""
+ echo "Obtaining the C++ compiler version:"
+ echo " $cplusplus -v"
+- version=`$cplusplus -v 2>&1 | grep version | cut -d' ' -f3`
++ version=`$cplusplus -v 2>&1 | grep " version " | cut -d' ' -f3`
+ echo "The version is $version"
+ majorversion=`echo $version | cut -d'.' -f1`
+ minorversion=`echo $version | cut -d'.' -f2`
+@@ -698,7 +698,7 @@
+ LDFLAGS=$ldflags
+
+ LEX= $lex
+-YACC= \$(BINDIR)/yacc
++YACC= /usr/bin/yacc
+ AR= ar rv
+ M4= $m4
+ RANLIB=$ranlib
diff --git a/sci-chemistry/ambertools/metadata.xml b/sci-chemistry/ambertools/metadata.xml
new file mode 100644
index 000000000..efb490d78
--- /dev/null
+++ b/sci-chemistry/ambertools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+</pkgmetadata>