aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-07-09 11:09:39 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2008-07-09 11:09:39 +0000
commit8ab0ac6738c29712d0410f1cd83361d9bce3f84c (patch)
treec58b95c8493f23dbc45e0562e0633d061a6cf851
parentIn the portage tree (diff)
downloadsci-8ab0ac6738c29712d0410f1cd83361d9bce3f84c.tar.gz
sci-8ab0ac6738c29712d0410f1cd83361d9bce3f84c.tar.bz2
sci-8ab0ac6738c29712d0410f1cd83361d9bce3f84c.zip
Added surfer
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1207 32389bae-6d03-0410-99cf-db05cde120eb
-rw-r--r--sci-mathematics/surfer/ChangeLog8
-rw-r--r--sci-mathematics/surfer/Manifest4
-rw-r--r--sci-mathematics/surfer/metadata.xml5
-rw-r--r--sci-mathematics/surfer/surfer-0.0.158.1.ebuild39
4 files changed, 56 insertions, 0 deletions
diff --git a/sci-mathematics/surfer/ChangeLog b/sci-mathematics/surfer/ChangeLog
new file mode 100644
index 000000000..85dc90f71
--- /dev/null
+++ b/sci-mathematics/surfer/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-mathematics/surfer
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 09 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +surfer-0.0.158.1.ebuild:
+ Initial import. See bug #210908
+
diff --git a/sci-mathematics/surfer/Manifest b/sci-mathematics/surfer/Manifest
new file mode 100644
index 000000000..a4b5325fd
--- /dev/null
+++ b/sci-mathematics/surfer/Manifest
@@ -0,0 +1,4 @@
+DIST surfer-0.0.158.1.tar.gz 1332147 RMD160 c4fa47a7e392d007c5b1e63955effe3d77eb3045 SHA1 b258eaec48c4371365db30833ba9294d09807933 SHA256 39123674d3d525277d8a685ce70ff82ad0724b26c980527ed7b47cd96baf5fc1
+EBUILD surfer-0.0.158.1.ebuild 835 RMD160 683786200cf6927ac799d24621086ddb186a74ea SHA1 f524dcccf247a6e0a8eaa948242e7529175b5686 SHA256 63252a6a18914f437fc69422019072613abc71fd9ab7ffd0efbae4bb26c071cc
+MISC ChangeLog 241 RMD160 05c08a59de1709a739584c40ceb6160ce7e23066 SHA1 e281bbf642fdaf141b545ed137b23cda37cdb915 SHA256 c053aba8f5b0d0d6bfaf9036ac1a65fcd90136a4d09a03184c68c545e0a1b518
+MISC metadata.xml 169 RMD160 a8b2671842bbec7d36e587fbf53c4eb111498347 SHA1 604114857745acb6253b121cda619e3c35771cc7 SHA256 7a9f25879c1299572cfaf2a3efb47313412564a1ef12c828224194f4e96edcd0
diff --git a/sci-mathematics/surfer/metadata.xml b/sci-mathematics/surfer/metadata.xml
new file mode 100644
index 000000000..2b0bd5314
--- /dev/null
+++ b/sci-mathematics/surfer/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+</pkgmetadata>
diff --git a/sci-mathematics/surfer/surfer-0.0.158.1.ebuild b/sci-mathematics/surfer/surfer-0.0.158.1.ebuild
new file mode 100644
index 000000000..b80215a0e
--- /dev/null
+++ b/sci-mathematics/surfer/surfer-0.0.158.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools
+
+DESCRIPTION="Frontend to surf to visualize algebraic curves and surfaces"
+HOMEPAGE="http://imaginary2008.de/surfer.php"
+SRC_URI="http://www.imaginary2008.de/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-cpp/gtkmm
+ dev-util/pkgconfig"
+
+RDEPEND="dev-cpp/gtkmm
+ media-gfx/surf"
+
+S="${WORKDIR}/${PN}-0.0.158"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # rebuild the buggy autotools
+ eautoreconf
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS
+}
+
+pkg_postinst() {
+ elog "${PN} ebuild is still under development."
+ elog "Help us improve the ebuild in:"
+ elog "http://bugs.gentoo.org/show_bug.cgi?id=210908"
+}