aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-26 11:45:50 +0000
committerAisha Tammy <gentoo@aisha.cc>2020-09-26 11:46:11 +0000
commit9a81b9caca5d3126d478a1e7faccd104864ef83d (patch)
tree99236fd1c2ebd6688cf74699420d12f1d0d1b588
parentsci-libs/nipy: PYTHON_COMPAT and live ebuild update (diff)
downloadsci-9a81b9caca5d3126d478a1e7faccd104864ef83d.tar.gz
sci-9a81b9caca5d3126d478a1e7faccd104864ef83d.tar.bz2
sci-9a81b9caca5d3126d478a1e7faccd104864ef83d.zip
dev-python/meshpy: version bump
test_torus is still failing Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-python/meshpy/Manifest3
-rw-r--r--dev-python/meshpy/meshpy-2014.1.ebuild45
-rw-r--r--dev-python/meshpy/meshpy-2018.2.1.ebuild47
-rw-r--r--dev-python/meshpy/meshpy-2018.2.1_p1.ebuild51
4 files changed, 100 insertions, 46 deletions
diff --git a/dev-python/meshpy/Manifest b/dev-python/meshpy/Manifest
index ec2e4a0c5..82dd9c18b 100644
--- a/dev-python/meshpy/Manifest
+++ b/dev-python/meshpy/Manifest
@@ -1 +1,2 @@
-DIST MeshPy-2014.1.tar.gz 1851120 BLAKE2B 1daac481c25b2605e485037842b89881d552e51e333a9cc2a52c02f0182167adda93e873eae5df4393cbeaaa3ba3ff7358267b95aa824c58bc2e800b71a4070e SHA512 d8d7823df60250382577f67bb5ffd3b6523c84729c013220eaddccfa4b227839c2e0ffb285f87e752cf0dc5292eb1e5c693d04139d2fb33a05877e0b2b1bcecc
+DIST meshpy-2018.2.1.tar.gz 493048 BLAKE2B 78a84bdf8af6228f991a8f724131dfe4f32cff156cb3c148894d4b2c07bfa30d192fc2830f5161cdc555c45aeff4a1189862a6e627bb1bfb4170b5f819b4538a SHA512 779a6fe6694eb381a32cb7304091402a11c019dbde75391c36aa9e76c57ee8b76f2215856c2998e58a7cee2b77626661f8b6518f54e5e6f2112f79acb3151d9d
+DIST meshpy-2018.2.1_p1.tar.gz 494699 BLAKE2B 2f8ca25e193437d5e4fd01c5ebbd6c1a6cb38103754455bec91d120484b89451bc9d34157a369ffcfb248ab4d993e1e0b015f20b80a558f97934f9302152aedf SHA512 9f830a32d8c7c32f34eb0dbdf7341bf49d03451957ea8b319639f6afc15fdfe43a8852a1049878fd1827822016aefca05794a588d6d3fd26c9471d52783e8f81
diff --git a/dev-python/meshpy/meshpy-2014.1.ebuild b/dev-python/meshpy/meshpy-2014.1.ebuild
deleted file mode 100644
index c46c8398a..000000000
--- a/dev-python/meshpy/meshpy-2014.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="MeshPy"
-
-DESCRIPTION="Quality triangular and tetrahedral mesh generation for Python"
-HOMEPAGE="https://mathema.tician.de/software/meshpy https://pypi.python.org/pypi/MeshPy"
-SRC_URI="mirror://pypi/M/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND="
- dev-libs/boost[python,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- sed 's: delay = 10: delay = 1:g' -i aksetup_helper.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- mkdir "${BUILD_DIR}" || die
- echo "BOOST_PYTHON_LIBNAME = [\'boost_${EPYTHON}-mt\']">> "${BUILD_DIR}"/siteconf.py
- distutils-r1_python_compile
-}
-
-python_test() {
- py.test || die
-}
diff --git a/dev-python/meshpy/meshpy-2018.2.1.ebuild b/dev-python/meshpy/meshpy-2018.2.1.ebuild
new file mode 100644
index 000000000..5df9336ad
--- /dev/null
+++ b/dev-python/meshpy/meshpy-2018.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Quality triangular and tetrahedral mesh generation for Python"
+HOMEPAGE="https://mathema.tician.de/software/meshpy
+ https://pypi.python.org/pypi/MeshPy
+"
+
+SRC_URI="https://github.com/inducer/meshpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ dev-python/gmsh_interop[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/gmsh
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed 's:delay=10:delay=1:g' -i aksetup_helper.py || die
+
+# echo "BOOST_PYTHON_LIBNAME = ['boost_${EPYTHON}-mt']">> "${S}"/siteconf.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/meshpy/meshpy-2018.2.1_p1.ebuild b/dev-python/meshpy/meshpy-2018.2.1_p1.ebuild
new file mode 100644
index 000000000..6985305a0
--- /dev/null
+++ b/dev-python/meshpy/meshpy-2018.2.1_p1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+MY_PN="MeshPy"
+
+DESCRIPTION="Quality triangular and tetrahedral mesh generation for Python"
+HOMEPAGE="https://mathema.tician.de/software/meshpy
+ https://pypi.python.org/pypi/MeshPy
+"
+
+COMMIT=6f4f9418f5f02b414d561bd8de710c4f1349ea72
+SRC_URI="https://github.com/inducer/meshpy/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ dev-python/gmsh_interop[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sci-libs/gmsh
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed 's:delay=10:delay=1:g' -i aksetup_helper.py || die
+
+# echo "BOOST_PYTHON_LIBNAME = ['boost_${EPYTHON}-mt']">> "${S}"/siteconf.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}