aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <francois.bissey@canterbury.ac.nz>2011-01-31 20:52:24 +1300
committerFrançois Bissey <francois.bissey@canterbury.ac.nz>2011-01-31 20:52:24 +1300
commita2e7b1fd96a0e951f6d744f5c5561bda87b6c063 (patch)
tree09e13b9277e8201c6211d6ae35d36232041b9fc6
parentImprovements to paraview-3.8.1 (diff)
downloadsci-a2e7b1fd96a0e951f6d744f5c5561bda87b6c063.tar.gz
sci-a2e7b1fd96a0e951f6d744f5c5561bda87b6c063.tar.bz2
sci-a2e7b1fd96a0e951f6d744f5c5561bda87b6c063.zip
Changes in vtk's handling of python-2.7
-rw-r--r--sci-libs/vtk/ChangeLog4
-rw-r--r--sci-libs/vtk/Manifest4
-rw-r--r--sci-libs/vtk/vtk-5.6.1.ebuild7
3 files changed, 9 insertions, 6 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 4aede00fc..22354938e 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.78 2010/07/24 18:25:18 jlec Exp $
+ 31 Jan 2011; François Bissey <francois.bissey@canterbury.ac.nz>
+ vtk-5.6.1.ebuild:
+ change the handling of python 2.7
+
29 Jan 2011; François Bissey <francois.bissey@canterbury.ac.nz>
vtk-5.6.1.ebuild:
Complete the removal of FindPythonLibs.cmake, so we don't have a failure at
diff --git a/sci-libs/vtk/Manifest b/sci-libs/vtk/Manifest
index d4038de39..7ce70defb 100644
--- a/sci-libs/vtk/Manifest
+++ b/sci-libs/vtk/Manifest
@@ -7,6 +7,6 @@ AUX vtk-5.6.0-odbc.patch 328 RMD160 888680f3e503f8ce624c73df9bb0402309c1384b SHA
DIST vtk-5.6.1.tar.gz 20780311 RMD160 ac1864c9604d843ab9c654c67109f4f1487acaee SHA1 6d4d0de3b468828f21f70c5af5e37f9412ee59c5 SHA256 007be00bae6c7c96f78ca9709516c993a4e3221d0b1762a7fe70e2abe407e86d
DIST vtkDocHtml-5.6.1.tar.gz 103469987 RMD160 ca6790ab0542fc91db53cc31f4ad9c3c025442d3 SHA1 9ade3dbfa76a2ac5e48dcb89398d2ffe85096a76 SHA256 2b035356743c36d982074078b2298d987e62c908285333a588addfb126f89dbe
DIST vtkdata-5.6.1.tar.gz 77991728 RMD160 b77b5f6919beae406712b93cd333dd4fad5ff3d1 SHA1 7350863d6351a961c4813ad6e73f74428307cd35 SHA256 ad2f8c99940f07f3edcbf71d838717c5c55d252cc8a67e705620858adaaa66f2
-EBUILD vtk-5.6.1.ebuild 7642 RMD160 7b381ec992d1201e17bcb4b6aef05cd68f445fbf SHA1 88abab5cc383d2945732332194376f4a45f93075 SHA256 7fc90e31b482e0926855f13f66adf64d9f495f4c1bb8d10cdd0b16e565588876
-MISC ChangeLog 14543 RMD160 608e58ee64b721a13ada0c9432c260d98ea921f0 SHA1 b3c1ace82abf01d7de70ba3a1cab47d7d7a1a050 SHA256 0f58d3c7996131b819ed8dcae47a80654ea5c8841c94cf55c422f57c3780328d
+EBUILD vtk-5.6.1.ebuild 7676 RMD160 218e5c63c1883bd3209c460b8ea28b3c6b045d7b SHA1 5669ff42c6420e536282bb06020739fbdd4cfaca SHA256 0a7c276018aca4a7a2a2fdb9be031d62df41b000af18330b2cc7b6b84a791cbb
+MISC ChangeLog 14667 RMD160 5e4aaed9c91ab4724fc4c557b19739225b41ea97 SHA1 c99bbb886caf4bba5c30d0433d626406f519af71 SHA256 b1b752b8fad4614b97f28bd763993ebbbd179e4e4a9809493e28a2391a8bf48b
MISC metadata.xml 574 RMD160 ccd927f3a387710bbf53f3f0f88c971dc814c605 SHA1 8160c080306039e0b3b18ced75ae6b81b8590ddc SHA256 9a3ca872da01db519865e7753e9c0922fe56972f4d6e27cbf5622afd41d23300
diff --git a/sci-libs/vtk/vtk-5.6.1.ebuild b/sci-libs/vtk/vtk-5.6.1.ebuild
index 4cd5ba2b3..ea4a50e5f 100644
--- a/sci-libs/vtk/vtk-5.6.1.ebuild
+++ b/sci-libs/vtk/vtk-5.6.1.ebuild
@@ -89,10 +89,9 @@ src_prepare() {
sed -e "s:@VTK_TCL_LIBRARY_DIR@:/usr/$(get_libdir):" \
-i Wrapping/Tcl/pkgIndex.tcl.in \
|| die "Failed to fix tcl pkgIndex file"
- # Remove FindPythonLibs.cmake to use the patched one from cmake
- rm CMake/FindPythonLibs.cmake
- # Also remove it from the list of files to install
- sed -i "/FindPythonLibs.cmake/d" CMakeLists.txt
+ # Patch FindPythonLibs.cmake for python-2.7, removing it does more harm than good.
+ sed -e "s:2.6 2.5 2.4 2.3 2.2 2.1 2.0:2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0:" \
+ -i CMake/FindPythonLibs.cmake || die "failed to patch for python 2.7"
}
src_configure() {