aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin <jlec@gentoo.org>2014-10-20 13:54:35 +0200
committerJustin <jlec@gentoo.org>2014-10-20 13:54:35 +0200
commita6fc4907717a900bfe2fabf897d7a1cbf3b71c47 (patch)
tree8883562e60cc21d74aeaf3d7d9d28b5b603c9fc8
parentsci-chemistry/pymol: Fix upstream buildsystem (diff)
parentdev-python/ccdproc: Version bump to 0.2.1 (diff)
downloadsci-a6fc4907717a900bfe2fabf897d7a1cbf3b71c47.tar.gz
sci-a6fc4907717a900bfe2fabf897d7a1cbf3b71c47.tar.bz2
sci-a6fc4907717a900bfe2fabf897d7a1cbf3b71c47.zip
Merge pull request #279 from sargas/ccdproc-0.2.1
dev-python/ccdproc: Version bump to 0.2.1
-rw-r--r--dev-python/ccdproc/ChangeLog9
-rw-r--r--dev-python/ccdproc/Manifest1
-rw-r--r--dev-python/ccdproc/ccdproc-0.2.1.ebuild59
3 files changed, 64 insertions, 5 deletions
diff --git a/dev-python/ccdproc/ChangeLog b/dev-python/ccdproc/ChangeLog
index ffd42973b..bb3af4dd1 100644
--- a/dev-python/ccdproc/ChangeLog
+++ b/dev-python/ccdproc/ChangeLog
@@ -2,9 +2,8 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
-*ccdproc-0.2 (08 Aug 2014)
-*ccdproc-9999 (08 Aug 2014)
+*ccdproc-0.2.1 (18 Oct 2014)
- 08 Aug 2014; Joseph Jon Booker <joe@neoturbine.net> +ccdproc-0.2.ebuild,
- +ccdproc-9999.ebuild, +metadata.xml:
- dev-python/ccdproc: Add ccdproc package
+ 18 Oct 2014; Joseph Jon Booker <joe@neoturbine.net> +ccdproc-0.2.1.ebuild,
+ -ChangeLog:
+ dev-python/ccdproc: Version bump to 0.2.1
diff --git a/dev-python/ccdproc/Manifest b/dev-python/ccdproc/Manifest
index 1c2be2d26..942838314 100644
--- a/dev-python/ccdproc/Manifest
+++ b/dev-python/ccdproc/Manifest
@@ -1 +1,2 @@
+DIST ccdproc-0.2.1.tar.gz 600743 SHA256 b4f23a5e6e1de6d88cd2b4a38398a922ae009896f807366d8625140320557f27 SHA512 50640b019c6d72d2c8e0a3dcb8d9021216fca606a5cdea90f65bb3241ebffe9d369c8d4697fd4ed1cdb158f4c1add514683d232ba8db5cb088580d64f8b4a57d WHIRLPOOL a5e12e25d242b9a2dc90facbcabb382c02683b166ed1f0090dbf38f8e9a9e22f89f5f11b14394f311392f942ae27438f451bc4d3eb51d5ba93093d96a796ef62
DIST ccdproc-0.2.tar.gz 480410 SHA256 4be572f7fb6d87ff4ded744485fe76a699a132ed6777d3971eb88dcfe5c34d3a SHA512 36e8938ac29e317ce1d4055ed1ba8a985499904c5caea06bbd0b50b8abf31e9248d46754bf7c2f721e0174f51af27cc94870db0e48dee2a8adde620fe9c5f376 WHIRLPOOL 0bb93d0712d40641412a610231264315d50389c71c70482af73b56ff27d27b9af62e15bd683d12461700df25c374356de63e8f80d4fdf7fad9335642a387792b
diff --git a/dev-python/ccdproc/ccdproc-0.2.1.ebuild b/dev-python/ccdproc/ccdproc-0.2.1.ebuild
new file mode 100644
index 000000000..1fd337a3c
--- /dev/null
+++ b/dev-python/ccdproc/ccdproc-0.2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+inherit distutils-r1
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/astropy/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Astropy affiliated package for reducing optical/IR CCD data"
+HOMEPAGE="https://github.com/astropy/ccdproc"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+DOCS=( README.rst )
+
+RDEPEND="
+ >=dev-python/astropy-0.4[${PYTHON_USEDEP}]
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e '/import ah_bootstrap/d' -i setup.py || die "Removing ah_bootstrap failed"
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}" || die
+ "${EPYTHON}" -c "import ${PN}, sys;r = ${PN}.test(verbose=True);sys.exit(r)" \
+ || die "tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}