aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius.kk@gmail.com>2012-11-10 02:37:19 -0800
committerKacper Kowalik <xarthisius.kk@gmail.com>2012-11-10 02:37:19 -0800
commitacd177afcfc71e90c25a6951c6fee33972043c0d (patch)
treef12481c187db4fc78b261f0733522770a7569fab
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci; github.c... (diff)
parentProper DEPEND list and eclass info (diff)
downloadsci-acd177afcfc71e90c25a6951c6fee33972043c0d.tar.gz
sci-acd177afcfc71e90c25a6951c6fee33972043c0d.tar.bz2
sci-acd177afcfc71e90c25a6951c6fee33972043c0d.zip
Merge pull request #24 from TheChymera/master
New ebuild for psychopy by Horea Christian
-rw-r--r--sci-biology/psychopy/Manifest1
-rw-r--r--sci-biology/psychopy/psychopy-1.75.01.ebuild42
-rw-r--r--sci-biology/psychopy/psychopy-9999.ebuild29
3 files changed, 72 insertions, 0 deletions
diff --git a/sci-biology/psychopy/Manifest b/sci-biology/psychopy/Manifest
new file mode 100644
index 000000000..ced74875f
--- /dev/null
+++ b/sci-biology/psychopy/Manifest
@@ -0,0 +1 @@
+DIST PsychoPy-1.75.01.zip 3512277 SHA256 c86c617bcd9a215f1fe3d1420563a9bc1c8c6707b477481f885437a68a56d211 SHA512 3a57dcff426d9bbeeababd7699d2fe99fc36025d45b4f52abb8ae4544454314dacb00b52b16f94168c86a255f9ac469fad297590b6e466931d5de12e7520f684 WHIRLPOOL a0f258c293937efbd6cbbc325663a1de93961de349e0113562c20d54a957c686590256d7c7a2e0ebea7a497090569ba0e2b777165e9cfe908af82a90991bb939
diff --git a/sci-biology/psychopy/psychopy-1.75.01.ebuild b/sci-biology/psychopy/psychopy-1.75.01.ebuild
new file mode 100644
index 000000000..6b341f50b
--- /dev/null
+++ b/sci-biology/psychopy/psychopy-1.75.01.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
+DISTUTILS_SRC_TEST="py.test"
+
+inherit distutils
+
+MY_P="PsychoPy-${PV}"
+
+DESCRIPTION="Python experimental psychology toolkit"
+HOMEPAGE="http://www.psychopy.org/"
+SRC_URI="http://psychopy.googlecode.com/files/${MY_P}.zip"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/numpy[lapack]
+ sci-libs/scipy
+ dev-python/matplotlib
+ dev-python/pyopengl
+ dev-python/imaging
+ dev-python/wxpython
+ dev-python/setuptools
+ dev-python/lxml
+ app-admin/eselect
+ dev-python/pyglet
+ dev-python/pygame"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ test? ( ${RDEPEND} )"
+
+RESTRICT="test" # interactive, opens lots of windows
+
+S="${WORKDIR}/${MY_P}"
diff --git a/sci-biology/psychopy/psychopy-9999.ebuild b/sci-biology/psychopy/psychopy-9999.ebuild
new file mode 100644
index 000000000..9165bb54f
--- /dev/null
+++ b/sci-biology/psychopy/psychopy-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit eutils distutils git-2
+
+DESCRIPTION="Python experiemntal psychology toolkit"
+HOMEPAGE="http://www.psychopy.org/"
+EGIT_REPO_URI="https://github.com/psychopy/psychopy"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/numpy[lapack]
+ sci-libs/scipy
+ dev-python/matplotlib
+ dev-python/pyopengl
+ dev-python/imaging
+ dev-python/wxpython
+ dev-python/setuptools
+ dev-python/lxml"
+
+RDEPEND="${DEPEND}
+ app-admin/eselect
+ dev-python/pyglet
+ dev-python/pygame
+ "