aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWitold Pilat <witold.pilat@gmail.com>2014-07-07 05:40:44 +0200
committerWitold Pilat <witold.pilat@gmail.com>2014-07-07 05:40:44 +0200
commitb6f4fe94c0bf11d823d61e21c82a6c005b90fed0 (patch)
tree92263778d30762a20a86116085c095ceab3ec76b
parentdev-python/bokeh: dev-python/bokeh: Copy latest ebuild from portage (diff)
downloadsci-b6f4fe94c0bf11d823d61e21c82a6c005b90fed0.tar.gz
sci-b6f4fe94c0bf11d823d61e21c82a6c005b90fed0.tar.bz2
sci-b6f4fe94c0bf11d823d61e21c82a6c005b90fed0.zip
dev-python/bokeh: dev-python/bokeh: New version with python3 support for bug #516052
Package-Manager: portage-2.2.10
-rw-r--r--dev-python/bokeh/ChangeLog11
-rw-r--r--dev-python/bokeh/Manifest2
-rw-r--r--dev-python/bokeh/bokeh-0.4.4.ebuild (renamed from dev-python/bokeh/bokeh-0.4.2.ebuild)57
-rw-r--r--dev-python/bokeh/files/bokeh-0.4.4-fix_test_object.patch32
-rw-r--r--dev-python/bokeh/metadata.xml3
5 files changed, 94 insertions, 11 deletions
diff --git a/dev-python/bokeh/ChangeLog b/dev-python/bokeh/ChangeLog
index e69de29bb..0dac60237 100644
--- a/dev-python/bokeh/ChangeLog
+++ b/dev-python/bokeh/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/bokeh
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*bokeh-0.4.4 (07 Jul 2014)
+
+ 07 Jul 2014; Witold Pilat (fau) <witold.pilat@gmail.com> +bokeh-0.4.4.ebuild,
+ +files/bokeh-0.4.4-fix_test_object.patch, -ChangeLog, -Manifest,
+ -bokeh-0.4.2.ebuild, metadata.xml:
+ dev-python/bokeh: dev-python/bokeh: New version with python3 support for bug
+ #516052
diff --git a/dev-python/bokeh/Manifest b/dev-python/bokeh/Manifest
index 19d286e33..2c752eaeb 100644
--- a/dev-python/bokeh/Manifest
+++ b/dev-python/bokeh/Manifest
@@ -1 +1 @@
-DIST bokeh-0.4.2.tar.gz 21640415 SHA256 663d2a32cd17a2f9bcec43d63a05f148b551c17856e859fef2a12ddffbd7da5a SHA512 0cb6fd38d17a1067cb6941c44cde6b7c8782124be3f4baa66f51db066da1454461f338c8e342dc803a5c41163f810dfb9ecf422e26674acbf7447b899c3b7175 WHIRLPOOL da954d5e3be5014c1961cfddd11c220970c3e4ac829285dab9492e692b74f99811cb7b49fd02f40e585190c9616eb4e501e62f8d2d56715d4b314f3f6a66ce4f
+DIST bokeh-0.4.4.tar.gz 40315677 SHA256 ca989c9d554d07bface516ad9eccda39cf999c244c85ca52881b10fea0466417 SHA512 46dfe615a53996158b9e17e1f5cb46b401d017e18638457905f283cb3bb1d734207b370f3b3d78850e8e75ccfbe47736beba8b5730296f5db2677d5eb92423e9 WHIRLPOOL b0c56b43091d171b7b85ccec66f0986bf747479f8fbb20a4758a9e788533f34578c5ce6f87f704c34e27030a58890733003bee23ad85d9cf6ac8a68e6d80bf2c
diff --git a/dev-python/bokeh/bokeh-0.4.2.ebuild b/dev-python/bokeh/bokeh-0.4.4.ebuild
index 8f865c04b..22d38c588 100644
--- a/dev-python/bokeh/bokeh-0.4.2.ebuild
+++ b/dev-python/bokeh/bokeh-0.4.4.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -15,13 +15,11 @@ SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.g
SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
+IUSE="examples test chaco"
+# docs require napoleon sphinx extension which will be included in next sphinx release
RDEPEND="
- >=dev-python/chaco-4.4[$(python_gen_usedep 'python2_7')]
>=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/gevent-0.13.8[$(python_gen_usedep 'python2_7')]
- >=dev-python/gevent-websocket-0.3.6[$(python_gen_usedep 'python2_7')]
>=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
>=dev-python/itsdangerous-0.23[${PYTHON_USEDEP}]
>=dev-python/jinja-2.7[${PYTHON_USEDEP}]
@@ -37,25 +35,64 @@ RDEPEND="
>=dev-python/redis-py-2.7.6[${PYTHON_USEDEP}]
>=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
>=dev-python/six-1.5.2[${PYTHON_USEDEP}]
- >=dev-python/traits-4.4[$(python_gen_usedep 'python2_7')]
>=dev-python/werkzeug-0.9.1[${PYTHON_USEDEP}]
- >=virtual/python-argparse-1[${PYTHON_USEDEP}]
-"
+ $(python_gen_cond_dep '>=dev-python/gevent-1.0[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep '>=dev-python/gevent-websocket-0.9.2[${PYTHON_USEDEP}]' python2_7)
+ chaco? (
+ $(python_gen_cond_dep '>=dev-python/traits-4.4[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep '>=dev-python/chaco-4.4[${PYTHON_USEDEP}]' python2_7)
+ )
+"
# testing server: needs websocket not in portage yet
# >=dev-python/websocket[${PYTHON_USEDEP}]
-DEPEND="${RDEPEND}
+# hdf5 backend: needs arraymanagement not in portage yet
+DEPEND="
test? (
+ ${RDEPEND}
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
>=dev-python/colorama-0.2.7[${PYTHON_USEDEP}]
)
"
+DOCS=( CHANGELOG QUICKSTART.md README.md )
+
+python_prepare_all() {
+ # Fix test_references_by_ref_by_value from test_object.py
+ local PATCHES=( "${FILESDIR}"/${P}-fix_test_object.patch )
+ # Remove broken test case
+ sed -i -e "s:MetaTest:_&:" bokeh/tests/test_bokeh_init.py || die
+
+ if ! use chaco; then
+ sed -i -e "/'bokeh.chaco_gg'/d" setup.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
+
python_test() {
cd "${BUILD_DIR}"/lib || die
# exclude server tests for now
nosetests -v \
-e multiuser_auth_test \
- -e wsmanager_test \
-e usermodel_test \
|| die
}
+
+pkg_postinst() {
+ elog "websockets work only with python2_7"
+ local chaco_msg="chaco useflag doesn't affect python targets other than python2_7"
+ if use chaco; then
+ if use python_targets_python2_7; then
+ elog "${chaco_msg}"
+ else
+ ewarn "${chaco_msg}"
+ fi
+ fi
+}
diff --git a/dev-python/bokeh/files/bokeh-0.4.4-fix_test_object.patch b/dev-python/bokeh/files/bokeh-0.4.4-fix_test_object.patch
new file mode 100644
index 000000000..24183d831
--- /dev/null
+++ b/dev-python/bokeh/files/bokeh-0.4.4-fix_test_object.patch
@@ -0,0 +1,32 @@
+commit 9606ae037dbd9ee888f9763a1bd9c6d7fc3b5824
+Author: Bryan Van de Ven <bryanv@continuum.io>
+Date: Sat Apr 19 10:05:35 2014 -0500
+
+ fix #548
+
+diff --git a/bokeh/plotobject.py b/bokeh/plotobject.py
+index 7485d27..92ae2dd 100644
+--- a/bokeh/plotobject.py
++++ b/bokeh/plotobject.py
+@@ -220,7 +220,7 @@ class PlotObject(HasProps):
+
+ def references(self):
+ """Returns all ``PlotObjects`` that this object has references to. """
+- return self.collect_plot_objects(self)
++ return set(self.collect_plot_objects(self))
+
+ #---------------------------------------------------------------------
+ # View Model connection methods
+diff --git a/bokeh/tests/test_objects.py b/bokeh/tests/test_objects.py
+index 1a17f69..75d5678 100644
+--- a/bokeh/tests/test_objects.py
++++ b/bokeh/tests/test_objects.py
+@@ -242,7 +242,7 @@ class TestPlotObject(unittest.TestCase):
+ x2 = X2(y=y, z2=z2)
+
+ # TODO: self.assertEqual(x1.references(), [t1, y, t2, x1])
+- self.assertEqual(x2.references(), [t1, y, t2, z2, x2])
++ self.assertEqual(x2.references(), set([t1, y, t2, z2, x2]))
+
+ if __name__ == "__main__":
+ unittest.main()
diff --git a/dev-python/bokeh/metadata.xml b/dev-python/bokeh/metadata.xml
index c43dd65b0..b59e358e7 100644
--- a/dev-python/bokeh/metadata.xml
+++ b/dev-python/bokeh/metadata.xml
@@ -9,4 +9,7 @@
style of Protovis/D3, while delivering high-performance
interactivity over large data to thin clients.
</longdescription>
+<use>
+ <flag name="chaco">Enable interface for implementing qplot and ggplot like functionality using chaco</flag>
+</use>
</pkgmetadata>