aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-01-22 13:17:12 +0100
committerMartin Mokrejs <mmokrejs@fold.natur.cuni.cz>2019-01-22 13:18:03 +0100
commitbb7161d41c11db40813d5ad231aeaa60b6db3b86 (patch)
treeaf853fbd79fb7b4354ce5a72f91e1bde649000f4
parentapp-arch/libdeflate: new package (diff)
downloadsci-bb7161d41c11db40813d5ad231aeaa60b6db3b86.tar.gz
sci-bb7161d41c11db40813d5ad231aeaa60b6db3b86.tar.bz2
sci-bb7161d41c11db40813d5ad231aeaa60b6db3b86.zip
sci-libs/io_lib: version bump
Add a new version with experimental CRAM support. Force dependency on libdeflate although it could/should be maybe protected by USE flag. However, it is recommended by upstream authors. https://github.com/jkbonfield/io_lib/issues/11 https://github.com/jkbonfield/io_lib/issues/12 https://github.com/jkbonfield/io_lib/issues/13 Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
-rw-r--r--sci-libs/io_lib/Manifest2
-rw-r--r--sci-libs/io_lib/io_lib-1.14.11.ebuild71
-rw-r--r--sci-libs/io_lib/io_lib-1.14.7.ebuild28
3 files changed, 72 insertions, 29 deletions
diff --git a/sci-libs/io_lib/Manifest b/sci-libs/io_lib/Manifest
index c460158b2..bf2a90999 100644
--- a/sci-libs/io_lib/Manifest
+++ b/sci-libs/io_lib/Manifest
@@ -1,2 +1,2 @@
-DIST io_lib-1.14.7.tar.gz 2177248 BLAKE2B 6c1a8133a0f0edd253bf0c475cb206294f95659efc82679034f36d8eb963e4020b953f18c0ccfefa6dad61daffbd054513d36a7bdf0e725b8c5a943d98e0d567 SHA512 c1021f0a0dd284e8abbf9cc1dd11995550cf6621455c873effaab56b573fee053ed9e55879003c735c26c403a0aa34d75be87d337cd515cc912706abe7e08665
+DIST io_lib-1.14.11.tar.gz 3391926 BLAKE2B 42ac0408101d39c00d6480f4511bc4b9173a564da31901976cde41ccc81d4da3ed3abb012170365a28ee20605417237d97b4667159182d67f5521a9a894eedac SHA512 b20c9b407b4708909d9172ba835f4ae40f94dfc8967f3db82f658053dcd689986d44a9b69645ca43e9e07c3c93e0a0c1ff3eaacf55a756f76d46d19b050e5879
DIST io_lib-1.14.9.tar.gz 1708486 BLAKE2B 47cf8cba2540d889590cb06b8be75c190579214ffbef2e6ba9dda6e99475699fef3da7f7c7732f83128dc959e24c3fd902c1aaa3f7e5b9ac2a092c89865b4dd1 SHA512 425fde2e5beed1737406dca7d62883053183c099160556bbf5c058de8808ea59739b15758e99116d40bb38020791a28822e5ba4dd30de7ec19975379bbbaf054
diff --git a/sci-libs/io_lib/io_lib-1.14.11.ebuild b/sci-libs/io_lib/io_lib-1.14.11.ebuild
new file mode 100644
index 000000000..73263df65
--- /dev/null
+++ b/sci-libs/io_lib/io_lib-1.14.11.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils eutils versionator
+MY_PV=$(replace_all_version_separators '-')
+
+DESCRIPTION="General purpose trace and experiment file reading/writing interface"
+HOMEPAGE="https://github.com/jkbonfield/io_lib
+ http://staden.sourceforge.net/"
+SRC_URI="https://github.com/jkbonfield/io_lib/archive/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bzip2 curl +lzma static-libs" # maybe introduce libdeflate USE flag?
+
+S="${WORKDIR}"/"${PN}-${PN}-${MY_PV}"
+
+# >>> Working in BUILD_DIR: "/scratch/var/tmp/portage/sci-libs/io_lib-1.14.11/work/io_lib-1.14.11_build"
+# /scratch/var/tmp/portage/sci-libs/io_lib-1.14.11/temp/environment: line 530: pushd: /scratch/var/tmp/portage/sci-libs/io_lib-1.14.11/work/io_lib-1.14.11_build: No such file or directory
+# * ERROR: sci-libs/io_lib-1.14.11::science failed (install phase):
+# * (no error message)
+# *
+# * Call stack:
+# * ebuild.sh, line 124: Called src_install
+# * environment, line 2506: Called autotools-utils_src_install
+# * environment, line 530: Called die
+# * The specific snippet of code:
+# * pushd "${BUILD_DIR}" > /dev/null || die;
+#
+BUILD_DIR="${S}"
+
+# Prototype changes in io_lib-1.9.0 create incompatibilities with BioPerl. (Only
+# versions 1.8.11 and 1.8.12 will work with the BioPerl Staden extensions.)
+#DEPEND="!sci-biology/bioperl"
+DEPEND="
+ app-arch/libdeflate
+ lzma? ( app-arch/xz-utils:= app-arch/lzma )
+ bzip2? ( app-arch/bzip2 )
+ curl? ( net-misc/curl )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ # https://github.com/jkbonfield/io_lib/issues/12
+ eautoreconf
+ default
+}
+
+src_configure(){
+ # https://github.com/jkbonfield/io_lib/issues/11
+ # https://github.com/jkbonfield/io_lib/issues/13
+ local myconf=()
+ ! use static-libs && myconf+=( "--enable-static=no" )
+ econf ${myconf[@]} $(use_with libdeflate)
+}
+
+src_compile(){
+ # BUG: "have to" provide my own src_compile() because ${P}_build dir is missing now
+ # alternatively BUILD_DIR="${S}" would probably help here too
+ emake
+}
+
+src_install() {
+ # cd "${S}" || die # this does not help to get around the ${P}_build missing
+ # what helped was to set BUILD_DIR="${S}" above
+ autotools-utils_src_install
+ dodoc docs/{Hash_File_Format,ZTR_format}
+}
diff --git a/sci-libs/io_lib/io_lib-1.14.7.ebuild b/sci-libs/io_lib/io_lib-1.14.7.ebuild
deleted file mode 100644
index d76cffe92..000000000
--- a/sci-libs/io_lib/io_lib-1.14.7.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils
-
-DESCRIPTION="General purpose trace and experiment file reading/writing interface"
-HOMEPAGE="http://staden.sourceforge.net/"
-SRC_URI="mirror://sourceforge/staden/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
-
-# Prototype changes in io_lib-1.9.0 create incompatibilities with BioPerl. (Only
-# versions 1.8.11 and 1.8.12 will work with the BioPerl Staden extensions.)
-#DEPEND="!sci-biology/bioperl"
-DEPEND="
- net-misc/curl
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-src_install() {
- autotools-utils_src_install
- dodoc docs/{Hash_File_Format,ZTR_format}
-}