aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortimcera <timcera@32389bae-6d03-0410-99cf-db05cde120eb>2008-10-08 23:49:16 +0000
committertimcera <timcera@32389bae-6d03-0410-99cf-db05cde120eb>2008-10-08 23:49:16 +0000
commitca09adae067f42cf460d9f4b1d3f49ffe03c1df1 (patch)
tree95827dcc00e95d40ace1cac7561ccf1a2944c38f
parentAdded Manifest for ipython (diff)
downloadsci-ca09adae067f42cf460d9f4b1d3f49ffe03c1df1.tar.gz
sci-ca09adae067f42cf460d9f4b1d3f49ffe03c1df1.tar.bz2
sci-ca09adae067f42cf460d9f4b1d3f49ffe03c1df1.zip
sci-mathematics/sage-bin
This is the Sage binary package. Sage is very difficult to tease out the sources to build separately and so I gritted my teeth and created this binary package ebuild. See http://bugs.gentoo.org/show_bug.cgi?id=201321 for information on the conventional source based ebuild. Submit bugs about this ebuild to http://bugs.gentoo.org/show_bug.cgi?id=240622 git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@1308 32389bae-6d03-0410-99cf-db05cde120eb
-rw-r--r--sci-mathematics/sage-bin/ChangeLog8
-rw-r--r--sci-mathematics/sage-bin/Manifest4
-rw-r--r--sci-mathematics/sage-bin/metadata.xml12
-rw-r--r--sci-mathematics/sage-bin/sage-bin-3.1.2.ebuild33
4 files changed, 57 insertions, 0 deletions
diff --git a/sci-mathematics/sage-bin/ChangeLog b/sci-mathematics/sage-bin/ChangeLog
new file mode 100644
index 000000000..ccf2dbb64
--- /dev/null
+++ b/sci-mathematics/sage-bin/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-mathematics/sage-bin
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 08 Oct 2008; Tim Cera <timcera@earthlink.net> +sage-bin-3.1.2.ebuild,
+ +metadata.xml:
+ Initial ebuild.
+
diff --git a/sci-mathematics/sage-bin/Manifest b/sci-mathematics/sage-bin/Manifest
new file mode 100644
index 000000000..b328fa8fb
--- /dev/null
+++ b/sci-mathematics/sage-bin/Manifest
@@ -0,0 +1,4 @@
+DIST sage-3.1.2-redhat5-i686-32bit-intel-i686-Linux.tar.gz 366711383 RMD160 65c9b7a2ff77e95bfd25a884bd37708b8f5e4416 SHA1 6a527cc374fe460ebb45140babbac0673e266fea SHA256 0dedf7e223557932e614f70eaf288d952a2c705f3c9bda3f498d6643f6cc591c
+EBUILD sage-bin-3.1.2.ebuild 697 RMD160 fc689f56b6c564af4adcce1a55c5256c1b37f535 SHA1 ecd17a557e528dad9f11aaf0d915c3c7922a39d5 SHA256 95827e69b9905b0a2bb9baa1a925ebdf0dea7059f0050e6e59a360201edb8247
+MISC ChangeLog 233 RMD160 4798f9a0028a0d1695e1a0c794a5f01db08e1a32 SHA1 a2650f177b378938599aa03e17ad328de3b30b67 SHA256 d7db3e3a944ca774c5a411359677699eda73bbb05a7da0276dc52eb3717ce359
+MISC metadata.xml 382 RMD160 8de737d72790910d3d1d9af886241651974b620e SHA1 1aea9e9694fc83551aaddcad724c8b4763cd883e SHA256 64d39a23d1e079a09044a89ac2c1ff67b4345e3dd6b584b860c74d67b703702c
diff --git a/sci-mathematics/sage-bin/metadata.xml b/sci-mathematics/sage-bin/metadata.xml
new file mode 100644
index 000000000..c12291562
--- /dev/null
+++ b/sci-mathematics/sage-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>timcera@earthlink.net</email>
+<name>Tim Cera</name>
+</maintainer>
+<longdescription lang="en">
+Math software for algebra, geometry, number theory, cryptography, and numerical computation.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/sage-bin/sage-bin-3.1.2.ebuild b/sci-mathematics/sage-bin/sage-bin-3.1.2.ebuild
new file mode 100644
index 000000000..c1c404d04
--- /dev/null
+++ b/sci-mathematics/sage-bin/sage-bin-3.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MY_P="${P/-bin/}"
+
+DESCRIPTION="Math software for algebra, geometry, number theory, cryptography,
+and numerical computation."
+HOMEPAGE="http://www.sagemath.org"
+SRC_URI="http://sagemath.org/bin/linux/32bit/${MY_P}-redhat5-i686-32bit-intel-i686-Linux.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+
+RDEPEND=">=virtual/jre-1.4
+ ${DEPEND}"
+
+
+src_install() {
+ dodir /opt/sage-bin
+ mv sage-*/ "${D}"/opt/sage-bin
+ dosym /opt/sage-bin/sage-*/sage /usr/bin/sage
+}
+
+
+pkg_postinst() {
+ # Running corrects all paths to the new location
+ /usr/bin/sage <<< quit
+}