aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-07-06 21:48:23 +0200
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-07-07 21:51:49 +0200
commitcdf3203be0c831d172bff20824b9d53f76bd8aec (patch)
tree2f9fba441d3141d534ddea5e9df8322fffc154d2
parentIn gentoo-x86 (diff)
downloadsci-cdf3203be0c831d172bff20824b9d53f76bd8aec.tar.gz
sci-cdf3203be0c831d172bff20824b9d53f76bd8aec.tar.bz2
sci-cdf3203be0c831d172bff20824b9d53f76bd8aec.zip
xdsi kpdf -> xpdf fix
-rw-r--r--sci-chemistry/xia2/ChangeLog6
-rw-r--r--sci-chemistry/xia2/xia2-0.3.0.0-r1.ebuild70
-rw-r--r--sci-visualization/xdsi/Manifest2
-rw-r--r--sci-visualization/xdsi/files/gentoo.patch65
4 files changed, 142 insertions, 1 deletions
diff --git a/sci-chemistry/xia2/ChangeLog b/sci-chemistry/xia2/ChangeLog
index 4c2c0f6e1..0325762db 100644
--- a/sci-chemistry/xia2/ChangeLog
+++ b/sci-chemistry/xia2/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*xia2-0.3.0.0-r1 (06 Jul 2009)
+
+ 06 Jul 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +xia2-0.3.0.0-r1.ebuild:
+ we don't depend on specific pointless version in xia
+
*xia2-0.3.0.0 (05 Jul 2009)
05 Jul 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
diff --git a/sci-chemistry/xia2/xia2-0.3.0.0-r1.ebuild b/sci-chemistry/xia2/xia2-0.3.0.0-r1.ebuild
new file mode 100644
index 000000000..f14e694b8
--- /dev/null
+++ b/sci-chemistry/xia2/xia2-0.3.0.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+FORTRANC="g77 gfortran ifc"
+
+inherit eutils python fortran
+
+DESCRIPTION="An automated data reduction system for crystallography"
+HOMEPAGE="http://www.ccp4.ac.uk/xia/"
+SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sci-chemistry/ccp4-6.1.1-r5
+ sci-chemistry/pointless
+ sci-chemistry/mosflm
+ >=sci-libs/ccp4-libs-6.1.1-r7"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ find . -name '*.bat' | xargs rm || die
+
+ epatch "${FILESDIR}"/${PV}-fix-syntax.patch
+}
+
+src_compile() {
+ cd "${S}"/${P}/binaries/src
+ cp "${FILESDIR}"/Makefile.chef Makefile
+ emake \
+ FC="${FORTRANC}" || die
+}
+
+src_install() {
+ dobin ${P}/binaries/src/{doser,chef,mat2symop,symop2mat} || die
+
+ rm -rf ${P}/binaries ${PN}core-${PV}/Test || die
+
+ insinto /usr/share/ccp4/XIAROOT/
+ doins -r * || die
+
+ # Set programs executable
+# fperms cannot handle wildcards
+ chmod 755 "${D}"/usr/share/ccp4/XIAROOT/${P}/Applications/* || die
+ chmod 644 "${D}"/usr/share/ccp4/XIAROOT/${P}/Applications/*.py || die
+
+ cat >> "${T}"/23XIA <<- EOF
+ XIA2_HOME=/usr/share/ccp4/XIAROOT
+
+ XIA2CORE_ROOT=/usr/share/ccp4/XIAROOT/xia2core-${PV}
+ XIA2_ROOT=/usr/share/ccp4/XIAROOT/xia2-${PV}
+
+ PATH=/usr/share/ccp4/XIAROOT/xia2-${PV}/Applications
+ EOF
+
+ doenvd "${T}"/23XIA
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/ccp4/XIAROOT
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/ccp4/XIAROOT
+}
diff --git a/sci-visualization/xdsi/Manifest b/sci-visualization/xdsi/Manifest
index 6a16497b5..3a56ca6cc 100644
--- a/sci-visualization/xdsi/Manifest
+++ b/sci-visualization/xdsi/Manifest
@@ -1,4 +1,4 @@
-AUX gentoo.patch 983 RMD160 fe29cc2a0874061695344466e6e0a0d5b46f8834 SHA1 59fcf2bd4151fb8757a52efff887d60f933bf3b5 SHA256 253fd5230b23cdcf19f746801915cc295290f33678178b21cd2b355ea4b4fe49
+AUX gentoo.patch 3417 RMD160 33791f960d61c4a0ca28f1e3f8ca87eb0ac0d0b9 SHA1 036c294285a20d8c6e2deb1a491b99d323792871 SHA256 a14311bd920d3562afb2a280d416c916eaa0375405f27f8131a9f86225b69dc9
DIST xdsi.tar.gz 542712 RMD160 2300e52f6f7aa249459ea37f4168fe77e4d2efc5 SHA1 1a63f5c2c644a1df2651d8c1de6914d2d5b7bd55 SHA256 5ce4f7e6ded3e5e8b7db32da8d87c97282de31af712682c7cd62e605a3f8e7db
EBUILD xdsi-090629.ebuild 850 RMD160 bc39fd283158a796d39cfafcb8f157b6a5ff725b SHA1 ea29a7c133e0327b0f51f7d4160c58a42def7c68 SHA256 02f378b4ecba24e5fce1bf89a513d5ea65dd8cd4979e577450ef0fdbf54f6847
MISC ChangeLog 364 RMD160 e7b5676810b86ea2f1f3257b280beef757e7b29e SHA1 fbaa6c95a6d163f77a3072c4f3fd4330446d8bf7 SHA256 231bd82a7ff32ab6901d9dc07ee4403ee99b33a57ccd573c02c9d4e2815de874
diff --git a/sci-visualization/xdsi/files/gentoo.patch b/sci-visualization/xdsi/files/gentoo.patch
index a419dab49..84a6b790f 100644
--- a/sci-visualization/xdsi/files/gentoo.patch
+++ b/sci-visualization/xdsi/files/gentoo.patch
@@ -31,3 +31,68 @@
} else {
button .view.button -text "Sorry, no pics" -command { }
}
+--- xdsi 2009-07-06 21:46:47.000000000 +0200
++++ xdsi.new 2009-07-06 21:47:12.000000000 +0200
+@@ -1314,7 +1314,7 @@
+ if {$Correct == "1" } {
+ PLOTALL $WorkDir $HOME $XdsManual }
+ #exec convert scalefactors.png rfactors.png compl.png isigma.png wilson.png uca.png ucb.png ucc.png plots_manual.pdf
+- #exec kpdf plots_manual.pdf &
++ #exec xpdf plots_manual.pdf &
+ }
+
+
+@@ -1371,7 +1371,7 @@
+ destroy .compare
+ cd $outputdir
+ exec convert rfactors.png compl.png isigma.png comp.pdf
+- exec kpdf comp.pdf &
++ exec xpdf comp.pdf &
+
+ }
+
+@@ -1755,7 +1755,7 @@
+ exec convert $outputdir/compall.png $outputdir/compalliosig.png $outputdir/compl.png $outputdir/compall.pdf
+ }
+ exec rm -f $outputdir/compall.png $outputdir/compalliosig.png $outputdir/compl.png
+- exec kpdf $outputdir/compall.pdf &
++ exec xpdf $outputdir/compall.pdf &
+ #exec display $outputdir/compall.png &
+ #exec display $outputdir/compalliosig.png &
+ } else { STATUS2 "Sorry, no usable CORRECT.LPs" }
+@@ -1935,7 +1935,7 @@
+ exec convert scalefactors.png rfactors.png compl.png isigma.png uca.png ucb.png ucc.png nstrong.png sigmab.png sigmar.png stat1.png stat2.png stat3.png aliens.png wilson.png rfacxdsstat.png iosigxdsstat.png peak.png corr.png unique.png rd.png sigano.png plots.pdf
+ }
+ if { $XdsManual == "1" } {
+- exec kpdf $outputdir/plots.pdf &
++ exec xpdf $outputdir/plots.pdf &
+ }
+
+ }
+@@ -2004,7 +2004,7 @@
+ exec echo "plot \"$outputdir/.ucc\" w lp title \"C\" " >> $outputdir/.plot
+ exec gnuplot < $outputdir/.plot >& /dev/null
+ #exec convert uca.png ucb.png ucc.png ucs.pdf
+- #exec kpdf ucs.pdf
++ #exec xpdf ucs.pdf
+ }
+
+
+@@ -3019,7 +3019,7 @@
+ eval [concat $b [lsort $path]]
+ event add <<Change>> <B1-ButtonRelease> <FocusOut> <Leave> <Expose>
+ #bind .plots.dummy.plot <<Change>> {puts $Plot}
+-button .plots.button -text Open -command {exec kpdf $Plot &}
++button .plots.button -text Open -command {exec xpdf $Plot &}
+ pack .plots.button -side bottom
+ #tk_optionMenu .plots.dummy.plot Plot $path
+ pack .plots.plot -anchor w
+@@ -3156,7 +3156,7 @@
+ set b "tk_optionMenu .help.help Help"
+ eval [concat $b $path]
+ event add <<Change>> <B1-ButtonRelease> <FocusOut> <Leave> <Expose>
+-button .help.button -text Open -command {exec kpdf $Help &}
++button .help.button -text Open -command {exec xpdf $Help &}
+ pack .help.button -side bottom
+ pack .help.help -anchor w
+