aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-25 15:48:18 +0200
committerJustin Lecher <jlec@gentoo.org>2011-06-25 15:48:18 +0200
commitdcc6b4904f2a0a9f1c6d37cd314cd12afae5b8a3 (patch)
tree167d8a09e140b819029c565dd51b8f536304818e
parentRDEPEND is not explicitly assigned -> fixed (diff)
downloadsci-dcc6b4904f2a0a9f1c6d37cd314cd12afae5b8a3.tar.gz
sci-dcc6b4904f2a0a9f1c6d37cd314cd12afae5b8a3.tar.bz2
sci-dcc6b4904f2a0a9f1c6d37cd314cd12afae5b8a3.zip
RDEPEND is not explicitly assigned -> fixed
(Portage version: 2.2.0_alpha41/git/Linux x86_64, signed Manifest commit with key 70EB7916)
-rw-r--r--sci-mathematics/cipi/ChangeLog5
-rw-r--r--sci-mathematics/cipi/Manifest16
-rw-r--r--sci-mathematics/cipi/cipi-1.0.ebuild22
-rw-r--r--sci-mathematics/cipi/metadata.xml12
4 files changed, 36 insertions, 19 deletions
diff --git a/sci-mathematics/cipi/ChangeLog b/sci-mathematics/cipi/ChangeLog
index 7aeb4a10a..69ebe9bee 100644
--- a/sci-mathematics/cipi/ChangeLog
+++ b/sci-mathematics/cipi/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for sci-mathematics/cipi
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 25 Jun 2011; Justin Lecher <jlec@gentoo.org> cipi-1.0.ebuild, metadata.xml:
+ RDEPEND is not explicitly assigned -> fixed
+
*cipi-1.0 (20 Jul 2010)
20 Jul 2010; Thomas Kahle <tom111@gmx.de> +cipi-1.0.ebuild, +metadata.xml:
diff --git a/sci-mathematics/cipi/Manifest b/sci-mathematics/cipi/Manifest
index 6a3e98085..092652b16 100644
--- a/sci-mathematics/cipi/Manifest
+++ b/sci-mathematics/cipi/Manifest
@@ -1,3 +1,13 @@
-EBUILD cipi-1.0.ebuild 799 RMD160 cb6909955cb4a63a632e92430d771b699b3c88a2 SHA1 b2056fbc05435cc00ba44275b7deb71a18570bae SHA256 608e3e5e915da9afa396ee4c21a95fe491a7b01b28983de36501439181974843
-MISC ChangeLog 256 RMD160 41008a342ed2556becffcd1f27de3b8bd21cdfa2 SHA1 6fcba3c185f96d73440d55ab2771115cc78d2cf7 SHA256 a408f473131cc2ea862285d6ba83c7c1913deac8dad0547cff5443dc22fb783e
-MISC metadata.xml 429 RMD160 3e6d840b453b9727a910b55817a10ca791291005 SHA1 11a41885d99172fa32e90a6e1b3da2ee71fd4a13 SHA256 8cdbca433ec6c0c2ffdb52fb8b494a00ab9f56bd24bc1fd90e5ffcc4995878ae
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+EBUILD cipi-1.0.ebuild 813 RMD160 6ca5e0ea1c45acfa5d068ade016f6116129261d3 SHA1 e9809c16412f37d3fd71c703b45de0a2b478aa65 SHA256 87100ad2785c3d526cf586a9358ad06655674d6454d44b3c576f8cd85196f9fc
+MISC ChangeLog 381 RMD160 03d323087f60067fbda1dd88a2da5b3b9bb26e50 SHA1 a8fb2b4b93a9bc65cd6506581ef676408073c819 SHA256 771c87ec15aa72ab0e69b78bcf1c18fb6cc3fbf015bafc6036c70f8cccece898
+MISC metadata.xml 433 RMD160 b2b35cf3a37c660b71abe052b9b051892f80bd35 SHA1 31360c9ced491acd0264f7356836ae6e67f350d2 SHA256 9af678a14427419b57161636a463939469c115f1e936d667dab1391a3085ff20
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEAREIAAYFAk4F5yIACgkQgAnW8HDreRbOUgCbBI+XntPDxsDM6luxfLNqSwwX
+OR0An3mDk2AeissiIa6LqbnuTws62QdH
+=0+fS
+-----END PGP SIGNATURE-----
diff --git a/sci-mathematics/cipi/cipi-1.0.ebuild b/sci-mathematics/cipi/cipi-1.0.ebuild
index ca0bc1afe..126bed614 100644
--- a/sci-mathematics/cipi/cipi-1.0.ebuild
+++ b/sci-mathematics/cipi/cipi-1.0.ebuild
@@ -1,26 +1,30 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=4
inherit cmake-utils git
-DESCRIPTION="cipi is computing information projections iteratively"
+DESCRIPTION="Computing information projections iteratively"
HOMEPAGE="http://github.com/tom111/cipi"
EGIT_REPO_URI="git://github.com/tom111/cipi.git"
EGIT_COMMIT="${PV}"
-CMAKE_IN_SOURCE_BUILD="yes"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="doc"
-DEPEND="dev-libs/boost
- doc? ( virtual/latex-base )"
+DEPEND="
+ dev-libs/boost
+ doc? ( virtual/latex-base )"
+RDEPEND="${DEPEND}"
DOCS="AUTHORS README"
+CMAKE_IN_SOURCE_BUILD="yes"
+
src_configure() {
mycmakeargs=(
$(cmake-utils_use_enable doc)
@@ -30,10 +34,10 @@ src_configure() {
}
pkg_postinst() {
- elog " "
+ echo ""
elog "The sample PARAM file has been installed to /usr/share/${PN}-${PV}"
- elog " "
+ echo ""
if use doc; then
elog "A pdf manual has been installed to /usr/share/${PN}-${PV}"
fi
-} \ No newline at end of file
+}
diff --git a/sci-mathematics/cipi/metadata.xml b/sci-mathematics/cipi/metadata.xml
index 462f8208d..7b5155f27 100644
--- a/sci-mathematics/cipi/metadata.xml
+++ b/sci-mathematics/cipi/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<maintainer>
- <email>tom111@gmx.de</email>
- <name>Thomas Kahle</name>
-</maintainer>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <maintainer>
+ <email>tom111@gmx.de</email>
+ <name>Thomas Kahle</name>
+ </maintainer>
+ <longdescription lang="en">
cipi is a threaded implementation of iterative proportional fitting. It is used to compute
information projections iteratively.
</longdescription>