aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-25 01:02:02 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-25 01:02:50 +0200
commitdf096482743b6bfa2598cc52bbb95117952f3b24 (patch)
treede08cfbeb322f618261112f9a38d6ab1af8082ea
parentsci-biology/bedtools: remove, in main tree (diff)
downloadsci-df096482743b6bfa2598cc52bbb95117952f3b24.tar.gz
sci-df096482743b6bfa2598cc52bbb95117952f3b24.tar.bz2
sci-df096482743b6bfa2598cc52bbb95117952f3b24.zip
sci-biology/biopython: remove, in main tree
-rw-r--r--sci-biology/biopython/Manifest1
-rw-r--r--sci-biology/biopython/biopython-1.67-r1.ebuild60
-rw-r--r--sci-biology/biopython/files/biopython-1.67-pull-884.patch87
-rw-r--r--sci-biology/biopython/metadata.xml8
4 files changed, 0 insertions, 156 deletions
diff --git a/sci-biology/biopython/Manifest b/sci-biology/biopython/Manifest
deleted file mode 100644
index 8b5151bde..000000000
--- a/sci-biology/biopython/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST biopython-1.67.tar.gz 14343462 SHA256 1ab322fe4d2f79d2d999c9d8faf8b4e0b4c41c4e8b5f0a97912dfa0e3aa249e6 SHA512 be4cd0b21bada441e9d416eea47cfb930cb01395b860a8e1c4ed06bf96afb6a9819bfb5bf2d552438441f764ed3072ff4e26460d036f8834bdd2f0d1c08d4757 WHIRLPOOL cf40b58e15d647a9bdf8879dcf599c8aaf5689d2e32fc62289f39c97ed5d2db7162828bfd07fbf8cb663aa18de3211840519d6e89ebcbca19c355b68ae93ac5a
diff --git a/sci-biology/biopython/biopython-1.67-r1.ebuild b/sci-biology/biopython/biopython-1.67-r1.ebuild
deleted file mode 100644
index 197e2656f..000000000
--- a/sci-biology/biopython/biopython-1.67-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Python modules for computational molecular biology"
-HOMEPAGE="http://www.biopython.org/ https://pypi.python.org/pypi/biopython/"
-SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- dev-python/matplotlib[$(python_gen_usedep 'python*')]
- dev-python/networkx[$(python_gen_usedep 'python*')]
- dev-python/numpy[$(python_gen_usedep 'python*')]
- dev-python/rdflib[$(python_gen_usedep 'python*')]
- dev-python/pygraphviz[$(python_gen_usedep 'python2*')]
- dev-python/reportlab[$(python_gen_usedep 'python*')]
- media-gfx/pydot[$(python_gen_usedep 'python2*')]
- "
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-DOCS=( CONTRIB DEPRECATED NEWS README Doc/. )
-
-src_prepare(){
- epatch "${FILESDIR}"/biopython-1.67-pull-884.patch
-}
-
-python_test() {
- distutils_install_for_testing
- cp -r "${S}"/{Doc,Tests} "${TEST_DIR}"/lib/ || die
- cd "${TEST_DIR}"/lib/Tests || die
- rm ./test_BioSQL_psycopg2.py ./test_BioSQL_MySQLdb.py ./test_BioSQL_mysql_connector.py || die
- ${PYTHON} run_tests.py --offline --verbose || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodir /usr/share/${PN}
- cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
-}
-
-pkg_postinst() {
- elog "For database support you need to install:"
- optfeature "MySQL" dev-python/mysql-python
- optfeature "PostGreSQL" dev-python/psycopg
- echo
- elog "Some applications need extra packages:"
- optfeature "EMBOSS (The European Molecular Biology Open Software Suite)" sci-biology/emboss
-}
diff --git a/sci-biology/biopython/files/biopython-1.67-pull-884.patch b/sci-biology/biopython/files/biopython-1.67-pull-884.patch
deleted file mode 100644
index f2a253716..000000000
--- a/sci-biology/biopython/files/biopython-1.67-pull-884.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- Bio/SeqRecord.py.old 2016-06-08 15:27:00.000000000 +0200
-+++ Bio/SeqRecord.py 2016-07-22 17:48:19.620712535 +0200
-@@ -292,19 +292,28 @@
- >>> sub_record.letter_annotations = {}
- >>> sub_record.letter_annotations
- {}
-+
-+ Note that if replacing the record's sequence with a sequence of a
-+ different length you must first clear the letter_annotations dict.
- """)
-
- def _set_seq(self, value):
- # TODO - Add a deprecation warning that the seq should be write only?
- if self._per_letter_annotations:
-- # TODO - Make this a warning? Silently empty the dictionary?
-- raise ValueError("You must empty the letter annotations first!")
-- self._seq = value
-- try:
-- self._per_letter_annotations = _RestrictedDict(length=len(self.seq))
-- except AttributeError:
-- # e.g. seq is None
-- self._per_letter_annotations = _RestrictedDict(length=0)
-+ if len(self) != len(value):
-+ # TODO - Make this a warning? Silently empty the dictionary?
-+ raise ValueError("You must empty the letter annotations first!")
-+ else:
-+ # Leave the existing per letter annotations unchanged:
-+ self._seq = value
-+ else:
-+ self._seq = value
-+ # Reset the (empty) letter annotations dict with new length:
-+ try:
-+ self._per_letter_annotations = _RestrictedDict(length=len(self.seq))
-+ except AttributeError:
-+ # e.g. seq is None
-+ self._per_letter_annotations = _RestrictedDict(length=0)
-
- seq = property(fget=lambda self: self._seq,
- fset=_set_seq,
-@@ -427,10 +436,17 @@
- if self.seq is None:
- raise ValueError("If the sequence is None, we cannot slice it.")
- parent_length = len(self)
-- answer = self.__class__(self.seq[index],
-- id=self.id,
-- name=self.name,
-- description=self.description)
-+ from BioSQL.BioSeq import DBSeqRecord
-+ if isinstance(self, DBSeqRecord):
-+ answer = SeqRecord(self.seq[index],
-+ id=self.id,
-+ name=self.name,
-+ description=self.description)
-+ else:
-+ answer = self.__class__(self.seq[index],
-+ id=self.id,
-+ name=self.name,
-+ description=self.description)
- # TODO - The description may no longer apply.
- # It would be safer to change it to something
- # generic like "edited" or the default value.
---- Tests/test_SeqRecord.py.old 2016-06-08 15:27:00.000000000 +0200
-+++ Tests/test_SeqRecord.py 2016-07-22 17:48:45.401428898 +0200
-@@ -72,6 +72,23 @@
- except (TypeError, ValueError) as e:
- pass
-
-+ def test_replacing_seq(self):
-+ """Replacing .seq if .letter_annotation present."""
-+ rec = SeqRecord(Seq("ACGT", generic_dna),
-+ id="Test", name="Test", description="Test",
-+ letter_annotations={"example": [1, 2, 3, 4]})
-+ try:
-+ rec.seq = Seq("ACGTACGT", generic_dna)
-+ self.fail("Changing .seq length with letter_annotations present should fail!")
-+ except ValueError as e:
-+ self.assertEqual(str(e), "You must empty the letter annotations first!")
-+ # Check we can replace IF the length is the same
-+ self.assertEqual(str(rec.seq), "ACGT")
-+ self.assertEqual(rec.letter_annotations, {"example": [1, 2, 3, 4]})
-+ rec.seq = Seq("NNNN" , generic_dna)
-+ self.assertEqual(str(rec.seq), "NNNN")
-+ self.assertEqual(rec.letter_annotations, {"example": [1, 2, 3, 4]})
-+
- def test_valid_id(self):
- with self.assertRaises(TypeError):
- SeqRecord(Seq("ACGT", generic_dna), id=dict())
diff --git a/sci-biology/biopython/metadata.xml b/sci-biology/biopython/metadata.xml
deleted file mode 100644
index 959160fe4..000000000
--- a/sci-biology/biopython/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
-</pkgmetadata>