aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-02 14:04:53 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-02 14:05:06 +0200
commite0b3f9f7470d470b1432ce9c66ed4be829e82c08 (patch)
treefad989dc599c8de9dd7175ecda84512e1606b62b
parentdev-python/dandischema: dropped package (diff)
downloadsci-e0b3f9f7470d470b1432ce9c66ed4be829e82c08.tar.gz
sci-e0b3f9f7470d470b1432ce9c66ed4be829e82c08.tar.bz2
sci-e0b3f9f7470d470b1432ce9c66ed4be829e82c08.zip
dev-python/zarr: add 2.11.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/zarr/Manifest1
-rw-r--r--dev-python/zarr/zarr-2.11.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/zarr/Manifest b/dev-python/zarr/Manifest
index 3a4a7df34..97e66531d 100644
--- a/dev-python/zarr/Manifest
+++ b/dev-python/zarr/Manifest
@@ -1,2 +1,3 @@
DIST zarr-2.10.3.tar.gz 3484571 BLAKE2B 2c955e6c55813b417decfcc195fb11292391d341a863ddb769767e7ece25dc1a1776e260d5dfa260fec9b41dc11ba3ad61d7e53f4785bfc4851889a68ff2b5d2 SHA512 949391b65e234d5ae18188c16497145314392d69037b88512626a6e762f920a70badcb36bbb69d66291e9422a5cdacaae318c5c30ebab3d93ab83e37b56d5fca
DIST zarr-2.11.1.tar.gz 3492813 BLAKE2B ff31cc2d11f5f863770f91136694108ab76525c644dd57861a4a57ca03dae0bb8cde5c20a2654f3566ffb69900d581e7592f576b9c0d2746e4fb95ed6991c740 SHA512 e0079a69f65a1bc230049469f50bf52af036d85d84f7c163ecdc2a4a8d7b75b07b59c1fcdecd83f578682914a6463641e9341d2c18f939c57f1e78f298f6b7ea
+DIST zarr-2.11.3.tar.gz 3492924 BLAKE2B ca7c5d4b4dd9a3ba4b108fb878e91418fda5b4020a09eb024c774ea8b06b1b329fd7537806632550d60b19ab16b6f6542b6e368cbaef1bbf43a8514b2347c5d6 SHA512 e11e08341769a730a22fcf9a14bbd6d284c4cb051d971dbd3a234ef42224a46e8119cb53360df1aa55580bc4912df61ddde42284c16173f68a3db1d666afbc65
diff --git a/dev-python/zarr/zarr-2.11.3.ebuild b/dev-python/zarr/zarr-2.11.3.ebuild
new file mode 100644
index 000000000..50ec85404
--- /dev/null
+++ b/dev-python/zarr/zarr-2.11.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Chunked, compressed, N-dimensional arrays for Python"
+HOMEPAGE="https://github.com/zarr-developers/zarr-python"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/asciitree[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ >=dev-python/numcodecs-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ )
+"
+
+# Reported upsream
+# https://github.com/zarr-developers/zarr-python/issues/961
+EPYTEST_DESELECT=(
+ zarr/tests/test_core.py::TestArray::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithPath::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithChunkStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithDirectoryStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithNestedDirectoryStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithDBMStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithSQLiteStore::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithNoCompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithBZ2Compressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithBloscCompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithLZMACompressor::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithCustomMapping::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayNoCache::test_object_arrays_vlen_bytes
+ zarr/tests/test_core.py::TestArrayWithStoreCache::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArray::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArrayWithThreadSynchronizer::test_object_arrays_vlen_bytes
+ zarr/tests/test_sync.py::TestArrayWithProcessSynchronizer::test_object_arrays_vlen_bytes
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/numpydoc dev-python/sphinx-issues dev-python/sphinx_rtd_theme