aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-05-23 02:22:42 +0200
committerHorea Christian <horea.christ@yandex.com>2018-05-23 02:22:42 +0200
commite17cf9a4deb90f442de5ab60d0fff1c5c3b31cf7 (patch)
tree6c6c052335478a6509898d66122fb6a123b7e21b
parentsci-biology/dipy: version bump and improved deps (diff)
downloadsci-e17cf9a4deb90f442de5ab60d0fff1c5c3b31cf7.tar.gz
sci-e17cf9a4deb90f442de5ab60d0fff1c5c3b31cf7.tar.bz2
sci-e17cf9a4deb90f442de5ab60d0fff1c5c3b31cf7.zip
dev-python/grabbit: new package (pybids dependency)
Package-Manager: Portage-2.3.38, Repoman-2.3.9
-rw-r--r--dev-python/grabbit/Manifest1
-rw-r--r--dev-python/grabbit/grabbit-0.1.1.ebuild27
-rw-r--r--dev-python/grabbit/metadata.xml21
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/grabbit/Manifest b/dev-python/grabbit/Manifest
new file mode 100644
index 000000000..d579f5301
--- /dev/null
+++ b/dev-python/grabbit/Manifest
@@ -0,0 +1 @@
+DIST grabbit-0.1.1.tar.gz 70145 BLAKE2B dffde22513697f28f89dfe76f0f8ae827a9a25046090a7abc1759cbc38a3cb1b77a01b8ddca86b347610345560fa93260a72573457496dde924b2dd0acb4776b SHA512 ae816a7c1a3a2ed1e521ba3e87473c447411d9b6efead824ee78707ca34bea24798609bbdec889a97948413021f2720be143bf3d8c4b081dccd243960a543232
diff --git a/dev-python/grabbit/grabbit-0.1.1.ebuild b/dev-python/grabbit/grabbit-0.1.1.ebuild
new file mode 100644
index 000000000..cceee888e
--- /dev/null
+++ b/dev-python/grabbit/grabbit-0.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get grabby with file trees"
+HOMEPAGE="https://github.com/grabbles/grabbit"
+SRC_URI="https://github.com/grabbles/grabbit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-3.4.1[${PYTHON_USEDEP}] )
+ "
+RDEPEND=""
+
+python_test() {
+ py.test -v || die
+}
diff --git a/dev-python/grabbit/metadata.xml b/dev-python/grabbit/metadata.xml
new file mode 100644
index 000000000..f297bae41
--- /dev/null
+++ b/dev-python/grabbit/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Grabbit is a lightweight Python 3 package for simple queries over filenames
+ within a project. It's geared towards projects or applications with highly
+ structured filenames that allow useful queries to be performed without having
+ to inspect the file metadata or contents.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">grabbles/grabbit</remote-id>
+ </upstream>
+</pkgmetadata>