aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-06 08:23:42 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-06 08:23:42 +0100
commite8ae9452197df889ba3309fb72d90cc5a5bd10d5 (patch)
tree9645e488afafe4bdb77e77eee0618de218828c02
parentsci-biology/genometools: another attempt to add the license (diff)
downloadsci-e8ae9452197df889ba3309fb72d90cc5a5bd10d5.tar.gz
sci-e8ae9452197df889ba3309fb72d90cc5a5bd10d5.tar.bz2
sci-e8ae9452197df889ba3309fb72d90cc5a5bd10d5.zip
sci-chemistry/openbabel: Respect CXXFLAGS
drop usage of dohtml Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-chemistry/openbabel/metadata.xml2
-rw-r--r--sci-chemistry/openbabel/openbabel-9999.ebuild20
2 files changed, 13 insertions, 9 deletions
diff --git a/sci-chemistry/openbabel/metadata.xml b/sci-chemistry/openbabel/metadata.xml
index 0e989df8a..971265884 100644
--- a/sci-chemistry/openbabel/metadata.xml
+++ b/sci-chemistry/openbabel/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-chemistry</herd>
diff --git a/sci-chemistry/openbabel/openbabel-9999.ebuild b/sci-chemistry/openbabel/openbabel-9999.ebuild
index c871b1405..660e3a761 100644
--- a/sci-chemistry/openbabel/openbabel-9999.ebuild
+++ b/sci-chemistry/openbabel/openbabel-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -50,6 +50,7 @@ src_configure() {
local mycmakeargs=""
mycmakeargs="${mycmakeargs}
-DOPENBABEL_USE_SYSTEM_INCHI=ON
+ -DOPTIMIZE_NATIVE=OFF
$(cmake-utils_use_enable openmp OPENMP)
$(cmake-utils_use wxwidgets BUILD_GUI)"
@@ -60,6 +61,7 @@ src_test() {
local mycmakeargs=""
mycmakeargs="${mycmakeargs}
-DOPENBABEL_USE_SYSTEM_INCHI=ON
+ -DOPTIMIZE_NATIVE=OFF
-DPYTHON_EXECUTABLE=false
$(cmake-utils_use wxwidgets BUILD_GUI)
$(cmake-utils_use_enable openmp OPENMP)
@@ -71,18 +73,20 @@ src_test() {
}
src_install() {
- dohtml doc/{*.html,*.png}
- if use doc ; then
- insinto /usr/share/doc/${PF}/API/html
- doins doc/API/html/*
+ docinto html
+ dodoc doc/{*.html,*.png}
+ if use doc; then
+ docinto html/API
+ dodoc doc/API/html/*
fi
+
cmake-utils_src_install
# Ensure that modules are allways in openbabel/${PV}
- pushd "${ED}/usr/$(get_libdir)/openbabel"
+ pushd "${ED}/usr/$(get_libdir)/openbabel" > /dev/null || die
ver=$(ls -d * | grep -E '([0-9]+[.]){2}[0-9]+')
if [ "${ver}" != "${PV}" ] ; then
- ln -s ${ver} ${PV}
+ ln -s ${ver} ${PV} || die
fi
- popd
+ popd > /dev/null || die
}