aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2018-07-31 20:36:39 +0200
committerHorea Christian <horea.christ@yandex.com>2018-07-31 20:36:39 +0200
commiteada628c39c5c56447fab296d318155f957bc416 (patch)
tree2f3222fd069dce61e1cec2fc9a498f4594f7bbb4
parentsci-libs/nibabel: version bump (diff)
downloadsci-eada628c39c5c56447fab296d318155f957bc416.tar.gz
sci-eada628c39c5c56447fab296d318155f957bc416.tar.bz2
sci-eada628c39c5c56447fab296d318155f957bc416.zip
sci-libs/pydicom: version bump
Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--sci-libs/pydicom/Manifest1
-rw-r--r--sci-libs/pydicom/pydicom-1.1.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/sci-libs/pydicom/Manifest b/sci-libs/pydicom/Manifest
index 73faf2e0e..18fbb7f9d 100644
--- a/sci-libs/pydicom/Manifest
+++ b/sci-libs/pydicom/Manifest
@@ -1 +1,2 @@
DIST pydicom-0.9.9.tar.gz 422348 BLAKE2B 68ffa180ab926ebce2bd30f8fa6ff2442dfacf0fb2832f179010afda7092e7b4a4cbac2738aff5c7188b04c433b08bc19d64c1c9ebe07ae5dac5cd120e77e92f SHA512 3c2f3af6cc1f4a4a53894f236f55c33658bb448ad71571521fabe5d8b2a0e48b9cfaec491aa6f524cf7bbe294d9a784c5290d31a312ebd26701bacaac8253da7
+DIST pydicom-1.1.0.tar.gz 6724086 BLAKE2B efdcdd722bc877b9b9cf137ecd2a3fa6fb2b7da022bdab49f03dbcdb5a3e3dc8bc24b6b0d8eb9ab946934ec182c13ec1df671461c357476f543afb6f435f604c SHA512 ffca9eb4333d29accea1d6e5a5b4c3c0bd0f8c12fdf00c5c84d83769db621e8f348c9200dff1dc1cd6016cbf5d76b00f08c3b112ba653433a84ce31ad1ab33d5
diff --git a/sci-libs/pydicom/pydicom-1.1.0.ebuild b/sci-libs/pydicom/pydicom-1.1.0.ebuild
new file mode 100644
index 000000000..0c2e1b15e
--- /dev/null
+++ b/sci-libs/pydicom/pydicom-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python package for parsing DICOM files"
+HOMEPAGE="http://www.pydicom.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Upstream bug: https://github.com/pydicom/pydicom/issues/663
+RESTRICT="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ distutils-r1_install_for_testing
+ py.test --cov=pydicom -r sx --pyargs pydicom --verbose || die
+}