aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gmail.com>2012-07-06 09:08:25 -0600
committerNicolas Bock <nicolasbock@gmail.com>2012-07-06 09:08:25 -0600
commiteddc02985ef102e6f6f3c2cebc13417b2d5fd137 (patch)
treef7bea5eacd956588d72f99ca2db7a6c90212b543
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/proj/sci; github.c... (diff)
downloadsci-eddc02985ef102e6f6f3c2cebc13417b2d5fd137.tar.gz
sci-eddc02985ef102e6f6f3c2cebc13417b2d5fd137.tar.bz2
sci-eddc02985ef102e6f6f3c2cebc13417b2d5fd137.zip
Moved prefix to /opt.
(Portage version: 2.1.10.65/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--sys-cluster/modules/ChangeLog3
-rw-r--r--sys-cluster/modules/modules-3.2.9c-r1.ebuild12
2 files changed, 6 insertions, 9 deletions
diff --git a/sys-cluster/modules/ChangeLog b/sys-cluster/modules/ChangeLog
index d63b6f73f..866d368eb 100644
--- a/sys-cluster/modules/ChangeLog
+++ b/sys-cluster/modules/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 Jul 2012; Nick <nbock@gentoo.org> modules-3.2.9c-r1.ebuild:
+ Moved prefix to /opt.
+
*modules-3.2.9c-r1 (05 Jul 2012)
05 Jul 2012; Nicolas Bock <nicolasbock@gmail.com> +modules-3.2.9c-r1.ebuild:
diff --git a/sys-cluster/modules/modules-3.2.9c-r1.ebuild b/sys-cluster/modules/modules-3.2.9c-r1.ebuild
index 16c87a0d7..b55a8d843 100644
--- a/sys-cluster/modules/modules-3.2.9c-r1.ebuild
+++ b/sys-cluster/modules/modules-3.2.9c-r1.ebuild
@@ -26,26 +26,20 @@ S="${WORKDIR}/${P%[a-z]}"
DOCS=(ChangeLog README NEWS TODO)
-pkg_setup() {
- export MODULES_PATH=/etc/Modules
- export MODULES_VERSION="3.2.9"
-}
-
src_configure() {
local myeconfargs=(
$(use_with X x)
- --with-module-path=${MODULES_PATH}/${MODULES_VERSION}/modulefiles
- --with-version-path=${MODULES_PATH}/${MODULES_VERSION}/versions
+ --prefix=/opt
)
autotools-utils_src_configure
}
src_install() {
autotools-utils_src_install
- dosym ${MODULES_PATH}/${MODULES_VERSION} ${MODULES_PATH}/default
+ dosym ${PV%[a-z]} /opt/Modules/default
}
pkg_postinst() {
elog "Add this line at the end of your bashrc:"
- elog "[ -e \"${MODULES_PATH}/default/init/bash\" ] && . \"${MODULES_PATH}/default/init/bash\""
+ elog "[ -e /opt/Modules/default/init/bash\" ] && . \"/opt/Modules/default/init/bash\""
}