aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-10-15 21:01:09 -0700
committerDavid Seifert <soap@gentoo.org>2017-10-15 21:01:09 -0700
commitf5fa3d050a6ae98a14266167c00241f7208c8452 (patch)
tree67157025369b6db4d88a59abb9ffd03229c5b7df
parentprofiles: remove use.local.desc permanently (diff)
downloadsci-f5fa3d050a6ae98a14266167c00241f7208c8452.tar.gz
sci-f5fa3d050a6ae98a14266167c00241f7208c8452.tar.bz2
sci-f5fa3d050a6ae98a14266167c00241f7208c8452.zip
sys-cluster/htcondor: Remove optional dep on net-libs/qmf
Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--sys-cluster/htcondor/htcondor-8.0.0.ebuild24
-rw-r--r--sys-cluster/htcondor/htcondor-8.3.2.ebuild25
-rw-r--r--sys-cluster/htcondor/metadata.xml1
3 files changed, 21 insertions, 29 deletions
diff --git a/sys-cluster/htcondor/htcondor-8.0.0.ebuild b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
index 9219714f5..5e25f0325 100644
--- a/sys-cluster/htcondor/htcondor-8.0.0.ebuild
+++ b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,7 +16,7 @@ SRC_URI="condor_src-${PV}-all-all.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="boinc cgroup contrib curl doc kerberos libvirt management minimal postgres python soap ssl test X xml"
+IUSE="boinc cgroup contrib curl doc kerberos libvirt minimal postgres python soap ssl test X xml"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -31,7 +31,6 @@ CDEPEND="
libvirt? ( >=app-emulation/libvirt-0.6.2 )
kerberos? ( virtual/krb5 )
X? ( x11-libs/libX11 )
- management? ( net-libs/qmf )
postgres? ( >=dev-db/postgresql-8.2.4:= )
python? ( ${PYTHON_DEPS} )
soap? ( >=net-libs/gsoap-2.7.11[ssl?] )
@@ -47,22 +46,19 @@ RDEPEND="${CDEPEND}
RESTRICT=fetch
S="${WORKDIR}/condor-${PV}"
+PATCHES=(
+ "${FILESDIR}"/condor_shadow_dlopen-${PV}.patch
+ "${FILESDIR}"/condor_config.generic.patch
+ "${FILESDIR}"/0001-Apply-the-user-s-condor_config-last-rather-than-firs.patch
+ "${FILESDIR}"/packaging_directories-${PV}.patch
+ "${FILESDIR}"/fix_sandbox_violations-${PV}.patch
+)
pkg_setup() {
enewgroup condor
enewuser condor -1 "${ROOT}"bin/bash "${ROOT}var/lib/condor" condor
}
-src_prepare() {
- epatch \
- "${FILESDIR}"/condor_shadow_dlopen-${PV}.patch \
- "${FILESDIR}"/condor_config.generic.patch \
- "${FILESDIR}"/0001-Apply-the-user-s-condor_config-last-rather-than-firs.patch \
- "${FILESDIR}"/packaging_directories-${PV}.patch \
- "${FILESDIR}"/fix_sandbox_violations-${PV}.patch
- cmake-utils_src_prepare
-}
-
src_configure() {
# All the hard coded -DWITH_X=OFF flags are for packages that aren't in portage
# I also haven't included support for HAVE_VMWARE because I don't know what it requires
@@ -81,6 +77,7 @@ src_configure() {
-DWITH_UNICOREGAHP=OFF
-DWITH_VOMS=OFF
-DWITH_WSO2=OFF
+ -DWITH_MANAGEMENT=OFF
$(cmake-utils_use_has boinc BACKFILL)
$(cmake-utils_use_has boinc)
$(cmake-utils_use_with cgroup LIBCGROUP)
@@ -92,7 +89,6 @@ src_configure() {
$(cmake-utils_use_with kerberos KRB5)
$(cmake-utils_use_with postgres POSTGRESQL)
$(cmake-utils_use_with python PYTHON_BINDINGS)
- $(cmake-utils_use_with management)
$(cmake-utils_use minimal CLIPPED)
$(cmake-utils_use_with soap AVIARY)
$(cmake-utils_use_with soap GSOAP)
diff --git a/sys-cluster/htcondor/htcondor-8.3.2.ebuild b/sys-cluster/htcondor/htcondor-8.3.2.ebuild
index 56b08cc76..c4464b88f 100644
--- a/sys-cluster/htcondor/htcondor-8.3.2.ebuild
+++ b/sys-cluster/htcondor/htcondor-8.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,7 +16,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/V${PV//./_}.tar.gz -> ${P}.tar.g
LICENSE="Apache-2.0"
SLOT="0"
#KEYWORDS="~amd64 ~x86"
-IUSE="boinc cgroup contrib curl dmtcp doc kerberos libvirt management minimal postgres python soap ssl test X xml"
+IUSE="boinc cgroup contrib curl dmtcp doc kerberos libvirt minimal postgres python soap ssl test X xml"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -31,7 +31,6 @@ CDEPEND="sys-libs/zlib
libvirt? ( >=app-emulation/libvirt-0.6.2 )
kerberos? ( virtual/krb5 )
X? ( x11-libs/libX11 )
- management? ( net-libs/qmf )
postgres? ( >=dev-db/postgresql-8.2.4:= )
python? ( ${PYTHON_DEPS} )
soap? ( >=net-libs/gsoap-2.7.11[ssl?] )
@@ -44,21 +43,19 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}
virtual/mailx"
+PATCHES=(
+ "${FILESDIR}"/${P}-shadow_dlopen.patch
+ "${FILESDIR}"/${P}-condor_config.generic.patch
+ "${FILESDIR}"/${P}-Apply-the-users-condor_config-last-rather-than-first.patch
+ "${FILESDIR}"/${P}-packaging_directories.patch
+ "${FILESDIR}"/fix_sandbox_violations-8.0.0.patch
+)
+
pkg_setup() {
enewgroup condor
enewuser condor -1 "${ROOT}"bin/bash "${ROOT}var/lib/condor" condor
}
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-shadow_dlopen.patch \
- "${FILESDIR}"/${P}-condor_config.generic.patch \
- "${FILESDIR}"/${P}-Apply-the-users-condor_config-last-rather-than-first.patch \
- "${FILESDIR}"/${P}-packaging_directories.patch \
- "${FILESDIR}"/fix_sandbox_violations-8.0.0.patch
- cmake-utils_src_prepare
-}
-
src_configure() {
# All the hard coded -DWITH_X=OFF flags are for packages that aren't in portage
# I also haven't included support for HAVE_VMWARE because I don't know what it requires
@@ -77,6 +74,7 @@ src_configure() {
-DWITH_UNICOREGAHP=OFF
-DWITH_VOMS=OFF
-DWITH_WSO2=OFF
+ -DWITH_MANAGEMENT=OFF
$(cmake-utils_use_has boinc BACKFILL)
$(cmake-utils_use_has boinc)
$(cmake-utils_use_with cgroup LIBCGROUP)
@@ -88,7 +86,6 @@ src_configure() {
$(cmake-utils_use_with kerberos KRB5)
$(cmake-utils_use_with postgres POSTGRESQL)
$(cmake-utils_use_with python PYTHON_BINDINGS)
- $(cmake-utils_use_with management)
$(cmake-utils_use minimal CLIPPED)
$(cmake-utils_use_with soap AVIARY)
$(cmake-utils_use_with soap GSOAP)
diff --git a/sys-cluster/htcondor/metadata.xml b/sys-cluster/htcondor/metadata.xml
index 6b59f13ef..32ec6ea2e 100644
--- a/sys-cluster/htcondor/metadata.xml
+++ b/sys-cluster/htcondor/metadata.xml
@@ -25,7 +25,6 @@
<flag name="contrib">Build contrib modules</flag>
<flag name="dmtcp">Use <pkg>sys-apps/dmtcp</pkg> for checkpointing</flag>
<flag name="libvirt">Use <pkg>app-emulation/libvirt</pkg> for virtualisation</flag>
- <flag name="management">Use <pkg>net-libs/qmf</pkg> for management</flag>
<flag name="minimal">Don't support standard universe jobs</flag>
<flag name="X">Enable the HTCondor Keyboard Daemon to monitor logged in X users for activity</flag>
</use>