aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-01-17 14:47:17 +0000
committerbicatali <bicatali@32389bae-6d03-0410-99cf-db05cde120eb>2006-01-17 14:47:17 +0000
commitfb28675dc617593a33084d45077127a0a8a7bc50 (patch)
treeb4bd3b446362c871621599d51de808466be54d19
parentremoved celestia (in portage) (diff)
downloadsci-fb28675dc617593a33084d45077127a0a8a7bc50.tar.gz
sci-fb28675dc617593a33084d45077127a0a8a7bc50.tar.bz2
sci-fb28675dc617593a33084d45077127a0a8a7bc50.zip
fixed for USE=examples
git-svn-id: http://overlays.gentoo.org/svn/proj/science/overlay@63 32389bae-6d03-0410-99cf-db05cde120eb
-rw-r--r--sci-libs/arpack/Manifest2
-rw-r--r--sci-libs/arpack/arpack-96.ebuild40
2 files changed, 29 insertions, 13 deletions
diff --git a/sci-libs/arpack/Manifest b/sci-libs/arpack/Manifest
index a7480c0a5..e0c782a38 100644
--- a/sci-libs/arpack/Manifest
+++ b/sci-libs/arpack/Manifest
@@ -1,4 +1,4 @@
MD5 85dace53bcf9a2871ab45cb0061fb7c7 ChangeLog 304
-MD5 9be4000505715a365fffbc75d6687398 arpack-96.ebuild 1811
+MD5 b14ee14fcbdb324108d8a2a593e33ee9 arpack-96.ebuild 2251
MD5 78fedce5e2dc0ae0dea2d24fcf9c7745 files/digest-arpack-96 236
MD5 db6b7bcfdff65546db2b62be1a72fe93 metadata.xml 257
diff --git a/sci-libs/arpack/arpack-96.ebuild b/sci-libs/arpack/arpack-96.ebuild
index 2df453685..cff6df3d6 100644
--- a/sci-libs/arpack/arpack-96.ebuild
+++ b/sci-libs/arpack/arpack-96.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit toolchain-funcs
+inherit toolchain-funcs fortran
DESCRIPTION="ARPACK is a collection of Fortran77 subroutines designed to solve large scale eigenvalue problems."
@@ -20,16 +20,16 @@ KEYWORDS="~amd64 ~x86"
DEPEND="virtual/libc
mpi? ( virtual/mpi )"
-S=${WORKDIR}/ARPACK
-ARPACKLIB=libarpack.a
-
-# lapack USE/dependence not included because README file strongly
+# lapack USE/dependence not implemented because README file strongly
# recommands using arpack internal lapack (unless is lapack-2,
# which does not exist on gentoo).
+# anyway, i could not run examples with the installed lapack-3 on my system
# mpi use is very experimental (basically non working)
+S=${WORKDIR}/ARPACK
+
src_compile() {
local mpiconf=""
if use mpi; then
@@ -43,26 +43,34 @@ src_compile() {
RANLIB=$(tc-getRANLIB) \
FFLAGS="${FFLAGS}" \
MAKE=/usr/bin/make \
- ARPACKLIB=${S}/${ARPACKLIB} \
+ ARPACKLIB=${S}/libarpack.a \
+ PRECISIONS="single double complex complex16 sdrv ddrv cdrv zdrv" \
${mpiconf} \
all || die "emake failed"
}
src_install() {
- dolib.a ${ARPACKLIB}
+ dolib.a libarpack.a
dodoc README
docinto DOCUMENTS
dodoc DOCUMENTS/*
- if use examples; then
- for mkfile in `ls -d EXAMPLES/*/makefile`; do
- sed -i -e "s:\$(ALIBS):-larpack:g" ${mkfile}
+ if use examples; then
+ for mkfile in $(ls -d EXAMPLES/*/makefile); do
+ sed -e '/^include/d' \
+ -e '1i ALIBS=-larpack' \
+ -i ${mkfile}
done
insinto /usr/share/doc/${P}
doins -r EXAMPLES
if use mpi; then
- for mkfile in `ls -d PARPACK/EXAMPLES/*/makefile`; do
- sed -i -e "s:\$(PLIBS):-lparpack:g" ${mkfile}
+ for mkfile in $(ls -d PARPACK/EXAMPLES/*/makefile); do
+ sed -e '/^include/d' \
+ -e 's:_\$(PLAT)::g' \
+ -e '1i PLIBS=-lparpack' \
+ -e '2i PFC=$(tc-getF77)' \
+ -e '3i PFFLAGS=${FFLAGS}' \
+ -i ${mkfile}
done
insinto /usr/share/doc/${P}/PARPACK
doins -r PARPACK/EXAMPLES
@@ -70,3 +78,11 @@ src_install() {
fi
}
+
+src_postinst() {
+ einfo
+ einfo "ARPACK has been compiled with internal LAPACK routines"
+ einfo "\"LDFLAGS=-llarpack\" is enough to link your applications"
+ einfo
+
+} \ No newline at end of file