aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2022-07-22 19:44:18 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-07-22 21:56:07 +0200
commitfb66f72d182b9fff1bad801eed85695bd3670188 (patch)
tree410450b99a670826af1cda218b0d94249de8a459
parentsci-physics/feynarts: new package, add 3.11 (diff)
downloadsci-fb66f72d182b9fff1bad801eed85695bd3670188.tar.gz
sci-fb66f72d182b9fff1bad801eed85695bd3670188.tar.bz2
sci-fb66f72d182b9fff1bad801eed85695bd3670188.zip
sci-physics/spheno: Fix toolchain gfortran
We should not call gfortran directly. Instead use `FC` provided by toolchain. Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/sci/pull/1161 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-physics/spheno/files/spheno-3.3.8-gfortran.patch40
-rw-r--r--sci-physics/spheno/spheno-3.3.8.ebuild8
2 files changed, 20 insertions, 28 deletions
diff --git a/sci-physics/spheno/files/spheno-3.3.8-gfortran.patch b/sci-physics/spheno/files/spheno-3.3.8-gfortran.patch
index 732c6c7ee..e4538e7c1 100644
--- a/sci-physics/spheno/files/spheno-3.3.8-gfortran.patch
+++ b/sci-physics/spheno/files/spheno-3.3.8-gfortran.patch
@@ -1,28 +1,18 @@
---- a/Makefile 2022-02-16 16:04:19.000000000 +0100
-+++ b/Makefile 2022-02-17 22:13:48.086482293 +0100
-@@ -3,10 +3,10 @@
- # cases NAG's nagfor, gfortran, g95, Lahey's lf95 and Intels ifort
- # Please uncomment the corresponding line
- # F90 = nagfor
--# F90 = gfortran
-+F90 = gfortran
- # F90 = g95
- # F90 = lf95
--F90 = ifort
-+#F90 = ifort
- Model = src
- version = 400.00
- bin/SPheno:
--- a/src/Makefile 2022-07-20 11:47:44.078639381 +0200
-+++ b/src/Makefile 2022-07-20 11:50:40.553222937 +0200
-@@ -23,8 +23,8 @@
++++ b/src/Makefile 2022-07-22 19:24:00.389938450 +0200
+@@ -9,10 +9,11 @@
+ # options for various compilers
+ #
- # gfortran
- ifeq (${F90},gfortran)
-- comp = -c -O -J${Mdir} -I${InDir}
-- LFlagsB = -O
-+ comp = -c -O -J${Mdir} -I${InDir} ${FFLAGS} ${FCFLAGS} ${CFLAGS}
-+ LFlagsB = -O ${LDFLAGS}
- endif
+-# Intels ifort, default in optimized mode
+-F90 = ifort
+-comp = -c -O -module ${Mdir} -I${InDir}
+-LFlagsB = -O
++
++# gentoo toolchain
++F90 = ${F90}
++comp = -c -O -J${Mdir} -I${InDir} ${FFLAGS} ${FCFLAGS} ${CFLAGS}
++LFlagsB = -O ${LDFLAGS}
- # g95
+ # Intels ifort, debug modus
+ ifeq (${F90},ifortg)
diff --git a/sci-physics/spheno/spheno-3.3.8.ebuild b/sci-physics/spheno/spheno-3.3.8.ebuild
index ef9ba6e97..21caf1019 100644
--- a/sci-physics/spheno/spheno-3.3.8.ebuild
+++ b/sci-physics/spheno/spheno-3.3.8.ebuild
@@ -3,12 +3,15 @@
EAPI=8
+inherit toolchain-funcs
+
MY_PN=SPheno
MY_P=${MY_PN}-${PV}
DESCRIPTION="SPheno stands for S(upersymmetric) Pheno(menology)"
HOMEPAGE="https://spheno.hepforge.org/"
SRC_URI="https://spheno.hepforge.org/downloads/?f=${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="all-rights-reserved"
RESTRICT="bindist mirror"
@@ -20,12 +23,11 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${P}-gfortran.patch )
-S="${WORKDIR}/${MY_P}"
-
src_compile() {
# single thread force needed since fortan mods depend on each other
export MAKEOPTS=-j1
- emake
+ F90=`tc-getFC`
+ emake F90="${F90}"
}
src_install() {