aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher (jlec) <jlec@j-schmitz.net>2009-03-22 12:04:40 +0100
committerJustin Lecher (jlec) <jlec@j-schmitz.net>2009-03-22 12:04:40 +0100
commitfc4b5d5512fe791004ed1d991c7f2cc64ef712ad (patch)
tree22bcf89a6ac34882111869e6c8813dd5518748fa
parentx11-libs/tr added (diff)
downloadsci-fc4b5d5512fe791004ed1d991c7f2cc64ef712ad.tar.gz
sci-fc4b5d5512fe791004ed1d991c7f2cc64ef712ad.tar.bz2
sci-fc4b5d5512fe791004ed1d991c7f2cc64ef712ad.zip
sys-devel/ucpp added
-rw-r--r--sys-devel/ucpp/ChangeLog10
-rw-r--r--sys-devel/ucpp/Manifest4
-rw-r--r--sys-devel/ucpp/files/tune.h.patch28
-rw-r--r--sys-devel/ucpp/metadata.xml8
-rw-r--r--sys-devel/ucpp/ucpp-1.3.ebuild37
5 files changed, 87 insertions, 0 deletions
diff --git a/sys-devel/ucpp/ChangeLog b/sys-devel/ucpp/ChangeLog
new file mode 100644
index 000000000..4ee7ce74f
--- /dev/null
+++ b/sys-devel/ucpp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-devel/ucpp
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*ucpp-1.3 (22 Mar 2009)
+
+ 22 Mar 2009; justin Lecher (jlec) <jlec@j-schmitz.net>
+ +files/tune.h.patch, +metadata.xml, +ucpp-1.3.ebuild:
+ initial checkin
+
diff --git a/sys-devel/ucpp/Manifest b/sys-devel/ucpp/Manifest
new file mode 100644
index 000000000..bfcbd687e
--- /dev/null
+++ b/sys-devel/ucpp/Manifest
@@ -0,0 +1,4 @@
+AUX tune.h.patch 723 RMD160 411f358400f0c0a8f813e25f580f69b22bf759d3 SHA1 022f30c77266c9b4c0773e9bdf54296503570971 SHA256 27bdbc0e81ba1c60b4f069b6a05eedb44445d4768b2a5808e53117a7ed7e7871
+DIST ucpp-1.3.tar.bz2 73958 RMD160 08f9ef1ada15c7451b7966733fb0a63bbe6b179a SHA1 12caf535986e3919d58c47ca35ae9ed4efaa1cf0 SHA256 d0a51c20040385b143f15fc08eefec6119773fb07232a14c08bbb49cb1c5f1fa
+EBUILD ucpp-1.3.ebuild 697 RMD160 a8f470f17e1200fb0a62dd48801e07cb0decce7d SHA1 b2f90239f517f961c82894ed819908023a4ad55e SHA256 5763741d0ee5a37da1710f2d23229c681ebd25d45ae589359372804972b59528
+MISC metadata.xml 215 RMD160 bc9c07aa91f2f175542244e4e4522a73558210a1 SHA1 facb283386de1c0b6b938cdcd4dde04d1694298b SHA256 13f32353652adbd3d934d41381cfc2cacc9e1127c508cebc73806cc1026ee80c
diff --git a/sys-devel/ucpp/files/tune.h.patch b/sys-devel/ucpp/files/tune.h.patch
new file mode 100644
index 000000000..7455dd242
--- /dev/null
+++ b/sys-devel/ucpp/files/tune.h.patch
@@ -0,0 +1,28 @@
+--- tune.h 2008-10-01 19:15:41.000000000 +0200
++++ tune.h.new 2009-03-22 11:59:42.000000000 +0100
+@@ -281,10 +281,10 @@
+ *
+ * If you want no standard assertion, define STD_ASSERT to 0.
+ */
+-/*
++
+ #define STD_ASSERT "cpu(i386)", "machine(i386)", "system(unix)", \
+ "system(freebsd)"
+-*/
++
+
+ /* ====================================================================== */
+ /*
+@@ -293,10 +293,10 @@
+ * Each string must be either "name" or "name=token-list". If you want
+ * no predefined macro, define STD_MACROS to 0.
+ */
+-/*
++
+ #define STD_MACROS "__FreeBSD=4", "__unix", "__i386", \
+ "__FreeBSD__=4", "__unix__", "__i386__"
+-*/
++
+
+ /* ====================================================================== */
+ /*
diff --git a/sys-devel/ucpp/metadata.xml b/sys-devel/ucpp/metadata.xml
new file mode 100644
index 000000000..efb490d78
--- /dev/null
+++ b/sys-devel/ucpp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-devel/ucpp/ucpp-1.3.ebuild b/sys-devel/ucpp/ucpp-1.3.ebuild
new file mode 100644
index 000000000..841b2c0fb
--- /dev/null
+++ b/sys-devel/ucpp/ucpp-1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A quick and light preprocessor, but anyway fully compliant to C99"
+HOMEPAGE="http://code.google.com/p/ucpp/"
+SRC_URI="http://ucpp.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/tune.h.patch
+}
+
+src_compile() {
+ emake \
+ FLAGS="${CFLAGS} -DSTAND_ALONE" \
+ CC=$(tc-getCC) \
+ STAND_ALONE="-DSTAND_ALONE"
+}
+
+src_install() {
+ dolib.a lib${PN}.a || die
+ doman ${PN}.1 || die
+ dobin ${PN} || die
+ dodoc README
+}