aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-04-21 19:40:12 -0600
committerChristoph Junghans <ottxor@gentoo.org>2013-04-21 19:40:12 -0600
commitff203adb5ad7adf5665409404fe79d1867bc5e49 (patch)
tree214f5443b4f4a7d8bbb9ff3c7860f5220c6699ae
parentsync with gx86 (diff)
parentMerge pull request #63 from ryao/lustre (diff)
downloadsci-ff203adb5ad7adf5665409404fe79d1867bc5e49.tar.gz
sci-ff203adb5ad7adf5665409404fe79d1867bc5e49.tar.bz2
sci-ff203adb5ad7adf5665409404fe79d1867bc5e49.zip
Merge ssh://github.com/gentoo-science/sci
-rw-r--r--sci-libs/trilinos/ChangeLog3
-rw-r--r--sci-libs/trilinos/Manifest1
-rw-r--r--sci-libs/trilinos/files/trilinos-11.0.3-fix-install-paths.patch76
-rw-r--r--sci-libs/trilinos/trilinos-11.0.3.ebuild127
-rw-r--r--sys-cluster/lustre/lustre-9999.ebuild10
5 files changed, 213 insertions, 4 deletions
diff --git a/sci-libs/trilinos/ChangeLog b/sci-libs/trilinos/ChangeLog
index 5461e6f6f..6c5b81bd9 100644
--- a/sci-libs/trilinos/ChangeLog
+++ b/sci-libs/trilinos/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 03 Apr 2013; Matthias Maier <tamiko@kyomu.43-1.org> trilinos-11.0.3.ebuild:
+ Version bump; correct install paths; fix prefix support
+
03 Mar 2013; Justin Lecher <jlec@gentoo.org> trilinos-10.10.1.ebuild:
Update to new qt deps names
diff --git a/sci-libs/trilinos/Manifest b/sci-libs/trilinos/Manifest
index 342ecff2c..32cc5b781 100644
--- a/sci-libs/trilinos/Manifest
+++ b/sci-libs/trilinos/Manifest
@@ -1 +1,2 @@
DIST trilinos-10.10.1-Source.tar.gz 94581166 SHA256 f28cd9ce32dc0e1dde6f0f2ff144ca86ba220799376bb3b5606dde749a6b4d30 SHA512 8d35b8c7e3ab3caa772d594ff1d012f75a0de4e70d7439e76c8db3ea94736fbdf3af508f1764c5d63df9414e651b9fd6659fcce130b7b6d9a9d22f77442627e6 WHIRLPOOL 804db8a0f44084b540f2ee0197e8ab15aaf2061a1c036123c9706910b536f647805068bbaa940ff921b11061b369ad031cdd6afe5417828cc461997a75385880
+DIST trilinos-11.0.3-Source.tar.gz 107076534 SHA256 4e9d68d23eac1076200a3224fab14cd3a63a77574f1456d1bff931b2887b5c63 SHA512 9c449c6f9b2bc6346867bc68c29f83edc81790889d483129a98d149e1ff79d32b13310e8fcb3b4412b2f722b5d7efedd2a65f2e882b38629d4a1d50ecfc9783f WHIRLPOOL 7af72bd92cb4aa72ec8d98065570c9af2cc04187b7b2cce5d701e25d2c25efdc8826a4359b035008b8cf086026b88126bcfa6e807cac4f18d5fb745a48568f10
diff --git a/sci-libs/trilinos/files/trilinos-11.0.3-fix-install-paths.patch b/sci-libs/trilinos/files/trilinos-11.0.3-fix-install-paths.patch
new file mode 100644
index 000000000..8ec15a47b
--- /dev/null
+++ b/sci-libs/trilinos/files/trilinos-11.0.3-fix-install-paths.patch
@@ -0,0 +1,76 @@
+--- a/cmake/tribits/package_arch/TribitsGlobalMacros.cmake 2013-04-03 11:00:54.342539245 +0200
++++ b/cmake/tribits/package_arch/TribitsGlobalMacros.cmake 2013-04-03 11:04:30.283837064 +0200
+@@ -209,26 +209,6 @@
+ ADVANCED_SET(${PROJECT_NAME}_LINK_SEARCH_START_STATIC OFF CACHE BOOL
+ "If on, then the properter LINK_SEARCH_START_STATIC will be added to all executables." )
+ ENDIF()
+-
+- ADVANCED_SET(${PROJECT_NAME}_INSTALL_INCLUDE_DIR "include"
+- CACHE PATH
+- "Location where the headers will be installed. If given as a relative path, it will be relative to ${CMAKE_INSTALL_PREFIX}. If given as an absolute path, it will used as such. Default is 'include'"
+- )
+-
+- ADVANCED_SET(${PROJECT_NAME}_INSTALL_LIB_DIR "lib"
+- CACHE PATH
+- "Location where the libraries will be installed. If given as a relative path, it will be relative to ${CMAKE_INSTALL_PREFIX}. If given as an absolute path, it will used as such. Default is 'lib'"
+- )
+-
+- ADVANCED_SET(${PROJECT_NAME}_INSTALL_RUNTIME_DIR "bin"
+- CACHE PATH
+- "Location where the runtime DLLs and designated programs will be installed. If given as a relative path, it will be relative to ${CMAKE_INSTALL_PREFIX}. If given as an absolute path, it will used as such. Default is 'bin'"
+- )
+-
+- ADVANCED_SET(${PROJECT_NAME}_INSTALL_EXAMPLE_DIR "example"
+- CACHE PATH
+- "Location where assorted examples will be installed. If given as a relative path, it will be relative to ${CMAKE_INSTALL_PREFIX}. If given as an absolute path, it will used as such. Default is 'example'"
+- )
+
+ IF ("${${PROJECT_NAME}_INSTALL_LIBRARIES_AND_HEADERS_DEFAULT}" STREQUAL "")
+ # Assume the TriBITS project wants to install headers and libraries by default
+--- a/cmake/tribits/package_arch/TribitsPackageWritePackageConfig.cmake 2012-11-12 14:58:00.000000000 +0100
++++ b/cmake/tribits/package_arch/TribitsPackageWritePackageConfig.cmake 2012-11-12 14:42:47.000000000 +0100
+@@ -367,7 +367,7 @@
+
+ INSTALL(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/CMakeFiles/${PACKAGE_NAME}Config_install.cmake
+- DESTINATION "${${PROJECT_NAME}_INSTALL_LIB_DIR}/cmake/${PACKAGE_NAME}"
++ DESTINATION "${${PROJECT_NAME}_INSTALL_CONFIG_DIR}/${PACKAGE_NAME}"
+ RENAME ${PACKAGE_NAME}Config.cmake
+ )
+
+@@ -563,7 +563,7 @@
+ IF(HAS_INSTALL_TARGETS)
+ INSTALL(
+ EXPORT ${PROJECT_NAME}
+- DESTINATION "${${PROJECT_NAME}_INSTALL_LIB_DIR}/cmake/${PROJECT_NAME}"
++ DESTINATION "${${PROJECT_NAME}_INSTALL_CONFIG_DIR}/${PROJECT_NAME}"
+ FILE ${PROJECT_NAME}Targets.cmake
+ )
+ # Import the targets in applications.
+@@ -589,7 +589,7 @@
+
+ INSTALL(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}Config_install.cmake
+- DESTINATION "${${PROJECT_NAME}_INSTALL_LIB_DIR}/cmake/${PROJECT_NAME}"
++ DESTINATION "${${PROJECT_NAME}_INSTALL_CONFIG_DIR}/${PROJECT_NAME}"
+ RENAME ${PROJECT_NAME}Config.cmake
+ )
+
+@@ -632,7 +632,7 @@
+
+ INSTALL(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}ConfigVersion.cmake
+- DESTINATION "${${PROJECT_NAME}_INSTALL_LIB_DIR}/cmake/${PROJECT_NAME}"
++ DESTINATION "${${PROJECT_NAME}_INSTALL_CONFIG_DIR}/${PROJECT_NAME}"
+ )
+
+ ENDFUNCTION()
+--- a/packages/fei/base/CMakeLists.txt 2012-11-12 14:05:18.000000000 +0100
++++ b/packages/fei/base/CMakeLists.txt 2012-11-12 14:05:18.000000000 +0100
+@@ -54,5 +54,5 @@
+ )
+
+ INSTALL(FILES ${HEADERS} DESTINATION
+- ${CMAKE_INSTALL_PREFIX}/include)
++ ${${PROJECT_NAME}_INSTALL_INCLUDE_DIR})
+
diff --git a/sci-libs/trilinos/trilinos-11.0.3.ebuild b/sci-libs/trilinos/trilinos-11.0.3.ebuild
new file mode 100644
index 000000000..209b1487d
--- /dev/null
+++ b/sci-libs/trilinos/trilinos-11.0.3.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+inherit cmake-utils
+
+DESCRIPTION="Scientific library collection for large scale problems"
+HOMEPAGE="http://trilinos.sandia.gov/"
+SRC_URI="${P}-Source.tar.gz"
+SRC_PAGE="11.0"
+
+SLOT="0"
+LICENSE="BSD LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="arprec boost cuda hdf5 hwloc netcdf qd qt scotch taucs tbb test umfpack zlib"
+
+RESTRICT="fetch"
+
+RDEPEND="virtual/blas
+ virtual/lapack
+ virtual/mpi
+ >=sci-libs/scalapack-2
+ arprec? ( sci-libs/arprec )
+ boost? ( dev-libs/boost )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-3.2 )
+ hdf5? ( sci-libs/hdf5[mpi] )
+ hwloc? ( sys-apps/hwloc )
+ netcdf? ( sci-libs/netcdf )
+ qd? ( sci-libs/qd )
+ qt? ( >=x11-libs/qt-gui-4.5 )
+ scotch? ( sci-libs/scotch[mpi] )
+ taucs? ( sci-libs/taucs )
+ tbb? ( dev-cpp/tbb )
+ umfpack? ( sci-libs/umfpack )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-Source"
+
+pkg_nofetch() {
+ einfo "Sandia requires that you register to the site in order to download Trilinos."
+ einfo "Please download ${SRC_URI} from:"
+ einfo "http://trilinos.sandia.gov/download/trilinos-${SRC_PAGE}.html"
+ einfo "and move it to ${DISTDIR}"
+}
+
+function trilinos_alternatives {
+ alt_dirs=""
+ for d in $(pkg-config --libs-only-L $1); do
+ alt_dirs="${alt_dirs};${d:2}"
+ done
+ arg="-D${2}_LIBRARY_DIRS=${alt_dirs:1}"
+ mycmakeargs+=(
+ $arg
+ )
+
+ alt_libs=""
+ for d in $(pkg-config --libs-only-l $1); do
+ alt_libs="${alt_libs};${d:2}"
+ done
+ arg="-D${2}_LIBRARY_NAMES=${alt_libs:1}"
+ mycmakeargs+=(
+ $arg
+ )
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-install-paths.patch
+}
+
+src_configure() {
+ CMAKE_BUILD_TYPE="release"
+
+ mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DTrilinos_ENABLE_ALL_PACKAGES=ON
+
+ -DTrilinos_INSTALL_BIN_DIR="bin"
+ -DTrilinos_INSTALL_CONFIG_DIR="$(get_libdir)/cmake"
+ -DTrilinos_INSTALL_INCLUDE_DIR="include/trilinos"
+ -DTrilinos_INSTALL_LIB_DIR="$(get_libdir)"
+ -DTrilinos_INSTALL_EXAMPLE_DIR="share/trilinos/example"
+
+ # Tests
+ $(cmake-utils_use test Trilinos_ENABLE_TESTS)
+
+ # Mandatory dependencies
+ -DTPL_ENABLE_BinUtils=ON
+ -DTPL_ENABLE_MPI=ON
+ -DTPL_ENABLE_BLAS=ON
+ -DTPL_ENABLE_LAPACK=ON
+ -DTPL_ENABLE_BLACS=ON
+ -DTPL_ENABLE_SCALAPACK=ON
+ -DTrilinos_EXTRA_LINK_FLAGS="-lmpi -lmpi_cxx"
+
+ # Optional dependencies
+ $(cmake-utils_use arprec TPL_ENABLE_ARPREC)
+ $(cmake-utils_use boost TPL_ENABLE_Boost)
+ $(cmake-utils_use boost TPL_ENABLE_BoostLib)
+ $(cmake-utils_use cuda TPL_ENABLE_CUDA)
+ $(cmake-utils_use hdf5 TPL_ENABLE_HDF5)
+ $(cmake-utils_use hwloc TPL_ENABLE_HWLOC)
+ $(cmake-utils_use netcdf TPL_ENABLE_Netcdf)
+ $(cmake-utils_use qd TPL_ENABLE_QD)
+ $(cmake-utils_use qt TPL_ENABLE_QT)
+ $(cmake-utils_use scotch TPL_ENABLE_Scotch)
+ $(cmake-utils_use taucs TPL_ENABLE_TAUCS)
+ $(cmake-utils_use tbb TPL_ENABLE_TBB)
+ $(cmake-utils_use umfpack TPL_ENABLE_UMFPACK)
+ $(cmake-utils_use zlib TPL_ENABLE_Zlib)
+ )
+
+ # Scotch libraries
+ if use scotch; then
+ mycmakeargs+=( -DScotch_INCLUDE_DIRS="${EPREFIX}/usr/include/scotch" )
+ fi
+
+ # Add BLAS libraries
+ trilinos_alternatives blas BLAS
+ trilinos_alternatives lapack LAPACK
+ trilinos_alternatives scalapack SCALAPACK
+ trilinos_alternatives scalapack BLACS
+
+ mycmakeargs+=( -DBLACS_INCLUDE_DIRS="${EPREFIX}/usr/include/blacs" )
+
+ cmake-utils_src_configure
+}
diff --git a/sys-cluster/lustre/lustre-9999.ebuild b/sys-cluster/lustre/lustre-9999.ebuild
index a40cd653f..875a197bf 100644
--- a/sys-cluster/lustre/lustre-9999.ebuild
+++ b/sys-cluster/lustre/lustre-9999.ebuild
@@ -25,8 +25,8 @@ DEPEND="
readline? ( sys-libs/readline )
tcpd? ( sys-apps/tcp-wrappers )
server? (
- sys-kernel/spl
- sys-fs/zfs-kmod
+ >=sys-kernel/spl-0.6.1
+ >=sys-fs/zfs-kmod-0.6.1
sys-fs/zfs
)
"
@@ -100,8 +100,10 @@ src_prepare() {
src_configure() {
local myconf
if use server; then
- myconf+="${myconf} --with-zfs=\"${EPREFIX}/usr/src/zfs\""
- myconf+="${myconf} --with-spl=\"${EPREFIX}/usr/src/spl\""
+ SPL_PATH=$(basename $(echo "${EROOT}usr/src/spl-"*)) \
+ myconf="${myconf} --with-spl=\"${EROOT}usr/src/${SPL_PATH}\""
+ ZFS_PATH=$(basename $(echo "${EROOT}usr/src/zfs-"*)) \
+ myconf="${myconf} --with-zfs=\"${EROOT}usr/src/${ZFS_PATH}\""
fi
econf \
${myconf} \